Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Eigrp router id configuration for 2 difference eigrp process id routing redistribution

Hi All,

   I need to setup a router configured with eigrp process id 2 on WAN interface and Internal LAN interface configured with Eigrp process id 1. since they are running in difference process id, i need to configure mutual redistribution between process id 1 and process id 2 in order for outside WAN network to talk to inside LAN network.

But I am confused with the process eigrp process id configuration. Can i configure the same router id into 2 difference eigrp process id and redistribute them to each other ? or i should configure 2 loopback interface, assigned one of the loopback ip to process id 1 as eigrp router id and another loopback interface assigned as eigrp router id for eigrp process id 2? will it cause any issue or make any difference?

Thanks a lots for the reply in advanced

Option 1:

interface loopback 0

ip address 172.16.16.1

router eigrp 1

network 10.1.1.0 0.0.0.255

no auto-summary

eigrp router-id 172.16.16.1

redistribute eigrp 2

router eigrp 2

network 192.168.1 0.0.0.255

no auto-summary

eigrp router-id 172.16.16.1

redistribute eigrp 1

Option 2:

interface loopback 0

ip address 172.16.16.1

interface loopback 0

ip address 172.16.16.2

router eigrp 1

network 10.1.1.0 0.0.0.255

no auto-summary

eigrp router-id 172.16.16.1

redistribute eigrp 2

router eigrp 2

network 192.168.1 0.0.0.255

no auto-summary

eigrp router-id 172.16.16.2

redistribute eigrp 1

Regards,

Timothy72

5 REPLIES

Eigrp router id configuration for 2 difference eigrp process id

Edward,

I don't think you'll have a problem using the same router-id for both processes. I labbed this up and I was able to get routes to both sides of the link using a router id of 1.1.1.1. The routes came in fine, and I don't believe you'll have an issue. The only time that I think there's a problem, and I'd have to lab this up, is when you are trying to establish a neighborship with a router that has the same router-id as yours. It's recommended that you have a different router id per router, but I don't believe it's per process.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Silver

Eigrp router id configuration for 2 difference eigrp process id

Timothy72

I have experienced the situation in a customer network where two routers were using the same router ID. I can certainly say that it did create problems in which prefixes advertised by router A were not accepted by router B. So very clearly different routers require different router ID.

I have not experienced the situation with 2 processes on the same router using the same router ID and so can not speak from experience about this. But based on my experience I would be more comfortable with your option 2 where each process has a unique router ID.

HTH

Rick

Re: Eigrp router id configuration for 2 difference eigrp process

hello

I am aware there is also way to prohibit advertising redistributed routes in a eigrp routing domain by setting the same router ids to each peer. so given this I would have to agree with Richard a possible routing issue would arise in you're scenario also

 

example:
router eigrp xx
eigtp router -id 11.11.11.11 ( same router id on each router)

When routes are redistributed into eigrp, the external routes are tagged with the router-id of the router that
originated the route/s and if the recieving router sees its own router id in the update it rejects the route

 


Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hello, there is an issue

Hello, there is an issue regarding duplicate router-id in EIGRP  but it appears when 2 routers in the same AS have the same router-id and redistribution is used (http://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/18685-eigrp-dup-id.html)

in our case i agree with John Blakley that this should work

Hall of Fame Super Silver

Since it has been several

Since it has been several months since the original question came up, I wonder if Timothy72 can tell us if he implemented it and if so what results did he get?

 

HTH

 

Rick

1512
Views
0
Helpful
5
Replies