Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP Routing Implementation

Hello everyone,

I have the following case:

Branch Router (R1) connected to Central Router (R2) via the following links:

1. DLL ? 128 Kbps (L1)

2. MPLS Tunnel ? 128 Kbps (L2)

I have implemented EIGRP with the following policy:

a. L1 ? primary link (delay 100)

a. L2 ? secondary link ? only if the primary fails (delay 250)

Everything is OK.

Now I am think how will be possible to balance some traffic between those 2 links as follow:

Branch Network: 192.168.0.0/24

R1

L1

R2

LAN1 ? 192.168.10.0/24

Branch Network: 192.168.0.0/24

R1

L2

R2

LAN2 ? 192.168.11.0/24

And in case L1 fails all traffic to pass on L2 and vice versa.

Any ideas how I should implement this scenario on R1 and R2?

Thank you,

Florin

3 REPLIES
Hall of Fame Super Bronze

Re: EIGRP Routing Implementation

The first thing you need to do is remove the delay from both links so R1 can see both R2's LANs via both links.

So from R1 you should something like this:

R1#show ip route eigrp

D 192.168.10.0/24 [90/2195456] via 192.168.1.2, 00:00:46, Serial1/0

[90/2195456] via 192.168.1.6, 00:00:46, Serial2/0

D 192.168.11.0/24 [90/2195456] via 192.168.1.2, 00:00:05, Serial1/0

[90/2195456] via 192.168.1.6, 00:00:05, Serial2/0

Now, you want R1 to reach 192.168.11.0 via 192.168.1.2 and 192.168.10.0 via 192.168.1.6, then you do the following:

router eigrp 1

offset-list Subnet10 in 2195456 Serial1/0

offset-list Subnet11 in 2195456 Serial2/0

ip access-list standard Subnet10

permit 192.168.10.0 0.0.0.255

ip access-list standard Subnet11

permit 192.168.11.0 0.0.0.255

Now, you have in R1's routing table:

R1#show ip route eigrp

D 192.168.10.0/24 [90/2195456] via 192.168.1.6, 00:01:07, Serial2/0

D 192.168.11.0/24 [90/2195456] via 192.168.1.2, 00:01:07, Serial1/0

If I bring one of the interfaces down:

R1(config)#int s2/0

R1(config-if)#shut

R1(config-if)#

*Aug 11 18:48:06.215: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.1.6 (Serial2/0) is down: interface down

*Aug 11 18:48:08.203: %LINK-5-CHANGED: Interface Serial2/0, changed state to administratively down

*Aug 11 18:48:09.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down

R1(config-if)#do show ip route eigrp

D 192.168.10.0/24 [90/4390912] via 192.168.1.2, 00:00:35, Serial1/0

D 192.168.11.0/24 [90/2195456] via 192.168.1.2, 00:02:00, Serial1/0

Therefore, R1 is taken care of - however with R2 the situation is different since you have to alter routing based on the source and dynamic routing protocols can only alter routing based on the destination. On R2, you need to use Policy Based Routing (PBR).

R2's routing table

R2#show ip route eigrp

D 192.168.0.0/24 [90/2195456] via 192.168.1.1, 00:05:08, Serial2/0

[90/2195456] via 192.168.1.5, 00:05:08, Serial3/0

PBR configuration:

ip prefix-list Subnet10 seq 5 permit 192.168.10.0/24

!

ip prefix-list Subnet11 seq 5 permit 192.168.10.0/24

!

route-map Subnet10 permit 10

match ip address prefix-list Subnet10

set ip next-hop 192.168.1.5

!

route-map Subnet11 permit 10

match ip address prefix-list Subnet11

set ip next-hop 192.168.1.1

interface Ethernet0/0

ip address 192.168.10.1 255.255.255.0

ip policy route-map Subnet10

!

interface Ethernet1/0

ip address 192.168.11.1 255.255.255.0

ip policy route-map Subnet11

Now, we verify it works and turn debug on R2 and ping from a device behind R2 from both subnets 192.168.10.0 and 192.168.11.0

From subnet 192.168.10.0

*Aug 11 19:00:04.311: IP: tableid=0, s=192.168.10.254 (Ethernet0/0), d=192.168.0.1 (Serial2/0), routed via RIB

*Aug 11 19:00:04.311: IP: s=192.168.10.254 (Ethernet0/0), d=192.168.0.1 (Serial2/0), g=192.168.1.1, len 100, forward

*Aug 11 19:00:04.311: ICMP type=8, code=0

*Aug 11 19:00:04.331: IP: tableid=0, s=192.168.0.1 (Serial2/0), d=192.168.10.254 (Ethernet0/0), routed via RIB

From subnet 192.168.11.0

*Aug 11 19:00:15.415: IP: tableid=0, s=192.168.11.254 (Ethernet0/0), d=192.168.0.1 (Serial3/0), routed via RIB

*Aug 11 19:00:15.415: IP: s=192.168.11.254 (Ethernet0/0), d=192.168.0.1 (Serial3/0), g=192.168.1.5, len 100, forward

*Aug 11 19:00:15.415: ICMP type=8, code=0

*Aug 11 19:00:15.431: IP: tableid=0, s=192.168.0.1 (Serial3/0), d=192.168.11.254 (Ethernet1/0), routed via RIB

HTH,

New Member

Re: EIGRP Routing Implementation

Hello,

First of all, thank you for you answer.

1. For configurations done on R1 I fully understand and is the correct approach.

2. For the configurations on R2 I have some questions:

a. What?s happening with the router performance (7206VXR with NPE-G1) when enable BPR (base on source) running for 100 Branches?

b. What?s happening if I will have multiple R1 connected to R2, for example:

BranchA Network: 192.168.0.0/24

R1A

L1

R2

LAN1 - 192.168.10.0/24

BranchA Network: 192.168.0.0/24

R1A

L2

R2

LAN2 - 192.168.11.0/24

BranchB Network: 192.168.5.0/24

R1B

L1

R2

LAN1 - 192.168.10.0/24

BranchB Network: 192.168.5.0/24

R1B

L2

R2

LAN2 - 192.168.11.0/24

Best regards,

Florin

Hall of Fame Super Bronze

Re: EIGRP Routing Implementation

You can enable 'Fast-Switched Policy Routing'

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hirp_c/ch20/piconfig.htm#wp1001538

I'm afraid PBR won't provide load-balancing for you. The best it can offer is failover to a secondary next-hop by inserting another next-hop ip address in the set ip next-hop command under the route-map.

The link I provided above explains it.

105
Views
5
Helpful
3
Replies
CreatePlease to create content