Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EIGRP Static route pointing to NULL 0

Hello Everyone,

I was just going through one of the labs in EIGRP in which I created two static routes both pointing to Null0.

However I observed that one of them got advertised and the other didn't.

R3#sh run | sec ip rou      ##router on which static route was created
ip route 11.0.0.0 255.0.0.0 Null0
ip route 55.55.55.0 255.255.255.0 Null0

 

R2#sh ip route    ###the neighbor router on which one of the static route was advertied but not the other.
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 192.168.12.1, 00:05:37, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/409600] via 192.168.23.3, 00:05:29, FastEthernet0/1
C    192.168.23.0/24 is directly connected, FastEthernet0/1
D    11.0.0.0/8 [90/281600] via 192.168.23.3, 00:05:29, FastEthernet0/1

 

 

Can anyone plz have a look and throw some light.

Thanks

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Thank you for posting the

Thank you for posting the configuration of both routers. It does make clear that there is not any filtering of routes on either router.

 

I believe that this behavior reflects the use of the statement network 0.0.0.0 under router EIGRP. There are two networks associated with interface Null 0 and EIGRP is picking up only one of them. I am not clear whether it is matching on the first one in the configuration or on the lowest numerical value. I do not believe that it is a question of classful vs classless behavior. I believe that if you were to change the static routes to this that the behavior would be the same

ip route 11.11.11.0 255.255.255.0 Null0
ip route 55.0.0.0 255.0.0.0 Null0

 

It would also be interesting to see what happens if you add network statements for both networks under router EIGRP

router eigrp 100

network 11.0.0.0

network 55.0.0.0

note that I am suggesting adding these to the existing network 0.0.0.0 and am not suggesting changing or eliminating it. Though it would also be interesting to see the results if you remove network 0.0.0.0 and put in network statements for the specific networks that you want to be advertised.

 

HTH

 

Rick

Hello.That is (probably)

Hello.

That is (probably) because of bug in 12.4 IOS, that is not putting "classless" prefixes into EIGRP topology, unless you have any other classless prefix already available (in RIB).

11.0.0.0/8 is a classful prefix; 55.55.55.0/24 is "classless" prefix.

 

13 REPLIES

Mudasir,Plz show your Eigrp

Mudasir,

Plz show your Eigrp  config on R3# most probably here is the problem.

Actually two possible reasons:

1) advertise route with wrong mask

2) Distribute-list  is filtering the route

 

HTH

Kazim Abbas

 

"Don't forget to select correct answer and rate for helpful posts"

New Member

 Thanks Kazim for the reply

 

Thanks Kazim for the reply.

The Eigrp config on R3 is as:

R3#sh run | section ei
router eigrp 1
 network 0.0.0.0
 no auto-summary

Actually this problem created some more confusions  is it possible that only classful addresses get redistributed automatically in Eigrp and not classless,and,

what will be  the case if these addresses don't exist on any physical interface or loopback.

Hope u got my point.

Hello.There is a difference

Hello.

There is a difference in behavior on 12.4 and 15.x IOSs.

In 15.2 all the networks (in you case) would be put into eigrp toppology.

But when (on 12.4(15)T13) I created loopback with 55.1.1.1/32 on the router, it started advertising 55.55.55.0/24 prefix.

I would say it looks like a bug (or a feature) on old IOSs.

New Member

 Thanks Vasilii for the reply

 

Thanks Vasilii for the reply,

I guess so....the issue might be with the new and old versions of ios.

Hall of Fame Super Silver

Would you post the output of

Would you post the output of show ip interface brief from R3? It might also be helpful if you would post the output of show ip route from R3.

 

HTH

 

Rick

New Member

 Hey Rich plz have a look: R3

 

Hey Rich plz have a look:

 

R3#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            192.168.23.3    YES manual up                    up
FastEthernet1/0            192.168.13.3    YES manual up                    up
Loopback0                  3.3.3.3         YES manual up                    up

========================================================

 

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    192.168.12.0/24 [90/284160] via 192.168.13.1, 00:04:59, FastEthernet1/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/156160] via 192.168.13.1, 00:04:59, FastEthernet1/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/409600] via 192.168.23.2, 00:04:59, FastEthernet0/1
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     55.0.0.0/24 is subnetted, 1 subnets
S       55.55.55.0 is directly connected, Null0
C    192.168.23.0/24 is directly connected, FastEthernet0/1
S    11.0.0.0/8 is directly connected, Null0

==============================================

 

Thanks

Hall of Fame Super Silver

Thank you for the additional

Thank you for the additional information. What I find interesting is that R2 sees the route as EIGRP internal route. If it were redistributed it would be EIGRP external. So it looks like EIGRP has matched 11.0.0.0 with your network statement. Does R3 use the network 0.0.0.0 similar to what you show for R2?

 

To understand what is going on and why the 55.55.55.0 is not advertised we may need to see more of the config of R3 and perhaps also of R2.

 

HTH

 

Rick

New Member

Hello,On R3 there is no

Hello,

On R3 there is no filtering or any such thing.

plz find the config of R2:

==

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!

!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 mac-address c200.04ec.2222
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 mac-address c200.04ec.2100
 ip address 192.168.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 network 0.0.0.0
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

============================================

Also on R3:

=====

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!

!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 mac-address c200.04ec.3333
 ip address 192.168.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 mac-address c200.04ec.3100
 ip address 192.168.13.3 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 100
 network 0.0.0.0
 no auto-summary
!
ip classless
ip route 11.0.0.0 255.0.0.0 Null0
ip route 55.55.55.0 255.255.255.0 Null0
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

 

Thanks

Hall of Fame Super Silver

Thank you for posting the

Thank you for posting the configuration of both routers. It does make clear that there is not any filtering of routes on either router.

 

I believe that this behavior reflects the use of the statement network 0.0.0.0 under router EIGRP. There are two networks associated with interface Null 0 and EIGRP is picking up only one of them. I am not clear whether it is matching on the first one in the configuration or on the lowest numerical value. I do not believe that it is a question of classful vs classless behavior. I believe that if you were to change the static routes to this that the behavior would be the same

ip route 11.11.11.0 255.255.255.0 Null0
ip route 55.0.0.0 255.0.0.0 Null0

 

It would also be interesting to see what happens if you add network statements for both networks under router EIGRP

router eigrp 100

network 11.0.0.0

network 55.0.0.0

note that I am suggesting adding these to the existing network 0.0.0.0 and am not suggesting changing or eliminating it. Though it would also be interesting to see the results if you remove network 0.0.0.0 and put in network statements for the specific networks that you want to be advertised.

 

HTH

 

Rick

New Member

 Thanks for the suggestions

 

Thanks for the suggestions,

When i issued network commands on R3 for both the networks ,they got advertised on R2 keeping network 0.0.0.0 as it is.....

===

On R3

==

R3#sh run | sec eig
router eigrp 100
 network 11.0.0.0
 network 55.55.55.0 0.0.0.255
 network 0.0.0.0
 no auto-summary

=============

R2 Routing Table

===

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 192.168.12.1, 00:03:47, FastEthernet0/0
D    192.168.13.0/24 [90/284160] via 192.168.23.3, 00:03:49, FastEthernet0/1
                     [90/284160] via 192.168.12.1, 00:03:49, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/409600] via 192.168.23.3, 00:03:47, FastEthernet0/1
     55.0.0.0/24 is subnetted, 1 subnets
D       55.55.55.0 [90/281600] via 192.168.23.3, 00:03:48, FastEthernet0/1
C    192.168.23.0/24 is directly connected, FastEthernet0/1
D    11.0.0.0/8 [90/281600] via 192.168.23.3, 00:03:48, FastEthernet0/1

============================================================

Also when i removed network 0.0.0.0 from both the routers,it still were present in the routing tables:

==

R3#sh run | sec ei
router eigrp 100
 network 11.0.0.0
 network 55.55.55.0 0.0.0.255
 network 192.168.13.0
 network 192.168.23.0
 no auto-summary

===============================

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/412160] via 192.168.23.3, 00:02:24, FastEthernet0/1
D    192.168.13.0/24 [90/284160] via 192.168.23.3, 00:02:24, FastEthernet0/1
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     55.0.0.0/24 is subnetted, 1 subnets
D       55.55.55.0 [90/281600] via 192.168.23.3, 00:02:53, FastEthernet0/1
C    192.168.23.0/24 is directly connected, FastEthernet0/1
D    11.0.0.0/8 [90/281600] via 192.168.23.3, 00:02:54, FastEthernet0/1

==========================================================

New Member

 Now iam confused with the

 Now iam confused with the thing that why earlier 11.0.0.0 got advertised on R2 without the network command and not 55.55.55.0.

 

Thanks

Hello.That is (probably)

Hello.

That is (probably) because of bug in 12.4 IOS, that is not putting "classless" prefixes into EIGRP topology, unless you have any other classless prefix already available (in RIB).

11.0.0.0/8 is a classful prefix; 55.55.55.0/24 is "classless" prefix.

 

New Member

 Thanks Vasilii and Rick for

 

Thanks Vasilii and Rick for your help.

357
Views
0
Helpful
13
Replies