Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP Stub receiving Default Route

I have a lab where my EIGRP Stub router is receiving all routes int the network and not just a default route. Any suggestions?

13 REPLIES

Re: EIGRP Stub receiving Default Route

Hi,

The EIGRP stub feature is used to limit the scope of EIGRP query messages,

and to limit what routes a neighbor advertises.

Regards

Hitesh Vinzoda

New Member

Re: EIGRP Stub receiving Default Route

Any other suggestions? Can this be done? In the BSCI book it clearly states a default route can be substituted for the rest of the routes, but I understand what you have said.

Hall of Fame Super Silver

Re: EIGRP Stub receiving Default Route

Ryan

Configuring a router as EIGRP stub affects how the router reacts when it receives an EIGRP query and what the router will advertise. But configuring the router as EIGRP stub does not affect whether the router learns the full route table or only a default route. To accomplish what you want (the stub router learns only a default route from upstream) you must configure the upstream router to send only a default route. You can configure the upstream router with a distribute-list or with summary-address to achieve that the upstream router will only advertise a default route to the downstream stub router.

HTH

Rick

New Member

Re: EIGRP Stub receiving Default Route

Thank you Rick and Hitesh for helping me undterstand EIGRP Stub routing. I was able to get the default route in the Stub routing table using the summary address command. I am able to ping to the connected interface but not any interfaces or networks past that. Am I missing something about default routing?

New Member

Re: EIGRP Stub receiving Default Route

R2#sh ip route

Gateway of last resort is 172.16.12.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.12.0 is directly connected, Serial1

C 172.16.7.0 is directly connected, Loopback0

D* 0.0.0.0/0 [90/2681856] via 172.16.12.1, 00:05:25, Serial1

R2#

R2#

R2#

R2#ping 172.16.9.1 source s1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.9.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.12.2

.....

Success rate is 0 percent (0/5)

New Member

Re: EIGRP Stub receiving Default Route

R8#sh ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.16.0.0/24 is subnetted, 5 subnets

C 172.16.12.0 is directly connected, Serial1/0

D 172.16.15.0 [90/642560] via 172.16.9.2, 00:46:52, Serial1/2

C 172.16.9.0 is directly connected, Serial1/2

D 172.16.10.0 [90/1026560] via 172.16.9.2, 00:46:31, Serial1/2

D 172.16.7.0 [90/20640000] via 172.16.12.2, 00:06:09, Serial1/0

D* 0.0.0.0/0 is a summary, 00:41:46, Null0

R2 is the Stub and R8 the Distributiob Router

Hall of Fame Super Silver

Re: EIGRP Stub receiving Default Route

Ryan

The routing table in R2 seems to have a valid default route pointing to R8. R8 sees the ping destination of 172.16.9.0 as a connected subnet and sees the connected serial subnet to R2 and the route to R2's loopback interface. So it looks to me like that part of the routing for the ping from R2 should work. I wonder if there is some other issue in the config (perhaps an access list) or perhaps the ping destination address is not the address of the interface on R8 (in which case we would need to see the routing table of the router where the address is).

I do note that on the routing table of R8 the default route is a route to null0, which is a result of the summary address that you configured. Is R8 supposed to have a valid default route?

Perhaps if you provide some additional details (like router configs) we might better understand what the problem is.

HTH

Rick

New Member

Re: EIGRP Stub receiving Default Route

There are no access lists or any other configs besides routing and interface commands.

Here is the router config for R2:

hostname R2

!

interface Loopback0

ip address 172.16.7.1 255.255.255.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

ip address 172.16.12.2 255.255.255.0

!

interface TokenRing0

no ip address

shutdown

!

router eigrp 1

network 172.16.7.0 0.0.0.255

network 172.16.12.0 0.0.0.255

no auto-summary

eigrp stub connected summary

New Member

Re: EIGRP Stub receiving Default Route

And R8:

hostname R8

!

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface Serial1/0

ip address 172.16.12.1 255.255.255.0

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

clock rate 64000

!

interface Serial1/1

bandwidth 3000000

ip address 172.16.8.1 255.255.255.0

!

interface Serial1/2

bandwidth 1000000

ip address 172.16.9.1 255.255.255.0

clock rate 64000

!

interface Serial1/3

no ip address

shutdown

!

router eigrp 1

network 172.16.8.0 0.0.0.255

network 172.16.9.0 0.0.0.255

network 172.16.12.0 0.0.0.255

no auto-summary

New Member

Re: EIGRP Stub receiving Default Route

R8#sh ip int b

Ethernet0/0 unassigned YES NVRAM administratively down down

Serial1/0 172.16.12.1 YES NVRAM up up

Serial1/1 172.16.8.1 YES NVRAM down down

Serial1/2 172.16.9.1 YES NVRAM up up

New Member

Re: EIGRP Stub receiving Default Route

When I replace the sum address command with 172.16.0.0 255.255.0.0 I am able to ping out to remote network listed in R8s routing table. I have also tried using network 0.0.0.0 on both routers but it did not work. What do you think? Thanks in advance

New Member

Re: EIGRP Stub receiving Default Route

Any other possible suggestions?

Hall of Fame Super Silver

Re: EIGRP Stub receiving Default Route

Hello Ryan,

try to use

ip summary address eigrp 100 0.0.0.0 0.0.0.0 201

the way you are generating the default summary route on R8 may be overriding a legitimate default-route.

a default-route to null0 is a silent discarder of packets (waste bin)

Note:

Rick had noted this in his post I had just developed the argument.

Hope to help

Giuseppe

2010
Views
5
Helpful
13
Replies
CreatePlease to create content