cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1823
Views
0
Helpful
11
Replies

EIGRP TO BGP not working

mnoma
Level 1
Level 1

hi people 

cant reach my eigrp  network from bgp 

R1# sh run | se router eigrp
router eigrp 1
network 1.1.1.0 0.0.0.3
network 10.0.0.0
R1#

 

R2#sh run | s router eigrp
router eigrp 1
!
address-family ipv4 vrf VPN_A autonomous-system 1
redistribute bgp 100
network 10.0.0.0
exit-address-family
R2#

R2#sh running-config | section router bgp
router bgp 100
bgp log-neighbor-changes
neighbor 19.19.19.19 remote-as 100
neighbor 19.19.19.19 update-source Loopback0
!
address-family vpnv4
neighbor 19.19.19.19 activate
neighbor 19.19.19.19 send-community extended
exit-address-family
!
address-family ipv4 vrf VPN_A
redistribute eigrp 1
exit-address-family
R2#

 

RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast
Wed Jan 17 14:18:26.531 UTC
BGP router identifier 19.19.19.19, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 8
BGP NSR Initial initsync version 4 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf VPN_A)
*>i1.1.1.1/32 2.2.2.2 156160 100 0 ?
*>i10.1.2.0/24 2.2.2.2 0 100 0 ?
*> 10.19.20.0/24 0.0.0.0 0 32768 ?
*> 20.20.20.20/32 10.19.20.20 10752 32768 ?

RP/0/0/CPU0:XR1#ping vrf VPN_A 1.1.1.1
Wed Jan 17 14:30:52.740 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
RP/0/0/CPU0:XR1#

1 Accepted Solution

Accepted Solutions

Hello,

On R2, you are missing the EIGRP-to-BGP redistribution. Please configure the following on R2:

router bgp 10
  address-family ipv4 vrf VPN_A
    redistribute eigrp 1

Then give it another try :)

Best regards,
Peter

View solution in original post

11 Replies 11

Peter Paluch
Cisco Employee
Cisco Employee

Hi,

From the outputs you have shared, your XR1 is learning about the 1.1.1.1/32 network which I assume is located on R1. However, how about the path back from R1 to XR1? Does the R1 know the path back to the IP address used by XR1 when pinging 1.1.1.1? There are potential caveats:

  • Your R2's EIGRP is configured using redistribute bgp 100 without an explicit metric. As a matter of rule, redistribution from other protocols into EIGRP should be equipped with an explicit redistribution metric; there are some exceptions but for the sake of simplicity, I suggest configuring this redistribution as redistribute bgp 100 metric 100000 1 255 1 1500
  • If the network where XR1 is located is not injected into BGP, R1 is unlikely to learn about it. You may need to redistribute that network into BGP.
  • If the routing tables check out okay, we might need to verify the labels and the MPLS data plane.

Best regards,
Peter

made the changes  but stil  down 

 

 

router eigrp PE_CE
!
address-family ipv4 unicast vrf VPN_A autonomous-system 1
!
topology base
redistribute bgp 100 metric 100000 1 255 1 1500
exit-af-topology
network 10.0.0.0
exit-address-family
R2#

RP/0/0/CPU0:XR1#ping vrf VPN_A 1.1.1.1
Wed Jan 17 14:51:41.764 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
RP/0/0/CPU0:XR1#

If the network where XR1 is located is not injected into BGP, R1 is unlikely to learn about it. You may need to redistribute that network into BGP.

done

Hello,

We need to understand more about your topology.

  1. Can you post a diagram of your network that contains at least the PE and CE routers, and describes the IP networks used on PE/CE links and behind the CEs?
  2. Is it possible to provide full configurations of the PE routers from your scenario?
  3. Is it possible to provide full outputs of the following commands from the PE routers (on XR-based routers, please use the corresponding equivalents)?
    show ip route vrf VPN_A
    show bgp vpnv4 unicast vrf VPN_A
  4. What is the IP address used by XR1 when pinging 1.1.1.1?

Thank you!

Best regards,
Peter

R2#sh running-config
Building configuration...

Current configuration : 1986 bytes
!
! Last configuration change at 14:51:33 UTC Wed Jan 17 2018
!
version 15.2
no service timestamps debug uptime
no service timestamps log uptime
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
vrf definition VPN_A
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ipv6 address 2001::2:2:2:2/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
vrf forwarding VPN_A
ip address 10.1.2.2 255.255.255.0
duplex full
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
interface FastEthernet3/0
ip address 20.2.3.2 255.255.255.0
duplex full
ipv6 address 2001:20:2:3::2/64
!
interface FastEthernet4/0
ip address 20.2.4.2 255.255.255.0
duplex full
ipv6 address 2001:20:4:2::2/64
!
interface FastEthernet5/0
no ip address
shutdown
duplex full
!
interface FastEthernet6/0
no ip address
shutdown
duplex full
!
!
router eigrp PE_CE
!
address-family ipv4 unicast vrf VPN_A autonomous-system 1
!
topology base
redistribute bgp 100 metric 100000 1 255 1 1500
exit-af-topology
network 10.0.0.0
exit-address-family
!
router ospf 1
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 0
mpls ldp autoconfig
!
router bgp 100
bgp log-neighbor-changes
neighbor 19.19.19.19 remote-as 100
neighbor 19.19.19.19 update-source Loopback0
!
address-family vpnv4
neighbor 19.19.19.19 activate
neighbor 19.19.19.19 send-community extended
exit-address-family
!
address-family ipv4 vrf VPN_A
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

R2#

 

uilding configuration...
!! IOS XR Configuration 6.0.1
!! Last configuration change at Wed Jan 17 14:50:24 2018 by cisco
!
hostname XR1
cdp
vrf VPN_A
address-family ipv4 unicast
import route-target
100:1
!
export route-target
100:1
!
!
!
line console
exec-timeout 0 0
!
interface Loopback0
ipv4 address 19.19.19.19 255.255.255.255
ipv6 address 2001::19:19:19:19/128
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
cdp
vrf VPN_A
ipv4 address 10.19.20.19 255.255.255.0
ipv6 address 2001:10:19:20::19/64
!
interface GigabitEthernet0/0/0/1
ipv4 address 20.5.19.19 255.255.255.0
ipv6 address 2001:20:5:19::19/64
!
interface GigabitEthernet0/0/0/2
ipv4 address 20.6.19.19 255.255.255.0
ipv6 address 2001:20:6:19::19/64
!
router ospf 1
router-id 19.19.19.19
mpls ldp auto-config
area 0
interface Loopback0
!
interface GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2
!
!
!
router bgp 100
address-family vpnv4 unicast
!
neighbor 2.2.2.2
remote-as 100
update-source Loopback0
address-family vpnv4 unicast
!
!
vrf VPN_A
rd 100:1
address-family ipv4 unicast
redistribute eigrp 1
!
!
!
mpls ldp
router-id 19.19.19.19
!
router eigrp PE_CE
vrf VPN_A
address-family ipv4
autonomous-system 1
redistribute bgp 100
interface GigabitEthernet0/0/0/0
!
!
!
!
end

RP/0/0/CPU0:XR1#

 

R2# show ip route vrf VPN_A

Routing Table: VPN_A
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2662400] via 10.1.2.1, 00:39:17, FastEthernet1/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.2.0/24 is directly connected, FastEthernet1/0
L 10.1.2.2/32 is directly connected, FastEthernet1/0
B 10.19.20.0/24 [200/0] via 19.19.19.19, 00:37:58
20.0.0.0/32 is subnetted, 1 subnets
B 20.20.20.20 [200/10752] via 19.19.19.19, 00:37:38
R2#show bgp vpnv4 unicast vrf VPN_A
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf VPN_A)
*>i 10.19.20.0/24 19.19.19.19 0 100 0 ?
*>i 20.20.20.20/32 19.19.19.19 10752 100 0 ?
R2#

 

RP/0/0/CPU0:XR1#show ip route vrf VPN_A
Wed Jan 17 15:29:21.099 UTC

Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
U - per-user static route, o - ODR, L - local, G - DAGR, l - LISP
A - access/subscriber, a - Application route
M - mobile route, r - RPL, (!) - FRR Backup path

Gateway of last resort is not set

C 10.19.20.0/24 is directly connected, 02:19:41, GigabitEthernet0/0/0/0
L 10.19.20.19/32 is directly connected, 02:19:41, GigabitEthernet0/0/0/0
D 20.20.20.20/32 [90/10752] via 10.19.20.20, 00:38:32, GigabitEthernet0/0/0/0
RP/0/0/CPU0:XR1#show bgp vpnv4 unicast vrf VPN_A
Wed Jan 17 15:29:22.389 UTC
BGP router identifier 19.19.19.19, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 14
BGP NSR Initial initsync version 4 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf VPN_A)
*> 10.19.20.0/24 0.0.0.0 0 32768 ?
*> 20.20.20.20/32 10.19.20.20 10752 32768 ?

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:XR1#

 

 

Hello,

On R2, you are missing the EIGRP-to-BGP redistribution. Please configure the following on R2:

router bgp 10
  address-family ipv4 vrf VPN_A
    redistribute eigrp 1

Then give it another try :)

Best regards,
Peter

thanks Peter !
dont know how i overlooked that

Hi,

You are very much welcome! Agreed, I missed it at first, too :)

Glad you got it working!

Best regards,
Peter

mmanthe
Level 1
Level 1

Redistribution of any other protocol into EIGRP requires metrics (bandwidth, delay, reliability, load and MTU). I didn’t see any metrics in your redistribute (BGP) statement under your EIGRP process - nor did I see any reference to a route map or default metrics configured - unless I overlooked something. 

Hey Mike,

You're absolutely right - but here comes the exception I kind of skipped earlier.

In MPLS L3VPNs, when redistributing EIGRP routes into BGP, Cisco routers preserve the metric components using a set of extended BGP attributes attached to individual networks. When the reverse BGP-to-EIGRP redistribution is performed, and the BGP networks have the necessary attributes attached, EIGRP will reconstitute the original metrics using the values from the BGP communities automatically. In such case, it is not necessary to specify the redistribution metric explicitly. However, the original post does not even clarify the topology and it is not clear where the BGP routes come from, so definitely, specifying the redistribution metric is a good troubleshooting step at this point.

Best regards,
Peter

routes are coming fron eigrp in XR2vredistributed to BGP in XR1  then via mpls domain to R2  then redistributed back ro EIGRP 

Review Cisco Networking products for a $25 gift card