Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

eigrp to eigrp as route redistribution

I'm starting to confuse myself and I was wondering if you guys can have a look at this and help me out. Does this look right?

router eigrp 104

redistribute eigrp 100 route-map to-eigrp104

network 10.xx.x.xx 0.0.0.0

network 10.xx.x.xx 0.0.0.0

no auto-summary

!

router eigrp 100

redistribute eigrp 104 route-map to-eigrp100

network 10.0.0.0 0.255.255.255

no auto-summary

route-map to-eigrp104

match address list 101

!

route-map to-eigrp100

match address list 102

access-list 101 permit 10.xx.0.0

access-list 101 deny any any

!

access-list 102 permit 172.xx.0.0 0.0.255.255

access-list 102 permit 172.xx.0.0 0.0.255.255

access-list 102 permit 172.xx.0.0 0.0.255.255

access-list 102 permit 172.xx.0.0 0.0.255.255

access-list 102 deny any any

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: eigrp to eigrp as route redistribution

Brent

It would help us to know if this looks right if we knew more about your environment and about what you are trying to accomplish. Without knowing that it is a bit difficult to evaluate the config.

One thing that is clearly wrong is your access lists. 101 and 102 are extended access lists. But you have coded them like they were standard access lists. In an access list for controlling redistribution you are better off using standard access lists rather than extended access lists. So perhaps you could make them access list 10 and 12?

It looks to me like the interfaces that you want to include in EIGRP 104 will also match the network statements in EIGRP 100 and will be included in both instances of EIGRP. Is that what you intended?

The redistribution route maps imply that 172.xx.0.0 prefixes will be learned from a neighbor in EIGRP 104 and will redistribute into EIGRP 100. And that some prefix 10.xx.0.0 is learned in EIGRP 100 and will redistribute into EIGRP 104. Are these correct?

HTH

Rick

3 REPLIES
Hall of Fame Super Silver

Re: eigrp to eigrp as route redistribution

Brent

It would help us to know if this looks right if we knew more about your environment and about what you are trying to accomplish. Without knowing that it is a bit difficult to evaluate the config.

One thing that is clearly wrong is your access lists. 101 and 102 are extended access lists. But you have coded them like they were standard access lists. In an access list for controlling redistribution you are better off using standard access lists rather than extended access lists. So perhaps you could make them access list 10 and 12?

It looks to me like the interfaces that you want to include in EIGRP 104 will also match the network statements in EIGRP 100 and will be included in both instances of EIGRP. Is that what you intended?

The redistribution route maps imply that 172.xx.0.0 prefixes will be learned from a neighbor in EIGRP 104 and will redistribute into EIGRP 100. And that some prefix 10.xx.0.0 is learned in EIGRP 100 and will redistribute into EIGRP 104. Are these correct?

HTH

Rick

New Member

Re: eigrp to eigrp as route redistribution

you're right about the ACL's so i've changed them to 10 and 12.

The two network statements in the AS 104 section are the two interfaces that I want eigrp to go out on (in my head this made sense) but I'm not sure if I need them.

you are correct with the last paragraph I want to take the 172.xx.0.0 routes learned from 104 and put them into 100 and the 10.xx.0.0 from 100 into 104.

i know I'm missing a metric statement on the end of the redistribution so it maybe this looks better

router eigrp 104

redistribute eigrp 100 route-map to-eigrp104 metric 8000 10 255 1 1500

network 10.66.x.xx 0.0.0.0

network 10.66.x.xx 0.0.0.0

no auto-summary

!

router eigrp 100

redistribute eigrp 104 route-map to-eigrp100 metric 8000 10 255 1 1500

network 10.0.0.0 0.255.255.255

no auto-summary

route-map to-eigrp104

match address list 101

!

route-map to-eigrp100

match address list 102

access-list 10 permit 10.xx.0.0

access-list 10 deny any any

!

access-list 12 permit 172.xx.0.0 0.0.255.255

access-list 12 permit 172.xx.0.0 0.0.255.255

access-list 12 permit 172.xx.0.0 0.0.255.255

access-list 12 permit 206.xx.0.0 0.0.255.255

access-list 12 deny any any

Cisco Employee

Re: eigrp to eigrp as route redistribution

Hi,

While redistributing one eigrp process to other eigrp, you dont necessarily need to mention metric. It will automatically get the parameters from other eigrp process.

Only whe you redistribute non-eigrp protocol into eigrp, you need the metric in place.

Regards,

Nagendra

318
Views
0
Helpful
3
Replies