Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP tunnels question.

I am a bit confused about this router config from a branch location of an enterprise network. They use EIGRP tunnels as backups to the HQ.

I have pasted what I believe is relevant to my question. Under the sh ip pro it states:

Address Summarization:

    10.102.73.0/24 for Tunnel1, Tunnel2, Tunnel3

but that network is for the inside user LAN. What does this command mean?

And the route table has this EIGRP config:

D       10.102.73.0/24 is a summary, 00:17:44, Null0

Rt1#sh int des

Interface                      Status         Protocol Description

Fa0/0                          up             up       ****TRUNK TO SWITCH****

Fa0/0.1                        up             up       **** POS ****

Fa0/0.2                        up             up       **** Users ****

Fa0/1                          up             up       Verizon DSL circuit

BR0/1/0                        up             up       Verizon ISDN circuit SPID1

BR0/1/0:1                      down           down

BR0/1/0:2                      down           down

Lo0                            up             up

Lo2                            up             up

Tu1                            up             up       GRE VPN2 Primary Tunnel

Tu2                            up             up       GRE VPN2 Secondary Tunnel

Tu3                            up             up       GRE VPN3 Backup Tunnel to HQ

Rt1#sh ip int brie

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES NVRAM  up                    up

FastEthernet0/0.1          10.102.73.1     YES NVRAM  up                    up

FastEthernet0/0.2          10.102.73.129   YES NVRAM  up                    up

FastEthernet0/1            72.86.158.250   YES NVRAM  up                    up

BRI0/1/0                   192.168.1.59    YES NVRAM  up                    up

BRI0/1/0:1                 unassigned      YES unset  down                  down

BRI0/1/0:2                 unassigned      YES unset  down                  down

Loopback0                  10.202.73.1     YES NVRAM  up                    up

Loopback2                  10.90.1.78      YES NVRAM  up                    up

Tunnel1                    10.99.5.54      YES NVRAM  up                    up

Tunnel2                    10.99.133.54    YES NVRAM  up                    up

Tunnel3                    10.99.69.54     YES NVRAM  up                    up

Rt1#sh ip eig ne

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

3   10.99.133.53            Tu2               14 01:18:31  459  2754  0  557854279

2   10.99.5.53              Tu1               13 01:18:38   71   426  0  552639512

1   10.99.69.53             Tu3               14 01:18:41  157   942  0  1267476614

   66.0.0.0/32 is subnetted, 1 subnets

S       66.187.216.11 [1/0] via 72.86.158.1

     216.143.116.0/32 is subnetted, 2 subnets

S       216.143.116.13 [1/0] via 72.86.158.1

S       216.143.116.12 [1/0] via 72.86.158.1

     172.31.0.0/32 is subnetted, 2 subnets

S       172.31.0.6 [1/0] via 72.86.158.1

S       172.31.0.10 [1/0] via 72.86.158.1

     10.0.0.0/8 is variably subnetted, 9 subnets, 4 masks

C       10.99.69.52/30 is directly connected, Tunnel3

C       10.90.1.78/32 is directly connected, Loopback2

C       10.102.73.0/25 is directly connected, FastEthernet0/0.1

D       10.102.73.0/24 is a summary, 00:17:44, Null0

C       10.99.5.52/30 is directly connected, Tunnel1

C       10.202.73.1/32 is directly connected, Loopback0

C       10.102.73.128/25 is directly connected, FastEthernet0/0.2

C       10.99.133.52/30 is directly connected, Tunnel2

S       10.5.251.12/32 [1/0] via 72.86.158.1

     72.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       72.86.158.0/24 is directly connected, FastEthernet0/1

S       72.37.251.30/32 [1/0] via 72.86.158.1

D*EX 0.0.0.0/0 [170/19467008] via 10.99.5.53, 01:18:50, Tunnel1

C    192.168.0.0/22 is directly connected, BRI0/1/0

Rt1#sh ip pro

Routing Protocol is "eigrp 100"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  EIGRP stub, connected, summary

  Redistributing: eigrp 100

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Address Summarization:

    10.102.73.0/24 for Tunnel1, Tunnel2, Tunnel3

      BRI0/1/0

      Summarizing with metric 28160

  Maximum path: 4

  Routing for Networks:

    10.99.5.52/30

    10.99.69.52/30

    10.99.133.52/30

    10.102.73.0/25

    10.102.73.128/25

    10.202.73.1/32

    192.168.0.0/22

  Passive Interface(s):

    FastEthernet0/0

    FastEthernet0/0.1

    FastEthernet0/0.2

    FastEthernet0/1

    BRI0/1/0:1

    BRI0/1/0:2

    Loopback0

    Loopback2

Routing Information Sources:

    Gateway         Distance      Last Update

    (this router)         90      00:17:57

    10.99.69.53           90      00:17:57

    10.99.5.53            90      00:00:05

    192.168.1.1           90      01:15:06

    10.99.133.53          90      00:00:05

  Distance: internal 90 external 170

interface Tunnel1

description GRE VPN2 Primary Tunnel

bandwidth 384

ip address 10.99.5.54 255.255.255.252

ip mtu 1400

ip tcp adjust-mss 1360

ip summary-address eigrp 100 10.102.73.0 255.255.255.0 5

keepalive 20 3

tunnel source Loopback2

tunnel destination 172.31.0.6

end

interface Tunnel2

description GRE VPN2 Secondary Tunnel

bandwidth 384

ip address 10.99.133.54 255.255.255.252

ip mtu 1400

ip tcp adjust-mss 1360

ip summary-address eigrp 100 10.102.73.0 255.255.255.0 5

delay 50010

keepalive 20 3

tunnel source Loopback2

tunnel destination 172.31.0.10

end

interface Tunnel3

description GRE VPN3 Backup Tunnel to Secaucus

bandwidth 256

ip address 10.99.69.54 255.255.255.252

ip mtu 1400

ip tcp adjust-mss 1360

ip summary-address eigrp 100 10.102.73.0 255.255.255.0 5

delay 100000

keepalive 20 3

tunnel source Loopback2

tunnel destination 10.5.251.12

end

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: EIGRP tunnels question.

This router has 2 subnets as local connected subnets within this address space. Rather than advertise the individual subnets the router has configured the summary address command on the tunnel interfaces. The result is that the router advertises one summary instead of the individual subnets. And when summarization is configured EIGRP will install a route for the aggregate with null 0 as the next hop.

HTH

Rick

Sent from Cisco Technical Support iPhone App

2 REPLIES
Hall of Fame Super Silver

Re: EIGRP tunnels question.

This router has 2 subnets as local connected subnets within this address space. Rather than advertise the individual subnets the router has configured the summary address command on the tunnel interfaces. The result is that the router advertises one summary instead of the individual subnets. And when summarization is configured EIGRP will install a route for the aggregate with null 0 as the next hop.

HTH

Rick

Sent from Cisco Technical Support iPhone App

Hall of Fame Super Silver

EIGRP tunnels question.

I am glad that my explanation was helpful. Thank you for using the rating system to mark this question as answered. It makes the forum more useful when people can read a question and can know that an answer was found. Your marking has contributed to this process.

HTH

Rick

762
Views
0
Helpful
2
Replies
CreatePlease login to create content