Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP Using SLOW connection vice fast connection

I am perplexed. My router is choosing the slow conneciton over the fast connection for EIGRP routes.

This is a dual hub and spoke design, with all the sites having a full T1 to the main (all via S0/0/0.1) and only 256k to the backup (all via the S0/0/0.2). For spoke site A to talk to spoke site B, it would either use two T1 links through the main hub or two 256k links through the backup hub.

Here is my setup (IPs have been changed):

interface Serial0/0/0.1 point-to-point

bandwidth 1544

ip address 1.1.1.1 255.255.255.252

ip nbar protocol-discovery

ip policy route-map nachi

frame-relay interface-dlci 16

!

interface Serial0/0/0.2 point-to-point

bandwidth 256

ip address 2.2.2.2 255.255.255.252

ip bandwidth-percent eigrp 1 10

ip policy route-map nachi

no cdp enable

frame-relay interface-dlci 20

!

router eigrp 1

redistribute connected

redistribute static

passive-interface GigabitEthernet0/0

passive-interface GigabitEthernet0/1

network 1.1.1.0 0.0.0.255

network 2.2.2.0 0.0.0.255

no auto-summary

no eigrp log-neighbor-changes

neighbor 1.1.1.2 Serial0/0/0.1

neighbor 2.2.2.2 Serial0/0/0.2

!

route-map nachi permit 10

match ip address 2003

match length 92 92

set interface Null0

#show ip eigrp nei

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 1.1.1.2 Se0/0/0.1 14 00:00:22 1244 5000 3 547766

0 2.2.2.2 Se0/0/0.2 10 00:04:51 32 2850 0 408246

#show ip eigrp top

IP-EIGRP Topology Table for AS(1)/ID(1.1.1.1)

P 0.0.0.0/0, 1 successors, FD is 10516992

via 2.2.2.2 (10516992/61952), Serial0/0/0.2

P 3.3.3.0/30, 1 successors, FD is 11023872

via 2.2.2.2 (11023872/10511872), Serial0/0/0.2

HELP!

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: EIGRP Using SLOW connection vice fast connection

Hi

I suspect this can be a mtu issue.

I would recomend you to set the mtu size to 1500 on the atm side.

/Mikael

19 REPLIES

Re: EIGRP Using SLOW connection vice fast connection

Try setting the delay on the 256k lines higher than that of the T1s. The bandwidth setting should be taken into consideration when eigrp does it's calculation, but Cisco recommends tuning the delay parameters first.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Using SLOW connection vice fast connection

I kept the delay of the T1 at 20,000 (default) and increased the delay of the 256k connection to 100,000 and there was no change.

Hall of Fame Super Bronze

Re: EIGRP Using SLOW connection vice fast connection

Based on the EIGRP Nei output the 'Q' count on neighbor 1.1.1.1 is 3 which means there are 3 pending updates on this link.

The 'Q' count should be '0' thus I suggest inspecting the link for errors and such.

HTH,

__

Edison.

New Member

Re: EIGRP Using SLOW connection vice fast connection

Inspecting the link for errors, as in Layer 1 and 2 errors, or configuation errors?

Hall of Fame Super Bronze

Re: EIGRP Using SLOW connection vice fast connection

Based on the config portion you've posted, I don't see a configuration issue. Can you post the remote site config?

Re: EIGRP Using SLOW connection vice fast connection

Edison,

Just throwing this out there since I'm trying to learn from this problem as well. Would putting a delay statement under his 256k link higher than his T1 fix the problem if the other side doesn't have any errors in the config either? I had seen that you said there were pending updates that were in the queue, so if that wasn't the problem would delay fix it?

Thanks,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Bronze

Re: EIGRP Using SLOW connection vice fast connection

Delay as well as bandwidth are part of the EIGRP metric calculation but it will not help any L1 L2 issues that are currently present as packets aren't leaving the interface in the correct manner.

He already has the bandwidth information so EIGRP will choose the higher bandwidth interface. You can use delay if you didn't want to use the bandwidth as part of the metric, IOW if bandwidth were equal but that's not the case here.

__

Edison.

Hall of Fame Super Silver

Re: EIGRP Using SLOW connection vice fast connection

What I notice is that the show ip eigrp topology only shows entries from one neighbor. I wonder what we would get if Michael would post the output of show ip eigrp topology all. Perhaps that will clarify what is going on. I wonder if advertisements from the T1 neighbor are getting through.

HTH

Rick

New Member

Re: EIGRP Using SLOW connection vice fast connection

Main Hub Site:

vc-class atm atm

vbr-nrt 30000 15000 256

!

vc-class atm Remote-1708-1708

vbr-nrt 1708 1708 32

!

interface ATM1/0

no ip address

ip route-cache flow

ip ospf priority 0

ip policy route-map nachi

class-int atm

atm scrambling cell-payload

atm framing cbitplcp

no atm auto-configuration

no atm ilmi-keepalive

!

interface ATM1/0.68 point-to-point

description Connection to messed up spoke site

bandwidth 1708

ip address 1.1.1.2 255.255.255.252

ip nbar protocol-discovery

ip bandwidth-percent eigrp 1 10

ip policy route-map nachi

pvc 3/68

class-vc Remote-1708-1708

vc-hold-queue 300

oam-pvc 0

!

router eigrp 1

redistribute connected

redistribute static

passive-interface FastEthernet0/0

passive-interface FastEthernet0/1

network 1.1.1.0 0.0.0.255

neighbor 1.1.1.1 ATM1/0.68

no auto-summary

Hall of Fame Super Bronze

Re: EIGRP Using SLOW connection vice fast connection

ATM to Serial? ugh. I suspect L1 L2 problems. Contact the provider. You also listed some input errors on the remote serial so...

New Member

Re: EIGRP Using SLOW connection vice fast connection

TY, I am opening up a case with them now and will post the results.

New Member

Re: EIGRP Using SLOW connection vice fast connection

I did a clear ip eigrp nei and grabbed a debug of the output. Here is part of it:

IP-EIGRP Route Events debugging is on

NEVC_2821#terminal monitor

NEVC_2821#clear ip eigrp 1 neighbors

NEVC_2821#

Aug 7 12:18:03.926 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet

Aug 7 12:18:03.978 EDT: IP-EIGRP(Default-IP-Routing-Table:1): A.A.A.0/25 - do advertise out Serial0/0/0.2

Aug 7 12:18:03.978 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Ext A.A.A.0/25 metric 28160 - 25600 2560

Aug 7 12:18:04.018 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet

Aug 7 12:18:04.018 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Int F.F.F.F/30 M 40516864 - 40000000 516864 SM 6169

6 - 56832 4864

Aug 7 12:18:04.018 EDT: IP-EIGRP(Default-IP-Routing-Table:1): route installed for F.F.F.F ()

...truncated...

Aug 7 12:18:04.749 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet

Aug 7 12:18:04.757 EDT: IP-EIGRP(Default-IP-Routing-Table:1): A.A.A.0/25 - do advertise out Serial0/0/0.1

Aug 7 12:18:04.757 EDT: IP-EIGRP(Default-IP-Routing-Table:1): Ext A.A.A.0/25 metric 28160 - 25600 2560

...truncated...

Aug 7 12:20:47.310 EDT: IP-EIGRP(Default-IP-Routing-Table:1): ExtS A.A.A.0/25 M 4294967295 - 9999872 4294967295 S

M 4294967295 - 9999872 4294967295

...truncated...

New Member

Re: EIGRP Using SLOW connection vice fast connection

Additional background info:

First started looking because site complained of slowness. I am using a netflow collector and saw that the site's incoming traffic was from the Main Hub site as expected, but all outgoing traffic was to the Backup Hub site.

Re: EIGRP Using SLOW connection vice fast connection

Well, do you see any crc errors or anything on the T1 link?

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Using SLOW connection vice fast connection

194 input errors in 20 minutes, no other errors. Uses an external CSU/DSU so I cannot check a cisco WIC. I cleared the counters after you mentioned possible line errors, since I have been messing with the router for a bit.

Re: EIGRP Using SLOW connection vice fast connection

I would look on the other end to see if you're getting errors there too. Then I would have the provider look at the line.

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Using SLOW connection vice fast connection

No errors on that side, but I will have the provider fix the slowly incrimenting incoming errors at the spoke site.

I will put the result in this thread and close out with the problem solved and such after they are done testing.

Thanks for all your help so far!

Silver

Re: EIGRP Using SLOW connection vice fast connection

Hi

I suspect this can be a mtu issue.

I would recomend you to set the mtu size to 1500 on the atm side.

/Mikael

New Member

Re: EIGRP Using SLOW connection vice fast connection

I changed the MTU to 1500 on the ATM subinterface and that fixed the problem!

360
Views
11
Helpful
19
Replies
CreatePlease to create content