Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Enable Ethernet port

I'm new to Cisco and I have a 2516 router. Does anyone know the command to make the Ethernet 0 port active?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Enable Ethernet port

2516-A#config t

Enter configuration commands, one per line. End with CNTL/Z.

2516-A(config)#int e0

2516-A(config-if)#no shut

2516-A(config-if)#

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
8 REPLIES
VIP Purple

Re: Enable Ethernet port

Hello,

use the following command sequence:

2516#conf t

2516(config)#interface Ethernet0

2516(config-if)#no shut

That should bring your interface into up/down status, which you can verify with the command:

show ip interface brief

Now, obviously, you need a physical (cable) connection on the port, in order to be able to sue it...

HTH,

GP

New Member

Re: Enable Ethernet port

Thanks for the help! I have one question. I'm using the router 2516 as a hub and my cable modem for access. None of my computers are getting out. Is there anything else I need to do to make the router accept my three computers and get out through the router, then the Modem? I really appreciate this. Thanks again for the help earlier. AJ

VIP Purple

Re: Enable Ethernet port

Hello,

can you post the configuration of your 2516 ? It would be easiest to see what you have configured, and then suggest the necessary additions...

Regards,

GP

New Member

Re: Enable Ethernet port

Try not to laugh. All I did was run the router and enable the Ethernet0 port. All my computers could talk to each other. I used E1 port to connect to a DSL router, Then I connected it to my Highspeed cable modem. It worked fine, but then I wanted to eliminate the DSL router. I want to use the Cisco as a hub and use E1 port to connect to my cable modem and reach the outside world. Here's the conf's below:

Router>enable

Router#show running-config

Building configuration...

Current configuration:

!

version 11.1

service udp-small-servers

service tcp-small-servers

!

hostname Router

!

!

!

hub ether 0 1

link-test

auto-polarity

!

hub ether 0 2

link-test

auto-polarity

!

hub ether 0 3

link-test

auto-polarity

!

hub ether 0 4

link-test

auto-polarity

!

hub ether 0 5

link-test

auto-polarity

!

hub ether 0 6

link-test

auto-polarity

!

hub ether 0 7

link-test

auto-polarity

!

hub ether 0 8

link-test

auto-polarity

!

hub ether 0 9

link-test

auto-polarity

!

hub ether 0 10

link-test

auto-polarity

!

hub ether 0 11

link-test

auto-polarity

!

hub ether 0 12

link-test

auto-polarity

!

hub ether 0 13

link-test

auto-polarity

!

hub ether 0 14

link-test

auto-polarity

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

no ip classless

logging buffered

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router#

VIP Purple

Re: Enable Ethernet port

Hello,

just so that you are aware, the 2516 does not support PPPoE or PPPoA, so you cannot connect it directly to your cable modem...

Regards,

GP

New Member

Re: Enable Ethernet port

GP,

I really want to thank you for all your help. Also, I wanted to tell you that how I had it hooked up...worked. I was able to connect a new computer to the router, it was to connect to the internet. I had the computers to the Cisco 2516 ethernet ports 2-4. Next, I had the LINKS router to ethernet port 1

Then I had the LINKS router to the Cable modem.

I unplugged everything and plug it all back in and now it doesn't work. It's a little frustrating when you know it works. I'm at the begging of learning about routers, so any addtional information would be helpful. Maybe a list of commands and what they mean would help.

Thanks!

--AJ

Cisco Employee

Re: Enable Ethernet port

2516-A#config t

Enter configuration commands, one per line. End with CNTL/Z.

2516-A(config)#int e0

2516-A(config-if)#no shut

2516-A(config-if)#

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Enable Ethernet port

Oh, I forgot. The lights on the router's Ethernet port were not working, but now they are but I can't get out. AJ

1165
Views
0
Helpful
8
Replies
CreatePlease login to create content