Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Enabling Vlan Cause another to shutdown

HI

I have a cat 2950 switch with 3 vlan LANs

Everytime i enable vlan 2, vlan 1 shutsdown. if I issue no shut on vlan 1, vlan 2 will shut

What am I doing wrong

7 REPLIES

Re: Enabling Vlan Cause another to shutdown

Hi John

Cicso 2950 is a layer 2 Switch and you can have only one SVI interface configured under that with ip address assigned to it.

If you try to create one more SVI with ip address the existing will be shut automatically.

But you can create layer 2 vlans under the vlan database and assign a port to be a member of that particular vlan using switch port command under the interface.

regds

New Member

Re: Enabling Vlan Cause another to shutdown

How can I tell the vlan its not an SVI

Silver

Re: Enabling Vlan Cause another to shutdown

Hi John

I think, first you should check your switch is in VTP server mode or VTP transparent mode. Then, try to configure VLANs in VLAN Configuration Mode ("vlan database" command).

By the way, how do you enable vlans?

Hope this helps

New Member

Re: Enabling Vlan Cause another to shutdown

I dont use vlan database command

here is what i have

!

interface FastEthernet0/1

switchport trunk native vlan 2

switchport mode trunk

speed 100

duplex full

interface FastEthernet0/23

switchport mode trunk

!

interface FastEthernet0/24

description *** Trunk to Computer Room ***

switchport trunk allowed vlan 1,2

switchport mode trunk

speed 100

duplex full

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface Vlan1

ip address 192.168.100.101 255.255.255.0

no ip route-cache

!

interface Vlan2

ip address 10.15.15.101 255.0.0.0

no ip route-cache

shutdown

Re: Enabling Vlan Cause another to shutdown

Hi John

As i have clearly mentioned in my earlier mail its not possible to have more than one SVI (VLAN) configured with ip address on your Cisco 2950 Switch.

You can make use of only one SVI (VLAN) with ip address configured.

If you want to have 2 different SVI (VLAN) interfaces with ip address configured you should look for a Layer 3 switch where in you can configure multiple SVIs based on your requirement.

regds

Re: Enabling Vlan Cause another to shutdown

You are probably talking about interface vlan X. This is the management interface for the switch and you are allowed to have only one of those on a layer2 switch. The management interface is used to perform switch management (telnet, http) over the network.

This does not say anything about the capability to switch different vlans. Use the command: "sh vlan" or "sh int status" to see which vlans the switch is aware of and to which ports they are assigned.

Regards,

Leo

Silver

Re: Enabling Vlan Cause another to shutdown

For this type of switch you must keep VLAN 1 as management. If youtry to move it to another VLAN VLAN 1 will shut down. Keep VLAN 1 as management and move on with your configuration....

201
Views
0
Helpful
7
Replies