Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

error-disable on Catalyst 2960 ethernet port

I have a catalyst 2960 switch installed. The port is in error-disable state. It was working fine a few days ago. I have checked the punch down wiring and the physical cables and they are fine. If I connect it to a different port on the switch it works fine.

Here is the configuration for that port:

interface FastEthernet0/17

switchport mode access

switchport voice vlan 100

macro description cisco-phone-data

spanning-tree portfast

here is the port it is connected to:

interface FastEthernet0/18

switchport mode access

switchport voice vlan 100

macro description cisco-phone-data

spanning-tree portfast

As you can see they are identical.

Here is the show int on the port:

FastEthernet0/17 is down, line protocol is down (err-disabled)

Hardware is Fast Ethernet, address is 0024.134c.6311 (bia 0024.134c.6311)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 1d02h, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

5510740 packets input, 369993922 bytes, 0 no buffer

Received 682 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

140716940 packets output, 40486108345 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

I am debating if it is a hardware issue. I also have tried no shutdown on the port to re-enable it and that did not work.

Any ideas?

3 REPLIES
New Member

Re: error-disable on Catalyst 2960 ethernet port

you have to shutdown the interface and then have to apply the no shut command.

Re: error-disable on Catalyst 2960 ethernet port

Can you please post the logs of the switch? This will usually show the reason for the interface going into err-disable.

Mark

New Member

Re: error-disable on Catalyst 2960 ethernet port

can u please post o/p of  command 'sh interfaces status err-disabled' even this command show the reason of err-disable

5430
Views
0
Helpful
3
Replies
CreatePlease to create content