Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Error enabling PPPoE

Hi!

I'm trying to configure a Cisco 1841 router to use PPPoE with ADSL, but when I try to enable PPPoE on fa0/0 I get the following error:

Router(config)#int fa0/0

Router(config-if)#no ip address

Router(config-if)#pppoe enable

PPPoE create bba subblock failed

This is a new router never used and I'm doing the first configuration on it. I have done the dialer configuration, but I have stopped on the above error and I can't finish the configuration.

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 10

ppp authentication pap callin

ppp pap sent-username XXXXXXXXXXXX password 0 XXXXXXXXXXXX

ppp ipcp route default

!

!

!

ip http server

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

------------------------------------------

I need some help, because I googoled the above error and I have found nothing how to solve it.

Regards,

Marcio

Everyone's tags (1)
6 REPLIES
VIP Purple

Re: Error enabling PPPoE

Hello

Ethernet interface

Int fa0/1

descritption Lan Interface

ip address 10.10.10.1 255.255.255.0 (rfc 1918 addressing )

io nat inside

no shut

Int fa0/0

descritption DSL Interface

no ip address

ppoe enable

ppoe-client dial-pool-number 1

ip tcp adjust-mss 1452

no shut

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

ppp chap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it  to you

ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)

ppp ipcp route default

ip nat outside

no shut

p dhcp excluded-address 10.10.10.1

ip dhcp pool DHCP

network 10.10.10.0 /24

dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP)

default-router 10.10.10.1

import all

i

ip access-list extended LAN_IP_Range

100 permit ip 10.10.10.0.0 0.0.0.255 any

ip nat inside source list LAN_IP_Range interface dialer 1 overload

ATM interfaces  ( same as above but instead of fa0/0 use the ATM interface

vpdn enable

vpdn-group ppoe

request-dialin

protocol pppoe

exit

interface ATM 0

description DSL interface

no ip address

dsl operating-mode auto

pvc x/x

ip tcp adjust-mss 1452

no shutdown

pppoe-client dial-pool-number 1

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
Community Member

Re: Error enabling PPPoE

Hi Paul,

I tryed to configure the router as you have suggested but the same error appear every time I try to enable pppoe in any of the FastEthernet Interfaces, as following:

Int fa0/0

descritption DSL Interface

no ip address

ppoe enable

PPPoE create bba subblock failed

Another issue is when I tryed to configure "

ppp chap sent-username

USERNAME

password

P@ssw0rd (this is the password that ISP gave it  to you"

In this case I got the following error:

Router(config)#int Dialer1

Router(config-if)#ip address negotiated

Router(config-if)#ip mtu 1492

Router(config-if)#encapsulation ppp

Router(config-if)#dialer pool 1

Router(config-if)#ppp chap sent-username XXXXXXXXXXX password XXXXXX

                            ^

% Invalid input detected at '^' marker.

No matter how I try to do this I get the same error.

Regards,

Marcio


Community Member

Error enabling PPPoE

interface Dialer1

description ADSL WAN Dialer$FW_OUTSIDE$

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nat outside

ip virtual-reassembly

zone-member security out-zone

encapsulation ppp

ip route-cache flow

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname .....................................

ppp chap password 7 .............................

ppp ipcp dns request

ppp ipcp route default

interface FastEthernet0
description ADSL WAN Interface
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable

VIP Purple

Re:Error enabling PPPoE

Hello

Not sure on this can ypu post output

Show version

Res
Paul

Sent from Cisco Technical Support Android App

Please don't forget to rate any posts that have been helpful. Thanks.
Community Member

Re: Error enabling PPPoE

Hi Paul,

I have copied default configuration from flash to startup-config and tryed again. Despite that, I got the same error again, but instead of stop doing the configuration I have continued.

At the end the connection has been estabilished and all the users inside the Lan network are now reaching external sites pages.

Regards,

Marcio

VIP Purple

Re: Error enabling PPPoE

Hello

Thanks for the feedback - unusual issue but glad to hear its now working

Can you confirm or post what configuration you used for future reference

Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
1215
Views
0
Helpful
6
Replies
CreatePlease to create content