Cisco Support Community
Community Member

% Error saving SNMP ifIndexes

Hello, when I try to save the running configuration, I get this error:

Router#wr mem

Building configuration...

% Error saving SNMP ifIndexes No space left on device[OK]


Router's SNMP configuration is as follows:

Router#sh run | i snmp

snmp-server community wag RO 11

snmp-server community public2 RO 99

snmp-server ifindex persist

snmp-server trap-source FastEthernet0/0

snmp-server trap-timeout 120

snmp-server location SUDEL-ElGeneina

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps entity


I tried with the snmo ifindex clear from every single interface of the router, but the error keeps comming out.

Any ideas?

Cisco Employee

Re: % Error saving SNMP ifIndexes

The ifIndex information is stored in the nvram area, which is normally small, whose size cannot be increased.

Given this limitation, there are a few options available for you:


Remove the cmd snmp-server ifindex-persist


Try using the cmd "service compress-config"


Try using the cmd "boot config flash:config.cfg"

Now, exit from config mode and issue wr mem. It should write the configs to flash:

Community Member

Re: % Error saving SNMP ifIndexes

davistan, thanks a lot for the reply.

I have tried the first 2 options and these are the results:

Option A: When I remove the ifindex persist, and the wr mem, there is no error and then the dir nvram: gives me the ifIndex-table but of course with 0 bytes in it. I re enable the ifindex command, re write mem and same problem occurs.

Option B: I disable the ifindex command, compress the image, wr mem, then enable the ifindex command again, and then wr mem finally. This works EXCELLENT, but the idea of having the config compressed doesn't feel right, besides I have seen that the ifindex-Table size is only 3955 bytes, so the uncompressed config and the ifindex have plenty of room to live together. I then de-compress the config, re write mem and same issue occurs.

This is what I will try: I will see the issue with the monitoring guys and see if we are able to get some graphics or if we are loosing any big features with the ifindex disable. If the results are not as expected, I will compress the config file again and hopefully everything works fine!

I will let you know how this goes!

CreatePlease to create content