Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

I have an old 7200, with a T3 terminating on it.  From there, I have several Point to Point T1's through Qwest terminating at various remote locations.  At one of my locations, I have a 2811, terminating 2 PTP T1's, and I am getting lots of errors on the T1's.  This has caused some issues with data speeds and voice quality (VOIP).  I suppose there could be some QOS issues, but I'm not sure.  I have had Qwest test the lines, and they have run clean to the NIU.  They are telling me there is probably a timing issue on the router config.

I have another 2811 configured the same way, and it has no problems.  I'm not sure what I'm missing.  Does anyone have any ideas?

Thanks

Jake

Here is some info from my environment:

###########################################

The two channels on the T3 on my 7200 that point to these T1's and the service policy referenced:

###########################################

interface Serial1/0/6:0

description Qwest Circuit ID# *********991                                                   

ip address 10.1.252.21 255.255.255.252

ip pim sparse-dense-mode

service-policy output axiom-voice

!

interface Serial1/0/7:0

description Qwest Circuit ID# *********992                                                   

ip address 10.1.252.25 255.255.255.252

ip pim sparse-dense-mode

service-policy output axiom-voice

!

class-map match-any voip-control

  match ip dscp af31

class-map match-any voip-rtp

  match ip dscp ef

!

!

policy-map axiom-voice

  class voip-rtp

   priority percent 33

  class voip-control

   bandwidth percent 5

  class class-default

   fair-queue

########################################

Some show interfaces of the Serial Interfaces on my 2811

########################################

Serial1/0/0:0 is up, line protocol is up

  Hardware is DSX1

  Description: Qwest PTP Circuit ID# **********991

  Internet address is 10.1.252.22/30

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 11/255, rxload 49/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input 00:00:00, output never, output hang never

  Last clearing of "show interface" counters 8w0d

  Input queue: 0/75/228/0 (size/max/drops/flushes); Total output drops: 1487

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/1487 (size/max total/threshold/drops)

     Conversations  0/25/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 299000 bits/sec, 90 packets/sec

  5 minute output rate 69000 bits/sec, 29 packets/sec

     101067499 packets input, 499789832 bytes, 0 no buffer

     Received 741536 broadcasts, 14975 runts, 0 giants, 0 throttles

     19643 input errors, 19638 CRC, 0 frame, 0 overrun, 0 ignored, 487 abort

     99354543 packets output, 301350989 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

Layton-2811#sho int Serial1/0/1:0

Serial1/0/1:0 is up, line protocol is up

  Hardware is DSX1

  Description: Qwest PTP Circuit ID# **********992

  Internet address is 10.1.252.26/30

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 16/255, rxload 8/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input 00:00:00, output never, output hang never

  Last clearing of "show interface" counters 8w0d

  Input queue: 0/75/656/0 (size/max/drops/flushes); Total output drops: 1741

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/1741 (size/max total/threshold/drops)

     Conversations  0/29/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 52000 bits/sec, 23 packets/sec

  5 minute output rate 97000 bits/sec, 72 packets/sec

     104860684 packets input, 552205434 bytes, 0 no buffer

     Received 741546 broadcasts, 15957 runts, 0 giants, 0 throttles

     20742 input errors, 20739 CRC, 0 frame, 0 overrun, 0 ignored, 535 abort

     90196734 packets output, 2306764998 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

########################################

The majority of the config on my 2811

########################################

Current configuration : 7660 bytes

!

! Last configuration change at 17:02:45 MST Wed Feb 29 2012

!

version 12.4

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname *********-2811

!

boot-start-marker

boot-end-marker

!

card type t1 1 0

card type t1 1 1

logging message-counter syslog

logging buffered 51200 warnings

!

no aaa new-model

clock timezone MST -7

clock summer-time MST recurring

network-clock-participate slot 1

network-clock-select 1 T1 1/0

!

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 10.1.9.1 10.1.9.25

!

ip dhcp pool ********DHCP

   network 10.1.9.0 255.255.255.0

   default-router 10.1.9.1

   option 150 ip *********

   dns-server **********

   domain-name *********

!

!

no ip domain lookup

ip multicast-routing

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

fax protocol pass-through g711ulaw

h323    

  h225 display-ie ccm-compatible

  call preserve

modem passthrough nse codec g711ulaw

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout ntf 100

h225 display-ie ccm-compatible

!

!

voice translation-rule 1

rule 1 /^2*/ /8015252/

!

!

voice translation-profile SRST-MASK

translate calling 1

!

!

voice-card 0

!

voice-card 1

!

!

!

archive

log config

  hidekeys

!

!

controller T1 1/0

cablelength short 133

pri-group timeslots 1-24

!

controller T1 1/0/0

clock source internal

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 1/0/1

clock source internal

cablelength short 110

channel-group 0 timeslots 1-24

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.10

description Data Vlan 10

encapsulation dot1Q 10

ip address 10.1.8.1 255.255.255.0

ip helper-address 10.1.2.10

!

interface FastEthernet0/0.20

description Voice Vlan 20

encapsulation dot1Q 20

ip address 10.1.9.1 255.255.255.0

h323-gateway voip bind srcaddr 10.1.9.1

!

interface FastEthernet0/0.30

description Management Interface

encapsulation dot1Q 30

ip address 10.1.250.17 255.255.255.248

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn supp-service name calling

no cdp enable

!

interface Serial1/0/0:0

description Qwest PTP Circuit ID# **********991

ip address 10.1.252.22 255.255.255.252

ip pim sparse-dense-mode

!

interface Serial1/0/1:0

description Qwest PTP Circuit ID# *********992

ip address 10.1.252.26 255.255.255.252

ip pim sparse-dense-mode

!

router eigrp 7

passive-interface FastEthernet0/0.10

passive-interface FastEthernet0/0.20

passive-interface FastEthernet0/0.30

network 10.0.0.0

no auto-summary

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

logging trap debugging

logging 10.1.2.24

!

!

snmp-server community *********** RO

!

control-plane

!

!

!

voice-port 1/0:23

!

!

!

!

!

dial-peer voice 1 pots

!

################ Removed all my dial peers to keep it a little cleaner on the discussion ################

!

dial-peer voice 109 voip

!

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 3 gain -6

transfer-system full-consult

timeouts interdigit 5

ip source-address 10.1.9.1 port 2000

max-ephones 42

max-dn 144

system message primary Your current options

transfer-pattern 9T

alias 1 xxxx to xxxx

alias 2 xxxx to xxxx

alias 3 xxxx to xxxx

translation-profile incoming SRST-MASK

!

line con 0

privilege level 15

password 7 ***************

login

line aux 0

line vty 0 4

privilege level 15

password 7 ****************

login

transport input telnet

line vty 5 15

privilege level 15

password 7 ****************

login

transport input telnet

!

scheduler allocate 20000 1000

ntp source FastEthernet0/0.10

ntp server x.x.x.x

end

Everyone's tags (7)
17 REPLIES
Bronze

Errors on Point to Point T1's - 2811 - Timing issue?

which generation T1 card you are using ??? , kindly note following about generation 2 and generation 3 cards .

Also I see a lot of inout error which is generally an indication of physical layer issue so ensure that the line from ISP is clean and if required change the cable from router to smart jack.

VWIC generation 2:

The  Cisco 2-port VWIC2 cards can enable each port  to be clocked from  independent clock sources for data applications. This  independent  clocking capability is not supported for voice applications  or with the  Cisco ATM/Voice Advanced Integration Modules (part numbers  AIM-ATM,  AIM-VOICE-30, and AIM-ATM-VOICE-30).

controller t1 0/0/0
framing esf
linecode b8zs

channel-group 1 timeslots 1-24 speed 64
clock source line independent <<<<<<   allowed

!
controller t1 0/1/0
framing esf

linecode b8zs 

channel-group 1 timeslots 1-24 speed 64 
clock source line independent <<<<<<   allowed 

However Customers started facing another issue when they use VWIC2
2 ports for both voice and data, they can't use Independent clock source.

controller t1 0/0/0
framing esf
linecode b8zs

pri-group timeslots 1-24 speed 64
clock source line independent <<<<<<  Not allowed

!
controller t1 0/1/0
framing esf

linecode b8zs 

channel-group 1 timeslots 1-24 speed 64 
clock source line independent <<<<<<  Not allowed 

In this case , Cu comes with same issue,  getting Slip sec  errors, clocking errors.  Earlier Cisco use to suggest,  As a design  perspective better use 2 ports for data only and  use another card for  voice , not to get slip errors. In order to support independent clocking  for both "Data " and "voice"  on same card Generation 3 card has come  into picture.

VWIC generation 3:

The   Cisco VWIC3 cards are supported only on the Cisco Integrated Services   Router (ISR) 1900, 2900, 3900 and 3900E series platforms.
The  VWIC3 cards add enhancements to the previous generation VWIC2 cards,   including: Enhanced clocking capabilities:  The Cisco VWIC3 cards can  enable each port to be clocked from an  independent clock source for  data applications. Data ports can also be  clocked independent of voice  ports. All voice ports on the card much use  the same clock  source.Multiple data channel-groups supported per T1/E1 port

controller t1 0/0/0
framing esf
linecode b8zs

pri-group timeslots 1-24 speed 64
clock source line independent <<<<<<  allowed

!
controller t1 0/1/0
framing esf

linecode b8zs 

channel-group 1 timeslots 1-24 speed 64 
clock source line independent <<<<<< allowed 

Thus VWIC3 eliminates the clocking issue compeletely.
New Member

Errors on Point to Point T1's - 2811 - Timing issue?

As you can see in the config, I have the 2 point to point T1's then I have a seperate voice T1 (PRI) terminating on another card.  I don't remember for sure the version of the VWIC card on my PRI, but I think the cards I'm using for my PTP T1's are

wic 1 dsu-t1v2 cards.  Or it could be a 2-port version of that same card.  It's been quite a while since I installed the hardware, so I don't remember specifically.  Is there a command I can run that will show me hardware specifics?  I am not near the physical device.

Bronze

Errors on Point to Point T1's - 2811 - Timing issue?

paste the "show inventory" from the router .

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

Here is my show inventory:

NAME: "2811 chassis", DESCR: "2811 chassis"

PID: CISCO2811         , VID: V07, SN: FTX1241F00U

NAME: "High Density Voice2 Network module with on board one port interface  on Slot 1", DESCR: "High Density Voice2 Network module with on board one port interface "

PID: NM-HDV2-1T1/E1    , VID: V03 , SN: FOC11463MF8

NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 1 SubSlot 0", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-2MFT-T1/E1  , VID: V01 , SN: FOC114836K0

NAME: "PVDMII DSP SIMM with four DSPs on Slot 1 SubSlot 2", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64          , VID: V01 , SN: FOC114869TS

I am not on site, so I haven't checked the cables since I opened up this discussion.  However, I have checked them for similar issues recently.  They looked and tested fine.

I must admit, I don't know too much about timing or setting the clock.  A contract CCIE voice set up this router when we were upgrading our CallManager software/hardware.

This is the only thing the 7200 really says about the clock:

clock timezone MST -7

clock summer-time MST recurring

ip subnet-zero

!

!

no ip cef

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

controller T3 1/0

clock source line

cablelength 150

t1 1 channel-group 0 timeslots 1-24

t1 2 channel-group 0 timeslots 1-24

t1 3 channel-group 0 timeslots 1-24

t1 4 channel-group 0 timeslots 1-24

t1 5 channel-group 0 timeslots 1-24

t1 6 channel-group 0 timeslots 1-24

t1 7 channel-group 0 timeslots 1-24

t1 8 channel-group 0 timeslots 1-24

t1 9 channel-group 0 timeslots 1-24

t1 10 channel-group 0 timeslots 1-24

t1 11 channel-group 0 timeslots 1-24

t1 12 channel-group 0 timeslots 1-24

t1 13 channel-group 0 timeslots 1-24

t1 14 channel-group 0 timeslots 1-24

t1 15 channel-group 0 timeslots 1-24

t1 16 channel-group 0 timeslots 1-24

t1 17 channel-group 0 timeslots 1-24

t1 18 channel-group 0 timeslots 1-24

t1 19 channel-group 0 timeslots 1-24

t1 20 channel-group 0 timeslots 1-24

t1 21 channel-group 0 timeslots 1-24

t1 22 channel-group 0 timeslots 1-24

t1 23 channel-group 0 timeslots 1-24

t1 24 channel-group 0 timeslots 1-24

t1 25 channel-group 0 timeslots 1-24

t1 26 channel-group 0 timeslots 1-24

t1 27 channel-group 0 timeslots 1-24

t1 28 channel-group 0 timeslots 1-24

I don't know if that helps.

Gold

Errors on Point to Point T1's - 2811 - Timing issue?

not that clock!

controller T1 1/0/0

clock source internal

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 1/0/1

clock source internal

cablelength short 110

channel-group 0 timeslots 1-24

switch that to network.

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

Thanks for the reply.

I'm not familiar with the syntax?

When I do a "clock source ?", the only options that show up are "free-running", "internal", and "line".

Do I want to use "clock source line"?

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

I set them both to "clock source line".  I set one of them to "clock source line primary".  After doing that I cleared the counters, and it seems like they are still grabing tons of errors.

Here is a "show controller t1" a couple minutes after clearing.  Still lots of slip secs.   And you can see the clock source:

T1 1/0 is up.

  Applique type is Channelized T1

  Cablelength is short 133

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090408, FPGA: 255, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  Current port master clock:recovered from backplane

  Data in current interval (136 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 1/0/0 is up.

  Applique type is Channelized T1

  Cablelength is long 0db

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090408, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.

  Current port master clock:recovered from backplane

  Data in current interval (137 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     18 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     18 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 1/0/1 is up.

  Applique type is Channelized T1

  Cablelength is short 110

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090408, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  Current port master clock:recovered from backplane

  Data in current interval (137 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     19 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     19 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Re: Errors on Point to Point T1's - 2811 - Timing issue?

Now that you’ve reset the clocking, try and bounce the router as well. I’ve seen clock issues not get “fixed” until a hard reboot.

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

I just rebooted the router, and cleared the counters again.  I'm still picking up a bunch of errors:

T1 1/0/0 is up.

  Applique type is Channelized T1

  Cablelength is long 0db

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090408, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.

  Current port master clock:recovered from backplane

  Data in current interval (143 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     18 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     18 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 1/0/1 is up.

  Applique type is Channelized T1

  Cablelength is short 110

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090408, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  Current port master clock:recovered from backplane

  Data in current interval (143 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     20 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     20 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Re: Errors on Point to Point T1's - 2811 - Timing issue?

I’ve been busy this morning and haven’t really read through all the interim emails, but as I recall you have a pair of T-1s at the branch, and a DS3 or something like that at the main location. Is that correct? If it is, then normally the telco is responsible for sending clock timing down the line. You have the branch router set to accept clock on the line. It looks like the telco is not sending clocking, or there is some other physical/logical issue. Basically, I’d bet you don’t have a Cisco problem, you’ve got a telco problem.

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

You are correct.  2 PTP T1's at the remote location, on the 2811, and 1 DS3 on a 7200 at my location.

I spent a bit of time talking to Qwest (the telco provider), and they say they tested everything fine back to my equipment.  I know they don't necisarilly use the same nomenclature as I do.  But they said it was probably a "timing" issue on my equipment.

Bronze

Errors on Point to Point T1's - 2811 - Timing issue?

also let me know if you had a chance to change the cable from router to the smart jack.

Re: Errors on Point to Point T1's - 2811 - Timing issue?

What do the controllers on the 7200 show? You're generating clocking on the 2811. Do you have clock source line on the 7200?

Sent from Cisco Technical Support iPad App

Gold

Errors on Point to Point T1's - 2811 - Timing issue?

As a general rule, only use internal timing for links like this when you are in a back to back mode, or if for some reason the LEC is just providing copper.the fact that one link does not error is more a function  of luck.

Switch both to take clock from the network.

New Member

Errors on Point to Point T1's - 2811 - Timing issue?

I think the point to point T1 is just copper.  I don't think they provide clock.  I just double checked my 7200, where the T3 terminates, and I had clock set to line there.  I think that might need to be set to internal, since it's where all my point to point T1's terminate.

I set it to clock source internal

and set my P2P T1's to clock source line

After making that change, I'm still getting lots of slip seconds.  But I haven't had a chance to hard bounce the routers yet.  I don't know that will make a difference or not.

Does that sound right to everyone?  If they are just providing copper, I should have my T3 set to internal, and all my T1's set to line?

Gold

Errors on Point to Point T1's - 2811 - Timing issue?

If your T3 is functioning ok, then you are getting clocking from the provider. As far as the point to points, assuming a leased line from the telco, they should be timed from the line also.

Cisco Employee

Errors on Point to Point T1's - 2811 - Timing issue?

Paste the output of

show network-clock

also try to replace the cable from the smart jack till the routers.

input errors and crc are cause of layer one issue , if  Career has alreay tested the line upto the smart jack ,then its recommended to replace cable from smartjack till the router.

as far as the serial line is concerned, there are

19643 input errors, 19638 CRC, 0 frame, 0 overrun, 0 ignored, 487 abort

input errors and CRC are nearly equivalent , then its a layer 1 issue..

you just try to replace cables from smart jack upto the router.

also you can try to use a loopback connecter and check the VWIC2 module.

for creation of loopback you need to take a RJ 45 cable , twist the wire 1,4 and 2,5  ;plug this cable into serial port , set clock as internal and encapsulation hdlc, after that ping your local interface and then check the interface

see if this test go's clean..

3752
Views
0
Helpful
17
Replies
CreatePlease login to create content