Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ethernet over GRE tunnel doesn't recognize messages

Helllo,

I'm configuring my ASR 1000 router with an Ethernet over GRE tunnel. Anytime I sent the Ethernet over GRE messages to the tunnel, the ASR router didn't recognize the messages were sent over the GRE tunnel. The ASR said that the messages were received on the LAN management interface, which was not what I intended. I'm wondering if the messages were not encapsulated correctly or I need to configure more on the ASR. I attached an ARP over GRE message capture.

 

Here is the router's log

*Jun  4 13:48:00.371: IP ARP: rcvd req src 10.14.18.1 0025.642c.4441, dst 10.14.18.152 GigabitEthernet0
*Jun  4 13:48:01.404: IP ARP: rcvd req src 10.14.18.1 0025.642c.4441, dst 10.14.18.152 GigabitEthernet0
*Jun  4 13:48:02.503: IP ARP: rcvd req src 10.14.18.1 0025.642c.4441, dst 10.14.18.152 GigabitEthernet0

 

 

Here is my ASR configuration

version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname moonstone
!
boot-start-marker
boot system flash bootflash:asr1000rp2-adventerprise.03.09.01.S.153-2.S1.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!

!
no aaa new-model
!
!
!
ip dhcp pool dhcp_over_gre_1
 network 172.16.0.0 255.255.0.0
!
ip dhcp pool dhcp_over_gre_2
 network 212.1.0.0 255.255.0.0
!
ip dhcp pool dhcp_over_gre_3
 network 200.1.0.0 255.255.0.0
!

multilink bundle-name authenticated
!
!
spanning-tree extend system-id
!

redundancy
 mode sso
!
!
!
ip ftp source-interface GigabitEthernet0
ip tftp source-interface GigabitEthernet0
!
!
interface Loopback0
 ip address 130.130.130.130 255.255.255.255
!
interface Tunnel0
 mac-address 0000.5e00.0001
 ip address 172.16.1.1 255.255.255.0
 no ip redirects
 tunnel source TenGigabitEthernet1/0/0
 tunnel mode ethernet gre ipv4
!
interface GigabitEthernet0/0/0
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/1
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/2
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/3
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/4
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/5
 ip address 70.0.1.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet0/0/6
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/7
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/8
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface GigabitEthernet0/0/9
 no ip address
 ip broadcast-address 0.0.0.0
 negotiation auto
!
interface TenGigabitEthernet1/0/0
 ip address 200.1.1.1 255.255.255.0
!
interface TenGigabitEthernet1/0/0.2
 encapsulation dot1Q 2
!
interface TenGigabitEthernet2/0/0
 ip address 212.1.1.1 255.255.255.0
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 10.14.18.130 255.255.255.0

 negotiation auto
 no mop enabled
!
router ospf 9
 network 70.0.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
ip route vrf Mgmt-intf 10.14.0.0 255.255.0.0 10.14.18.1
ip route vrf Mgmt-intf 10.15.0.0 255.255.0.0 10.14.18.1
!
!
control-plane
!

!
line con 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password spirent
 login
!
!
end

 

 

Everyone's tags (1)
5 REPLIES

HelloYou could try using the

Hello

You could try using the gre ip mode instead and allow for the fragmentation regards the gre overhead.

Also i dont see the tunnel ip subnet or the physical interface being advertised for readability either by static or dynamic addressing..

 

int interface Tunnel0
ip mtu 1400
ip tcp adjust-mss 1360
tunnel mode gre ip
 

res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi Paul, My test needs the

Hi Paul,

 

My test needs the tunnel mode to be Ethernet over GRE. How do I set up so the tunnel ip subnet and the physical interface are reachable?

 

Regards,

Don

Hi,Not sure about your

Hi,

Not sure about your diagram, please send your full topology diagram , moreover, see this link , how to configure ethernet over gre. i think you are missing something.

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/interface/configuration/xe-3s/ir-xe-3s-book/ir-eogre.html#task_82FE2071B9804F118B0BF4AA3D6A8500

Regards,

kazim

"please rate me if post helpful"

New Member

I was following the same link

I was following the same link but didn't get far. I'm wondering what kind of encapsulation the ARP packet should have when it arrives at the ASR physical interface. As you can see in the attachment, the ARP message has this format: (GRE) Ethernet header -> (GRE) IP header -> GRE -> (ARP) Ethernet header -> ARP. Can I use this encapsulation (Physical) Ethernet header -> (Physical) IP header -> (GRE) Ethernet header -> (GRE) IP header -> GRE -> (ARP) Ethernet header -> ARP?

New Member

I figured out what the

I figured out what the problem is. I sent the GRE encapsulated messages to the wrong address. It’s not the address on the GRE tunnel. It has to be the address of the tunnel source. Thanks for you guys time!

230
Views
8
Helpful
5
Replies
CreatePlease login to create content