Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

EVN design - route replication

Hi,

I am working the EVN design  but i am facing problem in the route replication (router leaking in VRF). I also read some cisco docs but did not get the

result.

Kindly look at below config and correct if there is any improper config

any example for EVN is helpful

sh run

Router#sh running-config

Building configuration...

Current configuration : 15692 bytes

!

! Last configuration change at 15:42:16 UTC Sat Jul 7 2012

! NVRAM config last updated at 15:08:38 UTC Sat Jul 7 2012

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service counters max age 5

!

hostname Router

!

boot-start-marker

boot system flash bootdisk:s2t54-advipservicesk9_npe-mz.SPA.150-1.SY1.bin

boot-end-marker

!

!

vrf definition green

vnet tag 20

rd 2:2

!

address-family ipv4

  route-replicate from vrf red unicast ospf 10

exit-address-family

!

vrf definition red

vnet tag 10

rd 1:1

!

address-family ipv4

  route-replicate from vrf green unicast ospf 20

exit-address-family

!

vrf list abc

member red

!

enable password cisco

!

no aaa new-model

platform ip cef load-sharing ip-only

!

ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.20.1 192.168.20.10

!

ip dhcp pool vlan10

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

!

ip dhcp pool vlan20

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

!

no ip domain-lookup

ip domain-name tera.com

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

redundancy

main-cpu

  auto-sync running-config

mode sso

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

interface GigabitEthernet7/1

no ip address

shutdown

!

interface GigabitEthernet7/2

no ip address

shutdown

!

interface GigabitEthernet7/3

no ip address

shutdown

!

interface TenGigabitEthernet7/4

no ip address

shutdown

!

interface TenGigabitEthernet7/5

no ip address

shutdown

!

interface GigabitEthernet10/1

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/2

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/3

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/4

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/5

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/6

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/7

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/8

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/9

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/10

switchport

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet10/11

no ip address

shutdown

!

interface GigabitEthernet10/12

no ip address

shutdown

!

interface GigabitEthernet10/13

switchport

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet10/14

switchport

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet10/15

no ip address

shutdown

!

interface Vlan1

ip address 192.168.100.15 255.255.255.0

!

interface Vlan10

vrf forwarding red

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

vrf forwarding green

ip address 192.168.20.1 255.255.255.0

!

interface Vlan100

ip address 192.168.1.254 255.255.255.0

!

router ospf 10 vrf red

redistribute connected subnets

redistribute vrf green ospf 20 subnets

network 192.168.10.0 0.0.0.255 area 0

!

router ospf 20 vrf green

redistribute connected subnets

redistribute vrf red ospf 10 subnets

network 192.168.20.0 0.0.0.255 area 0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

control-plane

service-policy input policy-default-autocopp

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password cisco

login

transport input all

!

ntp source Vlan100

ntp master 1

no event manager policy Mandatory.go_switchbus.tcl type system

!

end

Router#

175
Views
0
Helpful
0
Replies
CreatePlease to create content