Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Expert;HELP;URGENT PROBLEM

Hi All!

yesterday;i've configured a switch with 4 port uplink(EtherChanel)in the side access switch,the channel mode is desirable but by mistake the persom who configured in side core mode chanel is on;then when accees switch startup we have received duplicate ip address.loop,error,and all the access switch down.what is the problem here?what is happen;when we turnOff this switch every thing is fine

??????????????????????

the config was like this in the access side:

interface GigabitEthernet0/25

switchport trunk encapsulation isl

switchport mode trunk

channel-group 5 mode desirable

........................................

interface GigabitEthernet0/26

switchport trunk encapsulation isl

switchport mode trunk

channel-group 5 mode desirable

....................................

interface GigabitEthernet0/27

switchport trunk encapsulation isl

switchport mode trunk

channel-group 5 mode desirable

...................................

interface GigabitEthernet0/28

switchport trunk encapsulation isl

switchport mode trunk

channel-group 5 mode desirable

..............................................

interface Port-channel5

switchport trunk encapsulation isl

switchport mode trunk.

10xs for ur help

4 REPLIES

Re: Expert;HELP;URGENT PROBLEM

Hey there,

Check out this link:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12225see/cr/cli1.htm#wp1860162

If it's been nailed to "on" at the other end, then it'll be using EtherChannel. The ONLY command to un EtherChannel as the protocol is "on". Therefore, if you set your side to "on" - you'll be in business.

HTH if it does - give it a rating

Regads,

LH

Re: Expert;HELP;URGENT PROBLEM

PS - your "desirable" nails it to use PAgP, which will not talk to EtherChannel

New Member

Re: Expert;HELP;URGENT PROBLEM

HI All!

10xs for ur time to help me.but no body tell me why this problem occured{server no pingable;loop;duplicate ip address,this ipsubnet that appeared not exist;all access Switchs in the Enterprise down}its realy if the mode is desirable on the access switch;and mode is on on the core side;did all this problem.

PS,PS I NEED EXPLANATION WHAT HAPPEN.

10XS FOR UR HELP!

ALI

Re: Expert;HELP;URGENT PROBLEM

Hey there,

The reason it didn't work is because a link configured with "on" at one side and "desirable" at the other end will not work.

When making a port-channel, you can use different protocols to do it, similar to ISL and DOT1Q. "on" sets the protocol as EtherChannel and "desirable" sets the protocol to PAgP. The 2 protocols will not speak to eachother - so the link will never work.

Regards,

LH

Please rate all posts

92
Views
9
Helpful
4
Replies