Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

External Calling

Hi I'm trying to enable external calls currently I can call internally and receive external however I want to be able to phone out on one if not all phones connected to the network.

Below is my current config:

 

Building configuration...


Current configuration : 5655 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate wic 3
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.50
ip dhcp excluded-address 192.168.0.241 192.168.0.255
!
ip dhcp pool PHONES
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 192.168.0.5 192.168.0.6
 option 150 ip 192.168.0.17
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type basic-net3
!
cts logging verbose
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 192.168.0.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
  h245 tunnel disable
 sip
  bind control source-interface GigabitEthernet0/0
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g729br8
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 4
  call start fast
!
!
!
!
voice hunt-group 1 longest-idle
 timeout 0
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FGL173220Y3
license accept end user agreement
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.0
 duplex auto
 speed auto
!
interface ISM0/0
 description Unity-Express-Module
 ip unnumbered GigabitEthernet0/0
 ip virtual-reassembly in
 service-module ip address 192.168.0.10 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 192.168.0.17
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ISM0/1
 no ip address
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/1/0
 description Test_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn layer1-emulate network
 isdn incoming-voice voice
 isdn static-tei 0
!
interface BRI0/1/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/2/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/2/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/3/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/3/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 192.168.0.10 255.255.255.255 ISM0/0
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 description TEST_ISDN
!
voice-port 0/0/1
 input gain -6
 output attenuation -6
 echo-cancel coverage 64
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 timeouts interdigit 6
 description ***2BRI-NT/TE Port***
 bearer-cap Speech
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 2 voip
 destination-pattern 1[0-9][0-9][0-9]
 session target ipv4:162.168.0.17
!
dial-peer voice 1 pots
 destination-pattern 9.
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 destination-pattern 9T
 port 0/0/1
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 20
 max-dn 200
 ip source-address 192.168.0.17 port 2000
 network-locale GB
 load 7906 term11.default
 load 7960-7940 P0030801SR02
 load 6921 SCCP69xx.9-2-1-0
 load 6941 SCCP69xx.9-2-1-0
 max-conferences 8 gain -6
 web admin system name alex secret 5 $1$eSOq$7L1LD5IBwR3F5v0.3gc3i1
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1
 number 1001
 name ***Black 6941 ***
!
!
ephone-dn  2
 number 1002
 name ***6921 v1***
!
!
ephone-dn  3
 number 1003
 name ***6921 v2***
!
!
ephone-dn  4
 number 1004
 name ***Big Bertha***
!
!
ephone  1
 mac-address E8B7.484E.8483
 type 6941
 button  1:1
!
!
!
ephone  2
 mac-address 8478.ACC7.13C0
 type 6941
 button  1:2
!
!
!
ephone  3
 mac-address 8478.ACC7.13A4
 type 6921
 button  1:3
!
!
!
ephone  4
 mac-address 0023.5E18.A3AA
 type 7940
 button  1:4
!
!
ephone-hunt 1 longest-idle
 pilot 619879
 list 1001, 1002, 1003
!
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Basically you need a dial

Basically you need a dial peer setup for outside calls.

 

Take a look at this page: http://routerjockey.com/2009/09/08/cisco-voip-basics-cisco-dial-plans/

 

That will allow you to call out. 

 

For instance, this would allow for calls out with a 10 digit, outside number:

 

dial-peer voice 100 pots
 description outbound dialpeer 1
 preference 7
 destination-pattern 1[2-9].........
 port 2/0
 forward-digits all


Hope that helps!

^Edit - probably should have mentioned that will need to be adapted to your location as far as port number, etc. That is a pull from one of my setups. Thanks

New Member

You will need a specific dial

You will need a specific dial peer for your situation. What number are you dialing in order to dial outside numbers? Your destination pattern will need to include the exit digit as well as 10 digits or wildcards. For example: "destination-pattern 9.........." would mean that you dial 9 to get an outside line then any 10 digits that follows would be allowed. This link has a few examples:

http://www.cisco.com/c/en/us/td/docs/ios/12_2/voice/configuration/guide/fvvfax_c/vvfpeers.html

Also make sure you are only sending the service provider 10 digits. "forward-digits 10"

You may also want to check with your service provider to make sure you are allowed to dial out on those lines. 

Good Luck.

3 REPLIES
New Member

Basically you need a dial

Basically you need a dial peer setup for outside calls.

 

Take a look at this page: http://routerjockey.com/2009/09/08/cisco-voip-basics-cisco-dial-plans/

 

That will allow you to call out. 

 

For instance, this would allow for calls out with a 10 digit, outside number:

 

dial-peer voice 100 pots
 description outbound dialpeer 1
 preference 7
 destination-pattern 1[2-9].........
 port 2/0
 forward-digits all


Hope that helps!

^Edit - probably should have mentioned that will need to be adapted to your location as far as port number, etc. That is a pull from one of my setups. Thanks

New Member

Have tried adding however

Have tried adding however still getting an engaged tone. Below is my latest config can anyone help?

 

Building configuration...


Current configuration : 5860 bytes
!
! Last configuration change at 10:37:45 UTC Wed Jan 21 2015
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate wic 3
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.50
ip dhcp excluded-address 192.168.0.241 192.168.0.255
!
ip dhcp pool PHONES
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 192.168.0.5 192.168.0.6
 option 150 ip 192.168.0.17
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type basic-net3
!
cts logging verbose
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 192.168.0.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
  h245 tunnel disable
 sip
  bind control source-interface GigabitEthernet0/0
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g729br8
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 4
  call start fast
!
!
!
!
voice hunt-group 1 longest-idle
 timeout 0
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FGL173220Y3
license accept end user agreement
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.0
 duplex auto
 speed auto
!
interface ISM0/0
 description Unity-Express-Module
 ip unnumbered GigabitEthernet0/0
 ip virtual-reassembly in
 service-module ip address 192.168.0.10 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 192.168.0.17
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ISM0/1
 no ip address
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/1/0
 description Test_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn layer1-emulate network
 isdn incoming-voice voice
 isdn static-tei 0
!
interface BRI0/1/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/2/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/2/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/3/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/3/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 192.168.0.10 255.255.255.255 ISM0/0
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 description TEST_ISDN
!
voice-port 0/0/1
 input gain -6
 output attenuation -6
 echo-cancel coverage 64
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 timeouts interdigit 6
 description ***2BRI-NT/TE Port***
 bearer-cap Speech
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 2 voip
 destination-pattern 1[0-9][0-9][0-9]
 session target ipv4:162.168.0.17
!
dial-peer voice 1 pots
 destination-pattern 9.
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 destination-pattern 9T
 port 0/0/1
!
dial-peer voice 100 pots
 description outbound dialpeer 1
 preference 7
 destination-pattern 1[2-9].........
 port 0/0/0
 forward-digits all
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 20
 max-dn 200
 ip source-address 192.168.0.17 port 2000
 network-locale GB
 load 7906 term11.default
 load 7960-7940 P0030801SR02
 load 6921 SCCP69xx.9-2-1-0
 load 6941 SCCP69xx.9-2-1-0
 max-conferences 8 gain -6
 web admin system name alex secret 5 $1$eSOq$7L1LD5IBwR3F5v0.3gc3i1
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1
 number 1001
 name ***Black 6941 ***
!
!
ephone-dn  2
 number 1002
 name ***6921 v1***
!
!
ephone-dn  3
 number 1003
 name ***6921 v2***
!
!
ephone-dn  4
 number 1004
 name ***Big Bertha***
!
!
ephone  1
 mac-address E8B7.484E.8483
 type 6941
 button  1:1
!
!
!
ephone  2
 mac-address 8478.ACC7.13C0
 type 6941
 button  1:2
!
!
!
ephone  3
 mac-address 8478.ACC7.13A4
 type 6921
 button  1:3
!
!
!
ephone  4
 mac-address 0023.5E18.A3AA
 type 7940
 button  1:4
!
!
ephone-hunt 1 longest-idle
 pilot 619879
 list 1001, 1002, 1003
!
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end

 

New Member

You will need a specific dial

You will need a specific dial peer for your situation. What number are you dialing in order to dial outside numbers? Your destination pattern will need to include the exit digit as well as 10 digits or wildcards. For example: "destination-pattern 9.........." would mean that you dial 9 to get an outside line then any 10 digits that follows would be allowed. This link has a few examples:

http://www.cisco.com/c/en/us/td/docs/ios/12_2/voice/configuration/guide/fvvfax_c/vvfpeers.html

Also make sure you are only sending the service provider 10 digits. "forward-digits 10"

You may also want to check with your service provider to make sure you are allowed to dial out on those lines. 

Good Luck.

131
Views
0
Helpful
3
Replies