Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Failover WAN on 881 using Fast4 and VLAN on Fast3

I am looking for confirmation that I can use an interface other than the fastethernet4 as my ip nat outside on an 881.

Background:

We use 881g with the fast4 and cellular0 interfacs for WAN failover and wanted to do the same on an 881 without the wireless card.  We want to use fast4 as our primary WAN connection to the Internet and use VLAN3 on an interface on the 4 port switch.

The configuration commands do not error, but we get no nat trans via the outside interface if it is the VLAN based interface.

It seems therre maybe a limitation on this functionality but I do not see why this should be.

Here is the relevant info:

interface FastEthernet0

spanning-tree portfast

!

!

interface FastEthernet1

spanning-tree portfast

!       

!

interface FastEthernet2

spanning-tree portfast

!

!

interface FastEthernet3

switchport access vlan 3

spanning-tree portfast

!

!

interface FastEthernet4

description Comcast Cable Internet

ip address dhcp

ip nat outside

ip virtual-reassembly

zone-member security zone-outside

duplex auto

speed auto

!

!

interface Vlan1

description inside

ip address 192.168.40.1 255.255.255.0

ip nat inside

ip virtual-reassembly

zone-member security zone-inside

ip tcp adjust-mss 1452

!

!

!

interface Vlan3

description BACKUP Internet

ip address 64.xxx.xxx.xxx 255.255.255.248

ip nat outside

ip virtual-reassembly

zone-member security zone-outside

!

I have correct route-maps for nat and an sla/track.  Again, these concepts are proven on an 881g.  I cannot find a statement that says you cannot use a vlan as the outside.  The router itself can use the vlan3 backup just fine, it is NAT that fails.  Perhaps an 891 with GE/FE on the WAN is the only way to do this.

Thanks in advance!

1 REPLY
Purple

Failover WAN on 881 using Fast4 and VLAN on Fast3

Hi,

Perhaps an 891 with GE/FE on the WAN is the only way to do this.

I think so ,yes

Regards.

Alain

Don't forget to rate helpful posts.
303
Views
0
Helpful
1
Replies