Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Filter connected interface from EIGRP

How do you filter a connected interface from EIGRP even though it is defined on the network command?

Example:
interface vlan 100
ip address 10.1.1.1 255.255.255.0

router eigrp 1
passive-interface default
network 10.0.0.0 0.255.255.255

How do I filter 10.1.1.0 255.255.255.0 from participating in EIGRP 1?  Network command can not be modified.

THanks,

3 REPLIES

Filter connected interface from EIGRP

Hi,

You mean not to advertise 10.1.1.0/24 via eigrp? I guess you can use prefix list to deny 10.1.1.0/24 and allow all others in the the eigrp process. Correct me if I got your question wrong.

Thx

MS

New Member

Filter connected interface from EIGRP

Yes.  Is this possible?  Will it impact any other routes on other interfaces?

Access-list 20 deny any

Router eigrp 1

Distribute-list 20 in vlan 100

Thanks,

Filter connected interface from EIGRP

It should work...

ip prefix-list EIGRP_OUT seq 5 deny 10.1.1.0/24

ip prefix-list EIGRP_OUT seq 10 permit 0.0.0.0/0 le 32

!

router eigrp

distribute-list prefix EIGRP_OUT out

!

hth

MS

135
Views
0
Helpful
3
Replies