Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Flash dies while applying QOS

This happened for couple of routers in a row which never happened before. I have been updating QOS policy on the router applying reload command. Since, I lost the connectivity with the routers I was thinking the router will reload with the old configs in 10 mins and will come online and started applying the same QOS on the other router. While updating QOS the second router also lost connectivity and i waited for 20 mins and both the router didn't come in online and atlast I came to know routers flash is dead.

It?s a 877 router with the IOS ?c870-advipservicesk9-mz.124-9.T?. Did any one have came across similar situation or is the ISO is a buggy version ?? It will be of great, if some one let me know.

Thanks

Rajesh

10 REPLIES

Re: Flash dies while applying QOS

Hi Rajesh

you need to check the status of the remote router whether its stuck up in rommon mode or looping..

You can find out the exact reason once you get onto the console .

regds

New Member

Re: Flash dies while applying QOS

Prem,

The remote router get strucks up in the rommon mode and its not looping.

Prem, i also don't understand what you mean by "You can find out the exact reason once you get onto the console" ?? Can you explain me better.

Thanks

Rajesh

Re: Flash dies while applying QOS

Hi Rajesh

Untill unless you have the access to the router you wont be able to find out the exact state of the router.

Since its not coming up the only way out there is to login onto the console through which you can identify whether your router is looping or on rommon mode.

Can you post the ios code which you are running in your box and also the ram/flash size installed in your router..

Also can you check out for the config register available and change it accordingly ?

regds

New Member

Re: Flash dies while applying QOS

Prem,

I will be getting the router in couple of days. Then I will console and have a look and get the needed info you ware asking about. (Since, at the moment i was told that its going to rommon mode)

Anyhow thanks for your help and letz see how it goes.

Thanks

Rajesh

New Member

Re: Flash dies while applying QOS

Hi Rajesh,

I run into the same bug some time ago whilst running 124-4T2, please see the attached url;

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddb41bb

I opened up a TAC and had to wait for a time until they had a fix for me.

If you upgrade to 124-9.T1 you should be OK as I am now running this IOS on my 877's with the service-policy applied to the dialer interface and all is OK.

If your router drops into ROM monitor and you are unable to boot from flash then you can always tftpdnld a new IOS into flash.

New Member

Re: Flash dies while applying QOS

I got the router with me, when i consoled i am getting the following message. This happened to 3 routers in a row. With this output if some one has any idea kindly let me know.

System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2005 by cisco Systems, Inc.

C870 series (Board ID: 1-148) platform with 131072 Kbytes of main memory

flashfs[0]: unable to allocate available block.

flash: file system initialization failed

Could not open boot directory: flash:/

Unable to open boot file

System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2005 by cisco Systems, Inc.

C870 series (Board ID: 1-148) platform with 131072 Kbytes of main memory

flashfs[0]: unable to allocate available block.

flash: file system initialization failed

Could not open boot directory: flash:/

Unable to open boot file

System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2005 by cisco Systems, Inc.

C870 series (Board ID: 1-148) platform with 131072 Kbytes of main memory

rommon 1 >

Re: Flash dies while applying QOS

Hi

AFAIK you need to format the flas from the rommon prompt itself and need to upload the ios again.

Also find the below link which talks similar kinda problem..

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddc9f45

regds

New Member

Re: Flash dies while applying QOS

Prem,

Already i formated the flash, and loaded the new IOS and its all fine now.

My concern is, while applying the QOS for remote sites and if the flash dies as it happened earlier its not good. I think you can understand what i mean.

Is there is any reason, why some of the router goes to rommon while applying QOS??? I was applying the similar QOS for all the remote sites (877 routers, IOS : c870-advipservicesk9-mz.124-9.T) and few got me to this problem.

Thanks

Rajesh

Re: Flash dies while applying QOS

Hi

Can you post the configuration of your router here ?

regds

New Member

Re: Flash dies while applying QOS

Hi Prem,

I am have attached the QOS bit in which we experianced issues with the router flash memory.

class-map match-any VOIP

match precedence 5

match access-group 110

policy-map OUTBOUND

class VOIP

priority percent 50

class class-default

fair-queue

interface ATM0.1 point-to-point

description XXXXXX

bandwidth XXX

pvc 8/35

vbr-nrt XXX XXX 1

tx-ring-limit 3

encapsulation aal5mux ppp dialer

dialer pool-member 1

service-policy output OUTBOUND

interface Dialer1

bandwidth XXX

ip address negotiated

ip nat outside

no ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname XXXXXXXXXXXX

ppp chap password XXXXXXXXXXXX

Unless or otherwise specifically asked about this line "tx-ring-limit 3" we never use this.

Thanks

Rajesh

243
Views
0
Helpful
10
Replies
CreatePlease to create content