Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

flash

Dear all,

I am trying to upload the IOS in cisco 2610XM router . I am able to upload the IOS but at end, some checksum error is coming. When I run sh flash: command it shows file has been uploaded but at end shows { invalid checksum } .

I want to run verify flash : command to find out whether there is a problem wth IOs uploaded .

Can somebody tell me syntax since when I am running this command I am getting erro message " Erro opening file "

regds,

Aman

5 REPLIES

Re: flash

Hi

(1)To check a file is ok, the you need to run it directly from RAM.I believe you must be using :tftpdnld" command to upload IOS.Pls add r to it "tftpdnld -r" to load the IOS to RAM.The router will boot without a valid IOS is flash.

(2)Once you have booted the router, then erase flash and try to load again.

(3)If 1st step is unsucessful, the you have invalid IOS.If second step is unsucessful then flash has problem.

Pls rate helpful posts.

Regards

JD

New Member

Re: flash

DEar JD,

I have uploaded the IOS through Tftp. What my concern is that what I have uploaded is correct image or not...?

I want to check the same through verify flash:IOs name which is not working .Is there any command which u can tell me ..

regds,

aman

Re: flash

Hi

(1)First of all you need to check the intigrity to the IOS file.To achieve it, you need to run a MD5 check of it using the key available with every cisco download.

(2)Have you tried loading the IOS to RAM?

Regards

JD

Re: flash

Hi,

Try formatting the flash once and then upload the IOS.

See more information on this link

http://www.cisco.com/en/US/products/hw/routers/ps259/products_configuration_guide_chapter09186a008007e5fb.html

If it doesn't work even after that then you probably have a corrupted FLash. Raise an RMA if you a vlaid contract

New Member

Re: flash

Dear All,

I have conculded that there is problem with on board flash of router .

I have tried running verify flash on working router where in I get the message Verified Flash which means flash is fine .

Anyway , thanks a lot for support...

regds,

Aman

100
Views
0
Helpful
5
Replies