cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
1166
Views
0
Helpful
3
Replies

Floating Static Route - SLA Problem

OliverDarvall
Level 1
Level 1

Guys,

I have a Cisco 1841 with a DSL and 3G HWIC interface. I would like to setup  the DSL as the primary link and then use the 3G as a backup interface. I am trying to accomplish this using the Floating Static routes with SLA object tracking.

I have tried various options, like having two tracked routes, one tracked route, changing administrative distances, multiple SLA's, etc etc.

My problem basically is that when the DSL (Dialer0) goes down and the 3G (Cellular0/1/0) takes over, that the SLA never changes back when the DSL is available again, so that the DSL can take over as the primary link again.

My current config:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router_hostname

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

no logging buffered

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

!

no ip cef

ip domain name dyndns.org

ip ddns update method ccp_ddns1

! my_dyndns_details

!

no ipv6 cef

!

multilink bundle-name authenticated

!

chat-script gsm "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"

!

!

track 1 ip sla 1 reachability

!

track 2 list boolean and

object 1 not

!

!

!

interface Loopback0

ip address 50.35.8.1 255.255.255.255

!

interface FastEthernet0/0

description $ETH-LAN$

ip address 40.35.8.1 255.255.255.128

ip tcp adjust-mss 1412

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

pvc 8/35

  pppoe-client dial-pool-number 1

!

!

interface Cellular0/1/0

ip address negotiated

encapsulation ppp

dialer in-band

dialer string gsm

dialer-group 1

async mode interactive

ppp chap hostname uid

ppp chap password 0 pwd

ppp ipcp dns request

!

interface Dialer0

ip ddns update ccp_ddns1

ip address negotiated

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname my_hostname

ppp chap password 0 m_password

ppp pap sent-username my_hostname password 0 my_password

ppp ipcp dns request

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 10 track 2

ip route 0.0.0.0 0.0.0.0 Dialer0 20 permanent

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

ip sla 1

icmp-echo 196.25.1.1 source-interface Dialer0

timeout 10000

threshold 55

ip sla schedule 1 life forever start-time now

dialer-list 1 protocol ip permit

!

!

!

control-plane

!

!

!

line con 0

speed 115200

line aux 0

line 0/1/0

script dialer gsm

modem InOut

no exec

transport input all

speed 384000

line vty 0 4

login local

transport input telnet

!

scheduler allocate 20000 1000

end !
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router_hostname
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
no ip cef
ip domain name dyndns.org
ip ddns update method ccp_ddns1
! my_dyndns_details
!
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"
!
!
track 1 ip sla 1 reachability
!
track 2 list boolean and
object 1 not
!
!
!
interface Loopback0
ip address 50.35.8.1 255.255.255.255
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 40.35.8.1 255.255.255.128
ip tcp adjust-mss 1412
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
pvc 8/35
  pppoe-client dial-pool-number 1
!
!
interface Cellular0/1/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname uid
ppp chap password 0 pwd
ppp ipcp dns request
!
interface Dialer0
ip ddns update ccp_ddns1
ip address negotiated
ip mtu 1452
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname my_hostname
ppp chap password 0 m_password
ppp pap sent-username my_hostname password 0 my_password
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer0 20 permanent
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
ip sla 1
icmp-echo 196.25.1.1 source-interface Dialer0
timeout 10000
threshold 55
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
speed 115200
line aux 0
line 0/1/0
script dialer gsm
modem InOut
no exec
transport input all
speed 384000
line vty 0 4
login local
transport input telnet
!
scheduler allocate 20000 1000
end

3 Replies 3

ammahend
VIP
VIP

can you help me understanding how are you testing this.

I did a similar test with 2 serials configured in same fashion with 1841 (flash:c1841c-advipservicesk9mz.150-1.M5.bin"),

it works perfectly fine.

Ambuj

-hope this helps-

rupertsedgwick
Level 1
Level 1

Hi

You are removing the route for cellular when you are tracking the ATM route.

Your cellular interface should be a permanent route with the higher metric while your dialer route should have the track on it with a lower metric

Sent from Cisco Technical Support iPhone App

OliverDarvall
Level 1
Level 1

I managed to resolve this eventually. I added a permanent static route to the IP being tested in the SLA :

     ip route 196.25.1.1 255.255.255.255 Dialer0 permanent

My SLA has been working fine since then ...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: