Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Force a specific route for destination ip with route-map

Hi,

I'm using, on a 2600 Cisco Router, route-map command to have load balancing on two WAN interfaces (ethernet).

My configuration is this:

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 151.x.x.x

ip route 0.0.0.0 0.0.0.0 88.x.x.x

!

no ip http server

no ip http secure-server

ip nat inside source static tcp 192.168.27.100 1723 interface Ethernet1/0 1723

ip nat inside source static tcp 192.168.27.100 443 interface Ethernet1/0 443

ip nat inside source static tcp 192.168.27.101 1723 interface FastEthernet0/1 1723

ip nat inside source static tcp 192.168.27.101 443 interface FastEthernet0/1 443

ip nat inside source route-map Telecom-ISP interface Ethernet1/0 overload

ip nat inside source route-map Wind-ISP interface FastEthernet0/1 overload

!

ip access-list extended TRAFFIC-FROM-192.168.27.100

permit tcp host 192.168.27.100 eq 443 any

permit tcp host 192.168.27.100 eq 1723 any

ip access-list extended TRAFFIC-FROM-192.168.27.101

permit tcp host 192.168.27.101 eq 443 any

permit tcp host 192.168.27.101 eq 1723 any

!

access-list 110 permit ip 192.168.27.0 0.0.0.255 any

route-map Telecom-ISP permit 10

match ip address 110

match interface Ethernet1/0

set ip default next-hop 88.x.x.x

!

route-map Wind-ISP permit 10

match ip address 110

match interface FastEthernet0/1

set ip default next-hop 151.x.x.x

!

route-map STATIC-NAT permit 10

match ip address TRAFFIC-FROM-192.168.27.101

set interface FastEthernet0/1

!

route-map STATIC-NAT permit 20

match ip address TRAFFIC-FROM-192.168.27.100

set interface Ethernet1/0

How can I do do force a particulary ip destination, to use always Ethernet1/0 inteface?

Thanks

Everyone's tags (2)
8 REPLIES
New Member

Hi massimiliano,Creat a route

Hi massimiliano,

Call you router map on ingress interface, it will puch your traffic toword destination ip address via e1/0 because you set ip next-hope under route-map.

Hi,thanks for your answer,

Hi,

thanks for your answer, but is not clear for me.

Can you tell me the command to use to call router map in "ingress" interface?

What's the meaning for "puch your traffic toword destination".

For example if I want to force this ip destination 173.194.116.23 -> Ethernet1/0...what's the configuration?

Thanks

New Member

Do you want to force (push)

Do you want to force (push) all ingress traffic towards ip destination 173.194.116.23 via Ethernet 1/0?

Yes.Could I use this:access

Yes.

Could I use this:

access-list 120 permit ip 192.168.27.0 0.0.0.255 172.194.116.23 255.255.255.255 
route-map FORCE-IP-ADDRESS permit 5 
 match ip address 120
 match interface Ethernet1/0
 set ip default next-hop 88.x.x.x

?

Thanks

wrong ACL...better:access

wrong ACL...better:

access-list 120 permit ip any host 173.194.116.23

route-map FORCE-IP-ADDRESS permit 5 
 match ip address 120
 match interface Ethernet1/0
 set ip default next-hop 88.x.x.x

do you think it should work?

New Member

massimiliano,

massimiliano,

If you need to forward you all ingress traffic towards destination via e 1/0, you have to follow below config exmple:

interface Ethernet1/1 >>>>> ingress interface
 ip address 192.168.27.1 255.255.255.0
 ip policy route-map test
!
interface Etnernet1/0 >>>> egress interface
 ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
 ip address 20.20.20.1 255.255.255.0
!
access-list 100 permit ip 192.168.27.0 0.0.0.255 host 173.194.116.23
!
route-map test permit 10
 match ip address 100
 set ip default next-hop 10.10.10.2

Now your ingress traffic will force to ethernet 1/0 for destination ip 173.194.116.23

It works! But I had an other

It works! But I had an other

ip policy route-map

on inteface Ethernet 1/1

When I added the new ip policy map it removed the old. What can I do to have on the same interface both the policy map? Is there a way to use more than one policy map on the same interface or I've to create an unique policy map with all the conditions?

For example if I have to force an other ip addres on that route:

access-list 110 permit ip 192.168.27.0 0.0.0.255 host 173.194.116.24
!
route-map test2 permit 10
 match ip address 110
 set ip default next-hop 10.10.10.2

Thanks

Bye

New Member

 Massi,Second one is right

 Massi,

Second one is right option, you should use unique route map with all conditions, Infact I configured it at some where else and its working fine. Try it and let me know if you have still an issue

3901
Views
0
Helpful
8
Replies
CreatePlease to create content