Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

frame-relay cant ping from pont to point to multipoint

hi all,ive set up a frame relay lab using a fr switch for multi point  also have set up a point to point through the switch to 1 of the mp  routers(drawing of topology to be added),the pvcs work and i can ping  from first router to both multi points and from multi r1 to multi r2 and  can ping the point to point link 2 but cannot ping between p2p and  multi point

can ping from r1s0/0.102-103(191.168.123.1)191.168.123.2 s0.201 and 3(multi point) 301

and can ping from r1(191.168.12.1)s0/0.112 to r2 191.16812.2 211 s0/0.211

but cannot ping from 191.168.123.3 to 191.168.12.2

heres the show run from all 3 routers and fr switch

R1

!

version 12.3

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname tewys-comm-server

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Shr4$9O6/xjfAwHjxpmjcxD0c..

!

username chris secret 5 $1$eys4$LG5zu.XkuVocDQCma1X070

username cisco password 7 13061B13181F

no aaa new-model

ip subnet-zero

ip domain list cisco.com

no ip domain lookup

ip host 3620-2 2002 172.21.1.1

ip host 2620-rj 2003 172.21.1.1

ip host 3640-1 2001 172.21.1.1

ip host SW1-1 2004 172.21.1.1

ip host SW3-3 2005 172.21.1.1

ip host 3640-rj 2003 172.21.1.1

ip host 2621-1 2001 172.21.1.1

ip host 2950-1 2004 172.21.1.1

ip host 2950-2 2005 172.21.1.1

ip host 2950-3 2006 172.21.1.1

ip host 3600-3 2014 172.21.1.1

ip host 3600-2 2013 172.21.1.1

ip host 5200-1 2010 172.21.1.1

ip host 2600-1 2008 172.21.1.1

ip host 2509-1 2007 172.21.1.1

ip host 4500-1 2015 172.21.1.1

ip host 3600-1 2012 172.21.1.1

ip host 2600-r2 2002 172.21.1.1

ip host 3640-r3 2003 172.21.1.1

ip host 2621-r1 2001 172.21.1.1

ip host 5200-2 2011 172.21.1.1

ip host 2950-sw3 2004 172.21.1.1

ip host 2950-sw2 2005 172.21.1.1

ip host 2600-2 2009 172.21.1.1

ip host 2950-sw1 2006 172.21.1.1

ip host pix-1 2016 172.21.1.1

!

!

!

!

interface Loopback0

ip address 172.21.1.1 255.0.0.0

!

interface Loopback1

no ip address

!

interface Ethernet0

ip address 171.123.1.1 255.255.255.0

no ip mroute-cache

!

interface Serial0

no ip address

no ip split-horizon

encapsulation frame-relay

no ip mroute-cache

no fair-queue

!

interface Serial0.102 multipoint

ip address 191.168.123.1 255.255.255.0

frame-relay map ip 191.168.123.2 102 broadcast

frame-relay map ip 191.168.123.3 103 broadcast

!

interface Serial0.112 point-to-point

ip address 191.168.12.1 255.255.255.0

frame-relay interface-dlci 112  

!

interface Serial1

no ip address

shutdown

!

router eigrp 10

network 171.123.1.0 0.0.0.255

network 191.168.12.0 0.0.0.255

network 191.168.123.0 0.0.0.255

auto-summary

!

ip default-gateway 171.55.31.1

no ip http server

ip classless

!

!

!

alias exec c copy run start

!

line con 0

exec-timeout 0 0

logging synchronous

transport preferred telnet

line 1 16

session-timeout 20

exec-timeout 0 0

no exec

transport input telnet

line aux 0

logging synchronous

transport preferred telnet

transport input all

speed 38400

flowcontrol hardware

line vty 0 4

exec-timeout 60 0

password 7 13061E01080344

logging synchronous

login

!

end

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

frame-relay cant ping from pont to point to multipoint

Hi,

1)on the FR switch, no need for any routing protocol as well as FR mappings, this is just a switch.

   But it is not configured as a FR relay switch in the output config you posted ? where is this part of the config

2) on R1: on the multipoint subnet  you must have s0.103 pointing to R3 and not s0.102 which is already pointing to R2

      if you want to use a FR switch

3) split-horizon problem symptom is the spokes see the hub routes but not the other spokes routes so on the hub which should be R1 you have to disable split-horizon for the EIGRP process with the no ip split-horizon eigrp x interface command.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
8 REPLIES
New Member

frame-relay cant ping from pont to point to multipoint

sorry its like this but couldnt paste all in 1 post for some reason#

R2

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname BERLIN

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$M.5O$tU0pO7ImmP4A/X9Yj1K5y/

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

no ip domain lookup

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

no dce-terminal-timing-enable

!

interface Serial0/0.201 multipoint

ip address 191.168.123.2 255.255.255.0

frame-relay map ip 191.168.123.1 201 broadcast

frame-relay map ip 191.168.123.3 201 broadcast

!

interface Serial0/0.211 point-to-point

ip address 191.168.12.2 255.255.255.0

frame-relay interface-dlci 211  

!

router eigrp 10

network 191.168.12.0 0.0.0.255

network 191.168.123.0 0.0.0.255

auto-summary

!

!

ip http server

!

!

!

control-plane

!

banner login


C

*****************************************************

!!!!!!!!!!GET OFF MY FUCKIN ROUTER OR U DIE!!!!!!!!!!

*****************************************************


alias exec c copy run start

!

line con 0

exec-timeout 0 0

password 7 0822455D0A16

logging synchronous

login

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 01100F175804

logging synchronous

login

!

!

end

New Member

frame-relay cant ping from pont to point to multipoint

!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname STOCKHOLM
!
enable secret 5 $1$cK6v$GLqiVXDPgi2Kuz5hPbu7M.
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 194.111.0.1 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.301 multipoint
ip address 191.168.123.3 255.255.255.0
frame-relay map ip 191.168.123.1 301 broadcast
frame-relay map ip 191.168.123.2 301 broadcast
!
interface Serial1
no ip address
shutdown
!
router eigrp 10
network 191.168.0.0
network 194.111.0.0
!
ip http server
ip classless
banner login


C

*****************************************************

*****************************************************


alias exec c copy run start

!

line con 0

exec-timeout 0 0

password 7 05080F1C2243

logging synchronous

login

line 1 16

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 030752180500

logging synchronous

login

!

end

New Member

Re: frame-relay cant ping from pont to point to multipoint

raame-relay switch

!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname STOCKHOLM
!
enable secret 5 $1$cK6v$GLqiVXDPgi2Kuz5hPbu7M.
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 194.111.0.1 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.301 multipoint
ip address 191.168.123.3 255.255.255.0
frame-relay map ip 191.168.123.1 301 broadcast
frame-relay map ip 191.168.123.2 301 broadcast
!
interface Serial1
no ip address
shutdown
!
router eigrp 10
network 191.168.0.0
network 194.111.0.0
!
ip http server
ip classless
banner login


C

*****************************************************

!!!!!!!!!!GET OFF MY  ROUTER OR U DIE!!!!!!!!!!

*****************************************************


alias exec c copy run start

!

line con 0

exec-timeout 0 0

password 7 05080F1C2243

logging synchronous

login

line 1 16

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 030752180500

logging synchronous

login

!

end

any ideas thanks

thanks chris

Purple

frame-relay cant ping from pont to point to multipoint

Hi,

you surely have a problem with EIGRP split-horizon( but I just took a quick look at the configs and diagram).

Can you post output of sh ip route eigrp on all routers as well as sh ip eigrp neigh

Regards.

Alain .

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: frame-relay cant ping from pont to point to multipoint

hi cadet thanks for your reply,ok nso ill tell u wot ive done first then post the outputs,after your reply i looked in each routing tables and the route was there but as a summarised route sh i checked sh ip protocols and on all 3 routers i had not done no auto-summarisation,so added the command to all 3 router but not thr fr switch(do i need to??do i even need to enable eigrp on fr switch ??as i have)now some rout tables sh the route and some dont heres outputs

tewys-comm-server#sh ip route eigrp

D    192.168.10.0/24 [90/2198016] via 171.123.1.2, 00:19:57, Ethernet0

     172.30.0.0/24 is subnetted, 9 subnets

D       172.30.2.0 [90/409600] via 171.123.1.2, 00:19:57, Ethernet0

D       172.30.3.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.0.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.1.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.6.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.7.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.4.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.5.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D       172.30.8.0 [90/409600] via 171.123.1.2, 00:19:58, Ethernet0

D    192.168.20.0/24 [90/2198016] via 171.123.1.2, 00:19:58, Ethernet0

D    192.168.1.0/24 [90/2198016] via 171.123.1.2, 00:19:58, Ethernet0

D    194.111.0.0/24 [90/2195456] via 191.168.123.3, 00:09:38, Serial0.102

     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

D       192.168.2.0/24 [90/2195456] via 171.123.1.2, 00:19:59, Ethernet0

D       192.168.2.1/32 [90/2195456] via 171.123.1.2, 00:19:59, Ethernet0

R1

tewys-comm-server#sh ip eigrp neighbor

IP-EIGRP neighbors for process 10

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

2   191.168.123.3           Se0.102          139 00:10:49 1464  5000  0  16

3   191.168.123.2           Se0.102          129 00:20:31  101   606  0  23

1   171.123.1.2             Et0               12 00:21:09   20   200  0  23

0   191.168.12.2            Se0.112           11 00:21:09   22   200  0  22

BERLIN#sh ip route eigrp

     171.123.0.0/24 is subnetted, 1 subnets

D       171.123.1.0 [90/2195456] via 191.168.123.1, 00:15:13, Serial0/0.201

                    [90/2195456] via 191.168.12.1, 00:15:13, Serial0/0.211

D    192.168.10.0/24 [90/2710016] via 191.168.123.1, 00:15:13, Serial0/0.201

                     [90/2710016] via 191.168.12.1, 00:15:13, Serial0/0.211

     172.30.0.0/24 is subnetted, 9 subnets

D       172.30.2.0 [90/2323456] via 191.168.123.1, 00:15:13, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:13, Serial0/0.211

D       172.30.3.0 [90/2323456] via 191.168.123.1, 00:15:13, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:13, Serial0/0.211

D       172.30.0.0 [90/2323456] via 191.168.123.1, 00:15:13, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:13, Serial0/0.211

D       172.30.1.0 [90/2323456] via 191.168.123.1, 00:15:13, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:13, Serial0/0.211

D       172.30.6.0 [90/2323456] via 191.168.123.1, 00:15:14, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:14, Serial0/0.211

D       172.30.7.0 [90/2323456] via 191.168.123.1, 00:15:14, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:14, Serial0/0.211

D       172.30.4.0 [90/2323456] via 191.168.123.1, 00:15:14, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:14, Serial0/0.211

D       172.30.5.0 [90/2323456] via 191.168.123.1, 00:15:14, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:14, Serial0/0.211

D       172.30.8.0 [90/2323456] via 191.168.123.1, 00:15:14, Serial0/0.201

                   [90/2323456] via 191.168.12.1, 00:15:14, Serial0/0.211

D    192.168.20.0/24 [90/2710016] via 191.168.123.1, 00:15:31, Serial0/0.201

                     [90/2710016] via 191.168.12.1, 00:15:31, Serial0/0.211

D    192.168.1.0/24 [90/2710016] via 191.168.123.1, 00:15:32, Serial0/0.201

                    [90/2710016] via 191.168.12.1, 00:15:32, Serial0/0.211

D    194.111.0.0/24 [90/2707456] via 191.168.12.1, 00:06:09, Serial0/0.211

     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

D       192.168.2.0/24 [90/2707456] via 191.168.123.1, 00:15:34, Serial0/0.201

                       [90/2707456] via 191.168.12.1, 00:15:34, Serial0/0.211

D       192.168.2.1/32 [90/2707456] via 191.168.123.1, 00:15:35, Serial0/0.201

                       [90/2707456] via 191.168.12.1, 00:15:35, Serial0/0.211

R2

BERLIN#sh ip eigrp neighbor

IP-EIGRP neighbors for process 10

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   191.168.123.1           Se0/0.201        166 00:17:04  165   990  0  29

0   191.168.12.1            Se0/0.211         12 00:17:59   25   200  0  28

R3

STOCKHOLM#sh ip route eigrp

     191.168.0.0/24 is subnetted, 2 subnets

D       191.168.12.0 [90/2681856] via 191.168.123.1, 00:01:29, Serial0.301

D    192.168.10.0/24 [90/2710016] via 191.168.123.1, 00:01:29, Serial0.301

D    192.168.1.0/24 [90/2710016] via 191.168.123.1, 00:01:29, Serial0.301

     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

D       192.168.2.0/24 [90/2707456] via 191.168.123.1, 00:01:29, Serial0.301

D       192.168.2.1/32 [90/2707456] via 191.168.123.1, 00:01:29, Serial0.301

D    192.168.20.0/24 [90/2710016] via 191.168.123.1, 00:01:29, Serial0.301

     172.30.0.0/24 is subnetted, 9 subnets

D       172.30.2.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.3.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.0.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.1.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.6.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.7.0 [90/2323456] via 191.168.123.1, 00:01:29, Serial0.301

D       172.30.4.0 [90/2323456] via 191.168.123.1, 00:01:30, Serial0.301

D       172.30.5.0 [90/2323456] via 191.168.123.1, 00:01:30, Serial0.301

D       172.30.8.0 [90/2323456] via 191.168.123.1, 00:01:30, Serial0.301

     171.123.0.0/24 is subnetted, 1 subnets

D       171.123.1.0 [90/2195456] via 191.168.123.1, 00:01:30, Serial0.301

STOCKHOLM#sh ip eigrp neigh

IP-EIGRP neighbors for process 10

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

1   191.168.123.1           Se0.301      125 00:03:39   76   456  0  29

0   194.111.0.2             Et0           14 00:04:00   28   200  0  9

also do i need to do clock rate on the frame-relay serial links????

thanks again for your help sorry it took so long for me to reply

thanks chris

Purple

frame-relay cant ping from pont to point to multipoint

Hi,

1)on the FR switch, no need for any routing protocol as well as FR mappings, this is just a switch.

   But it is not configured as a FR relay switch in the output config you posted ? where is this part of the config

2) on R1: on the multipoint subnet  you must have s0.103 pointing to R3 and not s0.102 which is already pointing to R2

      if you want to use a FR switch

3) split-horizon problem symptom is the spokes see the hub routes but not the other spokes routes so on the hub which should be R1 you have to disable split-horizon for the EIGRP process with the no ip split-horizon eigrp x interface command.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

frame-relay cant ping from pont to point to multipoint

hi alain thanks for your reply

1)not sure where confiq gone did do the frame-relay switching command and also did frame-relay routes will check this out and get back to u

2)will check this and get back to u

3)ah i only did no ip split horizon command will change the command

thanks for all your help

chris

New Member

frame-relay cant ping from pont to point to multipoint

hi alain when i looked on R1 the commands for split horizon was for the eigrp process  so must of missed a bit off while copying and the frame relay switch was the whole wrong sh run not sure why i posted stockholm twice lol so the fr switch has all the right config,it was no 2 as soon as i did what u said i could ping accross,thanks for your help

chris

1100
Views
0
Helpful
8
Replies
CreatePlease login to create content