Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Frame Relay Configuration

All,

 

Sorry for asking this, but I have been beating my head against the wall here. I am getting a T1 installed in my residence for internet connectivity. I am using an old wic-1-dsu-t1-v1 in a 2610 router. I am unable to get this configuration working. I have a very simple configuration so far on the router, but I am unable to get this to come up. I have put the show run below. Some of the commands are default and are not showing up. Obviously I have changed the ip's to generic ones below. Any ideas?

 

 

version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JSS-2610-001
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
!
!
!
!
!         
interface Ethernet0/0
 no ip address
 shutdown
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial0/2
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0/2.21 point-to-point
 ip address 1.1.1.3 255.255.255.252
 frame-relay interface-dlci 16   
!
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip http server
!
!
!
line con 0
 speed 115200
line aux 0
line vty 0 4
!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Just a follow up, once the

Just a follow up, once the carrier activated the circuit everything came up. Thanks everyone for the help.

8 REPLIES
Green

Hi,Is the layer 1and 2 up ?sh

Hi,

Is the layer 1and 2 up ?

sh int s2/0
sh frame pvc

Your layer 3 is miconfigured

!
interface Serial0/2.21 point-to-point
 ip address 1.1.1.3 255.255.255.252    OOOPS  !!!
 frame-relay interface-dlci 16   
!

1.1.1.3 is the broadcast for this subnet

if 1.1.1.2 is the othr end then you need

!
interface Serial0/2.21 point-to-point
 ip address 1.1.1.1 255.255.255.252
 frame-relay interface-dlci 16   
!

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Sorry when I transposed the

Sorry when I transposed the ip's to post i made a mistake in them. 1.1.1.2 is my address and 1.1.1.1 is the gateway for them (their side of the t1). I have it configure correctly on my router with the real ip's.

 

Here is the post to the rest of your questions:

 

Serial0/2 is up, line protocol is up 
  Hardware is PQUICC with Fractional T1 CSU/DSU
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY IETF, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  16787, LMI stat recvd 16788, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 2812/0, interface broadcasts 15
  Last input 00:00:04, output 00:00:04, output hang never
  Last clearing of "show interface" counters 1d22h
  Input queue: 0/75/3/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     16791 packets input, 249054 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 1 giants, 0 throttles
     3350 input errors, 1097 CRC, 1758 frame, 0 overrun, 0 ignored, 495 abort
     19638 packets output, 1080335 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     6 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

 

 

JSS-2610-001#show frame-relay pvc 

PVC Statistics for interface Serial0/2 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2.21

  input pkts 0             output pkts 2834         in bytes 0         
  out bytes 844139         dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 2809       out bcast bytes 841611    
  pvc create time 1d22h, last time pvc status changed 15:31:28

 

 

 

 

Is it possible the carrier just hasn't "activated" the circuit?

Hall of Fame Super Silver

If the provider has not

If the provider has not activated the circuit it is likely that your end would not be up/up. Since your interface is up/up I would think that the circuit is activated. Did the provider give you information identifying the DLCI as 16? Since DLCI 16 shows up as local and active it seems that this is not the DLCI being used by the provider. If you have difficulty in getting the provider to clarify the DLCI number you might try running the Frame Relay on the physical interface. This means that you do not have to specify a DLCI value. After the interface comes up you can see what DLCI they advertise to you. Then you can go back to the subinterface configuration with the correct DLCI number.

 

HTH

 

Rick

New Member

Sorry for the delay, been out

Sorry for the delay, been out of town for a couple of days:

 

Here is the relevant information from my carrier:

 

 

Network WAN IP:1.1.1.0
Carrier WAN IP:1.1.1.1
Customer WAN IP:1.1.1.2
WAN SUBNET:255.255.255.252 
   
Encapsulation:Frame Relay DLCI 16

 

 

Should I just put the config on the physical interface and then verify that they are actually using dlci 16?

New Member

Just got the following note

Just got the following note back from my carrier, it appears the circuit may not be fully activated.

 

 

The ILEC has informed that the order is with engineer's as they are in the process of placing a new repeater cage. At this point they are estimating a due date for the facilities to be installed by 07/11.

 

Hall of Fame Super Silver

That does make it pretty

That does make it pretty clear that it is a problem with the circuit. I am surprised that your interface would be up/up if the circuit was not complete. But obviously that is the case.

 

HTH

 

Rick

New Member

Just a follow up, once the

Just a follow up, once the carrier activated the circuit everything came up. Thanks everyone for the help.

Hall of Fame Super Silver

Thanks for posting back to

Thanks for posting back to the forum and confirming that it was a provider issue and that when they completed the activation of the circuit that everything came up as expected. It is good to know that this issue had a successful conclusion.

 

HTH

 

Rick

139
Views
5
Helpful
8
Replies
CreatePlease to create content