Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame Relay Configuration

Config.:

R1---IGX -----IGX----R2

R1 7206 Router connected to IGX 8430 at IND and IGX 8430 Connected to IGX 8430 over IPLC at US and it connected to R2 Router 7206.

I've 2 FR configured on R1 s2/1.1 n s2/1.2 for 2 processes.

|-172.x.x.1---| 172.x.x.2

R1--------------IGX-----IGX(US)---R2

|-192.x.x.1---| 192.x.x.2

R1-S2/1.1-172.x.x.1

S2/1.2-192..x.x.1

I am implementing new Back link from IND to US, what should be the config.,so that I 'll ger reduendency in either case the link fails?

9 REPLIES

Re: Frame Relay Configuration

create another FRL between US and India and congiure the 2nd link to kick in when the first fails.

You can use floating static routes or manipulate protocol metrics.

Narayan

New Member

Re: Frame Relay Configuration

Thanks narayan but I've 2 FRL between IND and US and already confiured ,if one failed the 2nd link would kick.

However, I implemented 3rd FRL ,now What I want is my traffic should flow from all 3 links and I'll configureon both the routers accordingly But if any links fails ,traffic shuld switch to another link.Static routes with metrics will be there.

I'd like to know the advantages and disadvantages of this and if i could configure on another way.So that i can explain it to client.

Re: Frame Relay Configuration

Try building MLPPoFR i.e multilink

i have the configuration running and it works fine .. below is a config example for one side

interface Multilink1

ip address

keepalive 1

ppp multilink

ppp multilink group 1

interface Serial0/0/0:0

bandwidth 1536

no ip address

encapsulation frame-relay

load-interval 30

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/0/0:0.1 point-to-point

keepalive 1

no cdp enable

frame-relay interface-dlci 642 ppp Virtual-Template1

interface Serial0/1/0:0

bandwidth 1536

no ip address

encapsulation frame-relay

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/1/0:0.1 point-to-point

keepalive 1

no cdp enable

frame-relay interface-dlci 641 ppp Virtual-Template2

interface Virtual-Template1

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

!

interface Virtual-Template2

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

do a similar configuration for the 3rd link

HTH

Narayan

New Member

Re: Frame Relay Configuration

oh!that's good.Let me know one thing that If my any links fails than traffic would switch to another link and IF my already configured links like i mentioned in config..will all the traffic will shift to 3rd link.

I configured static routes for all with the 3rd links US routers IP add and given metric of 10.

Is that okay? and kindly let me knw the above i asked u and advantages and disadvantages as well.

Thanks in advance.

Re: Frame Relay Configuration

The above scenario which i posted was for multilink in which all links are active and the traffic will be loadbalanced. if any one of the link fails entire traffic will be taken care by the other link.

If you want your links to be active/standby then multilink is not the way for you. THe floating static routes which you have configured are good to go.

If you can post your config, we can suggest some fine tuning.

HTH, rate if it does

Narayan

New Member

Re: Frame Relay Configuration

Hi! narayan,

I tired but IGX dosen't support ppp and my both end routers connected to IGX.

How should i design the network for 3rd link or for all the 2 links.I am lookin for a solution with advantages and disadvantages.

Or the solution in which i should configure 3rd link and give static routes of metric 10.I meant, like present config Route ,I'll put 2 more route for the same route and give IP address of the destination address for other 2 links and metric 10.

Plz suggest.

Thnanks

Re: Frame Relay Configuration

Hi,

you might use frame forwarding, as this does not look for FR specifics in the IGX.

The other option is to use 3 point-to-point subinterfaces with a FR PVC each on the router and static routes. Example:

interface Serial2/1

encapsulation frame-relay

interface Serial2/1.1

ip address 10.1.1.1 255.255.255.252

frame-relay interface-dlci 100

interface Serial2/1.2

ip address 10.1.2.1 255.255.255.252

frame-relay interface-dlci 200

interface Serial3/0

encapsulation frame-relay

interface Serial3/0.3

ip address 10.1.3.1 255.255.255.252

frame-relay interface-dlci 300

ip route 192.168.0.0 255.255.0.0 10.1.1.2 Serial2/1.1

ip route 192.168.0.0 255.255.0.0 10.1.2.2 Serial2/1.2

ip route 192.168.0.0 255.255.0.0 10.1.3.2 Serial3/0.3

This would enable load sharing over the 3 FR PVCs. If one PVC goes down (enable LMI across the port!) the remaining PVCs would take the traffic.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Frame Relay Configuration

Hi!Martin,

Thanks as I suggested my first solution the same way.I am lookin for some other,

My current config is:

interface Tunnel1

no ip address

!

interface FastEthernet0/0

*** Pix Firewall***

ip address 172.2x.x.x 255.255.2x.240

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

description ***Connected to Core ****

ip address 172.2x.x.x 255.255.255.0

no ip proxy-arp

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial1/0

no ip address

no ip redirects

no ip mroute-cache

load-interval 30

shutdown

serial restart_delay 0

no cdp enable

!

interface Serial1/1

description ***Process Over a.b.200***

ip address 172.2y.x.x 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation frame-relay

ip route-cache flow

no ip mroute-cache

load-interval 30

ntp disable

no fair-queue

serial restart_delay 0

frame-relay interface-dlci 200

!

interface Serial1/2

no ip address

shutdown

serial restart_delay 0

no cdp enable

!

interface Serial1/3

no ip address

no keepalive

shutdown

serial restart_delay 0

no cdp enable

!

interface Serial2/0

no ip address

shutdown

serial restart_delay 0

no cdp enable

!

interface Serial2/1

description *** Link to US router over IPLC on Port xx.7***

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation frame-relay

ip route-cache flow

no ip mroute-cache

load-interval 30

ntp disable

no fair-queue

serial restart_delay 0

!

interface Serial2/1.1 point-to-point

description ***process ind Over a.b.100***

ip address 192.168.x.x 255.255.x.252

no ip redirects

no ip unreachables

ip accounting output-packets

no cdp enable

frame-relay interface-dlci 100

crypto map ADSEPIC

!

interface Serial2/1.2 point-to-point

description " *****Process2 over a.b.200 ***** "

ip address 172.2x.x.x 255.255.x.252

no ip unreachables

shutdown

no cdp enable

frame-relay interface-dlci 200

!

interface Serial2/2

no ip address

shutdown

serial restart_delay 0

no cdp enable

!

interface Serial2/3

no ip address

shutdown

serial restart_delay 0

no cdp enable

!

ip classless

ip route 10.x.x.x 255.255.255.255 192.168.x.x

ip route 10.x.x.x 255.255.255.255 192.168.x.y

ip route 10.x.x.x 255.255.255.255 172.2a.x.y

ip flow-export source Serial1/1

ip flow-export version 5

ip flow-export destination 172.a.b.c aabc

no ip http server

ip pim bidir-enable

If u can suggest anything else in this config.

Re: Frame Relay Configuration

Hi,

then I did not understand your requirements.

The suggested setup will provide load sharing across all 3 links and also provide redundancy, i.e. all links, which are up will be used for load sharing.

If this does not meet your requirements, what is missing?

Regards, Martin

147
Views
5
Helpful
9
Replies
CreatePlease to create content