Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FRAME RELAY DDR ISDN

The only way we can get our DDR to come up is to do a shutdown on both ends of our frame relay serial interfaces. The dialing ends config looks like this.

hostname Denton

!

logging buffered 4096 debugging

enable secret 5 <gone>

enable password 7 <gone>

!

username FLOWAN1 password 7 <gone>

!

!

!

!

ip subnet-zero

ip cef

no ip domain-lookup

no ip dhcp conflict logging

!

isdn switch-type basic-dms100

isdn voice-call-failure 0

modemcap entry MyMultitech:MSC=&FS0-1&C4&D3$SB115200

!

!

!

interface FastEthernet0/0

ip address 75.75.188.110 255.255.255.0

ip access-group 115 in

ip access-group 115 out

no ip directed-broadcast

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/0

description Connected to Internet T1

bandwidth 512

no ip address

ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-8

service-module t1 fdl both

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

bandwidth 512

ip address 75.75.97.17 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

frame-relay interface-dlci 100

!

interface BRI0/0

ip address 192.168.1.2 255.255.255.0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

load-interval 30

no keepalive

dialer idle-timeout 170

dialer map ip 192.168.1.1 name FLOWAN1 12294300357

dialer map ip 192.168.1.1 name FLOWAN1 12294300359

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-dms100

isdn spid1 94038376660101 3837666

isdn spid2 94038323310101 3832331

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 75.75.97.18

ip route 0.0.0.0 0.0.0.0 192.168.1.1 150

ip route 10.99.99.99 255.255.255.255 BRI0/0

no ip http server

!

!

map-class dialer BRI

logging 75.75.1.4

access-list 101 remark Intersting Traffic Definition for Backup Link

access-list 101 permit ip any any

access-list 115 deny udp any any eq tftp

access-list 115 deny tcp any any eq 135

access-list 115 deny udp any any eq 135

access-list 115 permit ip any any

access-list 115 deny tcp any any eq 445

access-list 115 deny tcp any any eq 5554

dialer-list 1 protocol ip list 101

!

line con 0

exec-timeout 5 0

password 7 <gone>

login

transport input none

line aux 0

modem autoconfigure type MyMultitech

line vty 0

password 7 <gone>

login

modem autoconfigure type MyMultitech

line vty 1 4

password 7 <gone>

login

!

end

3 REPLIES

Re: FRAME RELAY DDR ISDN

Hi Friend,

You config makes me feel your primary and backup interface are on same router.

Now you have to define on your primary what is the condition which can bring the backup interface up which is your BRI interface.

Define

backup interface bri0 --- under serial sub interface which is for frame relay

Check this link out

http://www.cisco.com/warp/public/793/access_dial/britobribackup.html

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml

HTH

Ankur

New Member

Re: FRAME RELAY DDR ISDN

Am I correct in assuming that your sub-interface never goes down when the other end fails ? If so, "backup interface" on this end won't help you either. Perhaps Frame Relay End to End Keepalive or Dialer Watch might do the trick for you.

Hall of Fame Super Silver

Re: FRAME RELAY DDR ISDN

Larry

Do I understand correctly that if you just shut down the frame relay interface on the local router that DDR does not start up? Does it really require shutting down the remote router interface as well?

There are several approaches that can be taken for implementing DDR. Your approach of floating static routes is quite common, backup interface is another traditional implementation. I find Backup Interface to be a bit more restrictive (it dedicates the dialing interface so that it can not be used for anything else.) and would probably look for other solutions in your situation. Dialer Watch is somewhat newer and since it looks like there would be only connected routes and the one static default route, I am not sure that Dialer Watch would be a whole lot better that what you are doing.

As I look at your config it looks like that if the static default route is withdrawn that the floating static should kick in and initiate DDR (assuming that there is interesting traffic). I am puzzled why shut down of the local interface does not remove the default route and initiate DDR. I would think that shutting down either the physical serial interface or the subinterface should be enough to start DDR.

HTH

Rick

125
Views
0
Helpful
3
Replies