Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame Relay encapsulation at OSPF protocols?

To all:

Please help.

I have a connections(router to router) over frame relay and I configured OSPF protocols. But when I try the command "show ip ospf neighbor", there is no output or no connections found. Is that possible that using frame relay connections, the LSA's didn't send?

TIA

Below are examples for clarifications:

Router0#sho run

!

interface Serial6/0

ip address 192.176.1.17 255.255.255.252

encapsulation frame-relay ietf

frame-relay map ip 192.176.1.17 101 broadcast cisco

frame-relay interface-dlci 101

!

router ospf 1

log-adjacency-changes

network 192.176.1.0 0.0.0.255 area 0

Router0#sho ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.176.1.2 1 FULL/- 00:00:31 192.176.1.2 Serial2/0

192.176.1.6 1 FULL/- 00:00:39 192.176.1.6 Serial3/0

192.176.1.14 1 FULL/- 00:00:32 192.176.1.14 Serial5/0

192.176.1.10 1 FULL/- 00:00:31 192.176.1.10 Serial4/0

Router0#

........................................

Router5#sho run

!

interface Serial2/0

ip address 192.176.1.18 255.255.255.252

encapsulation frame-relay ietf

frame-relay map ip 192.176.1.18 100 broadcast cisco

frame-relay interface-dlci 100

!

router ospf 1

log-adjacency-changes

network 192.176.1.0 0.0.0.255 area 0

Router5#sho ip ospf neighbor

Router5#

8 REPLIES
Green

Re: Frame Relay encapsulation at OSPF protocols?

Are you sure you want a wildcard mask of 0.0.0.255 on a /30 point-to-point?

Try the interface's IP address with a wildcard of 0.0.0.0.

Just a shot in the dark ...

Hall of Fame Super Gold

Re: Frame Relay encapsulation at OSPF protocols?

Martee

I believe that the problem is in your frame relay map statements. On router0 you have:

ip address 192.176.1.17 255.255.255.252

frame-relay map ip 192.176.1.17 101 broadcast cisco

but why does it point to its own address? I suggest that you change it to

frame-relay map ip 192.176.1.18 101 broadcast cisco

and on router5 you have:

ip address 192.176.1.18 255.255.255.252

frame-relay map ip 192.176.1.18 100 broadcast cisco

and I suggest that you change it to

frame-relay map ip 192.176.1.17 100 broadcast cisco

HTH

Rick

New Member

Re: Frame Relay encapsulation at OSPF protocols?

Thanks Rick and Scott for the additional info. I try this first. BTY, I passed CCNA 640-801 last year of October with the help of this forum..

New Member

Re: Frame Relay encapsulation at OSPF protocols?

Hi Rick,

Your suggestion was invalid because when I try to change the map the output is just like this:

Router0(config-if)#frame-relay map ip 192.176.1.18 101 broadcast cisco

%Address already in map

Router0(config-if)#

same output at Router5.

But when I ping from Router0 to Router5, it is OK and by itself. But when I try to ping from the host connected to Router0 going out to Router5, the problem exist..Is it possible on OSPF area 0 problem?

Hall of Fame Super Gold

Re: Frame Relay encapsulation at OSPF protocols?

Martee

Did you remove the existing frame relay map before you attempted to configure the new one?

Perhaps some additional information would help us to figure out what the problem is. Would you post the output from these commands:

show frame-relay map

show ip ospf interface

show cdp neighbor detail

HTH

Rick

Cisco Employee

Re: Frame Relay encapsulation at OSPF protocols?

Martee,

The default ospf network type in this case is "non-broadcast", which requires the neighbor statement to be configured for the session to come up. Try configuring "ip ospf network broadcast" under the interface on each side. You could also set the network type as point to point as you only have these two neighbors.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Cisco Employee

Re: Frame Relay encapsulation at OSPF protocols?

Martee,

By the way, here

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094054.shtml

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Frame Relay encapsulation at OSPF protocols?

1. When issuing a frame relay map this is the local ip address to map to thr remote DLCI

2. Under each interface type the command ip ospf network point-to-point

3. Also if you are running loopbacks for router id then add the ip oapf network type point-to-point over lopback interfaces

After perfroming the following test by issuing ther following commands

sh ip ospf neigh - shows ospf directly connected neighbor

sh ip ospf interface- ospf interface info

sh ip ospf data - ospf lsa database

154
Views
4
Helpful
8
Replies
CreatePlease to create content