Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Frame Relay Lab Routing Issues

Hello,

I am having a bit of a routing issues I believe in my home lab.  I have set up a frame relay hub-and-spoke config w/ 3 routers. All routers are receiving routes via EIGRP and all appear to have a complete view of the network complete with each routers loopback int.  The hub has been configured with point-to-point sub interfaces connecting to R3 and R5 (the hub is R2).  One issue is that the routers on the "left" can ping only R3 and R2's loopback int, their S0 ip address can not be pinged.  It is the same with the routers on the "right".  R5 and R2 can ping each others loopback but not their S0 ip addresses.  Also R3 and R5 can not access the hub's (R2) FastEthernet networks, even though it shows up in their routing table.  It is almost like the sub interfaces on the hub are not communicating properly. 

frame relay.JPG

R2

interface Serial0

no ip address

encapsulation frame-relay

fair-queue

no frame-relay inverse-arp

frame-relay lmi-type ansi

!

interface Serial0.12 point-to-point

ip address 192.168.5.1 255.255.255.0

frame-relay interface-dlci 122

!

interface Serial0.13 point-to-point

ip address 192.168.5.2 255.255.255.0

frame-relay interface-dlci 123

router eigrp 10

network 2.2.2.2 0.0.0.0

network 192.168.5.0

network 192.168.20.0

network 192.168.0.0

Serial0.12 (up): point-to-point dlci, dlci 123(0x7B,0x1CB0), broadcast

          status defined, active

Serial0.13 (up): point-to-point dlci, dlci 122(0x7A,0x1CA0), broadcast

          status defined, active

R3

interface Serial0

ip address 192.168.5.3 255.255.255.0

encapsulation frame-relay

no fair-queue

frame-relay map ip 192.168.5.1 301 broadcast

no frame-relay inverse-arp

frame-relay lmi-type ansi

router eigrp 10

network 192.168.5.0

network 3.3.3.3 0.0.0.0

Serial0 (up): ip 192.168.5.1 dlci 301(0x12D,0x48D0), static,

              broadcast,

              CISCO, status defined, active

R5

interface Serial0

ip address 192.168.5.5 255.255.255.0

encapsulation frame-relay

no fair-queue

frame-relay map ip 192.168.5.2 501 broadcast

no frame-relay inverse-arp

frame-relay lmi-type ansi

router eigrp 10

network 192.168.5.0

network 5.5.5.5 0.0.0.0

Serial0 (up): ip 192.168.5.2 dlci 501(0x1F5,0x7C50), static,

              broadcast,

              CISCO, status defined, active

I'm not sure if I provided enough info, but if more is needed please let me know. 

Any help is greatly appreciated

Thanks

-Jeff

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Frame Relay Lab Routing Issues

At least there is an issue on R2: You have configured both subinterfaces with the the same ip subnet 192.168.5.0/24.

This is a mistake which causes the spokes to think they can reach eachother directly.

Configure a different subnet on your subinterfaces and try again.

regards,

Leo

2 REPLIES

Frame Relay Lab Routing Issues

At least there is an issue on R2: You have configured both subinterfaces with the the same ip subnet 192.168.5.0/24.

This is a mistake which causes the spokes to think they can reach eachother directly.

Configure a different subnet on your subinterfaces and try again.

regards,

Leo

New Member

Frame Relay Lab Routing Issues

Leo,

Thank you very very much. That was the issue.

Sincerely

-Jeff

309
Views
0
Helpful
2
Replies