Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame-relay Mapping?

I have 3 routers connected via fram-relay cloud. I am facing a problem in connectivity because the Hub router is not mapping the spoke routers IP with relevant DLCI but spokes are mapping IP to relevant DLCI to HUB. Below is output of frame-relay map on routers.

R1:

R1#sh frame-relay map

Serial1/0.1 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast

status defined, active

Serial1/0.2 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast

status defined, active

R2:

Serial1/0 (up): ip 172.26.22.1 dlci 201(0xC9,0x3090), dynamic,

broadcast,, status defined, active

R3:

R3#sh frame-relay map

Serial1/0 (up): ip 172.26.23.1 dlci 301(0x12D,0x48D0), dynamic,

broadcast,, status defined, active

I tried mapping manually on HUB router but it shows this error message:

R1(config-subif)#frame-relay map ip 172.26.22.2 102 broadcast

FRAME-RELAY INTERFACE-DLCI command should be used on point-to-point interfaces

Please help me to resolve this issue.

12 REPLIES
Hall of Fame Super Gold

Re: Frame-relay Mapping?

MUHAMMAD

It looks to me like the issue that you have got is that you are configuring Frame Relay on the spoke routers on the physial interface and it therefore is operating as multipoint. But you are configuring Frame Relay on the hub router as point to point subinterfaces. So you have a mismatch in operational characteristics.

I suggest that you reconfigure the spoke routers to use point to point subinterfaces. I believe that this will resolve your issue.

HTH

Rick

New Member

Re: Frame-relay Mapping?

Please have a look on the below sh run sample of routers.

R1:

!

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

!

interface Serial1/0.1 point-to-point

ip address 172.26.22.1 255.255.255.0

ip ospf priority 255

frame-relay interface-dlci 102

!

interface Serial1/0.2 point-to-point

ip address 172.26.23.1 255.255.255.0

frame-relay interface-dlci 103

!

R2:

!

interface Serial1/0

ip address 172.26.22.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay interface-dlci 201

!

R3:

!

interface Serial1/0

ip address 172.26.23.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay interface-dlci 301

!

My Dear same like above setup I am using in a real production network and it is working perfectly fine from years. Why not in this lab scenario. Please guide me if something is wrong.

Hall of Fame Super Gold

Re: Frame-relay Mapping?

MUHAMMAD

The config information that you posted clearly confirms what I had suggested that R1 is configuring the Frame Relay with point to point subinterfaces and R2 and R3 are configuring Frame Relay on the physical interface. Therefore R1 is operating as point to point whle R2 and R3 are operating as multipoint.

Cisco does not do inverse ARP (mapping DLCIs) on point to point subinterfaces and does do inverse ARP (mapping DLCIs) on multipoint interfaces. This is why R2 and R3 are mapping but R1 is not. I am not convinced that you do not have IP connectivity as your network is configured, but you do have inconsistency. I suggest that you configure R2 and R3 to use point to point subinterfaces.

I do not know what you have in a real production network and take your word that it is working perfectly fine. I am not convinced that your test network does not work. But it is inconsistent and I suggest that you change it. If your production network is also inconsistent then I suggest that you change it also.

HTH

Rick

Re: Frame-relay Mapping?

On point-to-point (sub-)interfaces the router will send all packets to remote end. According to Cisco's Q&A (http://www.cisco.com/en/US/partner/tech/tk713/tk237/technologies_q_and_a_item09186a008009457a.shtml) FR InARP is on by default regardless of interface type (p2p or p2m), but apparently since for p2p you don't need mapping to get things working (router will send all packets out anyway) InARP is not used.

In your setup you should nevertheless be able to ping remote ends of p2p sub-interfaces.

New Member

Re: Frame-relay Mapping?

But believe me the setup like above is working perfectly fine in an production environment with 20 spoke and one HUB router.

For my this above lab setup what do you suggest?

Re: Frame-relay Mapping?

I believe your lab setup is working too (in terms of connectivity), doesn't it?

I have just configured test p2p sub-interfaces in my lab and they also do not show mapping (just like yours), but ping is working just fine. So your lab setup seems to behave perfectly normal.

New Member

Re: Frame-relay Mapping?

But my friend my all routers are not able to ping each other. Even I have restarted all routers many times. What do you think about the rburts' replies. He said that your production network is inconsistent, what do you think about his reply . I don't know how it is as its working normal from years.

Re: Frame-relay Mapping?

Then you have different issue, and not FR map. Check status of all PVC to start with. Also, is communication broken between hub and the spoke routers or between two spoke routers?

New Member

Re: Frame-relay Mapping?

There is no communication break between any pear + PVCs are active.

Hall of Fame Super Gold

Re: Frame-relay Mapping?

MUHAMMAD

If you do not have it resolved yet then I will repeat the suggestion that I made before: configure the spoke routers as point to point subinterfaces. Try this and let us know if the behavior changes.

HTH

Rick

New Member

Re: Frame-relay Mapping?

Yah dear Rick I did as you suggested, now its working fine. But actually I was looking for the answer that why the same scenario is working in production setup. Amazing.

Hall of Fame Super Gold

Re: Frame-relay Mapping?

MUHAMMAD

I am glad that my suggestion helped you to resolve the issue in your test environment. Without seeing more detail it is difficult to know why the production environment is working differently than your test environment. Several possible things might explain it:

- the Frame Relay in production might be provisioned slightly differently than what you have in your test environment.

- different versions of IOS might behave differently.

- there might be some small difference in configs.

HTH

Rick

214
Views
0
Helpful
12
Replies
CreatePlease to create content