Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame Relay Multipoint OSPF neighbor command

I have the following network.

Network Diagram.png

R1 is the hub. A PVC exists between R1 & R2, R1 & R3 and R3 & R4. This is a partial mesh topology. I am doing this for study purposes.

My understand is that with an NMBA multipoint network the neighbor command is required to get OSPF neighborships up and running.

And indeed, in my case, R1 and R2 do not form a full neighborship until I enter the neighbor command on R1.

But I have noticed a couple of add things:

1) I do not need to configure the neighbor command on R2 for it to work ... I thought it needed to be configured on both ends...

2) If I then reverse the neighbor command using no the neighborship initially goes down... but then comes back up a minute later with no neighbor commands at all!

R1(config-router)#no neighbor 172.16.1.2

R1(config-router)#

*Mar  1 00:33:09.483: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.1.2 on Serial0/0.1 from FULL to DOWN, Neighbor Down: Neighbor deconfigured

R1(config-router)#

*Mar  1 00:33:32.171: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.1.2 on Serial0/0.1 from LOADING to FULL, Loading Done

R1(config-router)#do show ip ospf interface serial0/0.1

Serial0/0.1 is up, line protocol is up

  Internet Address 172.16.1.1/24, Area 0

  Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 1.1.1.1, Interface address 172.16.1.1

  No backup designated router on this network

  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

    oob-resync timeout 120

    Hello due in 00:00:10

  Supports Link-local Signaling (LLS)

  Cisco NSF helper support enabled

  IETF NSF helper support enabled

  Index 1/1, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 1, maximum is 1

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 172.16.1.2

  Suppress hello for 0 neighbor(s)

R1(config-router)#

Can any help me to explain this? I will provide whatever show commands may help. I am doing this in GNS3 with a standard GN3 Frame Relay Switch.

Frame Relay Switch Setup.png

Everyone's tags (3)
1 REPLY

Frame Relay Multipoint OSPF neighbor command

I'd have to lab this up to see it, but here's what I would suggest. The neighbor command is required for NBMA networks. The neighbor command is only required on 1 router, but for consistency a lot of people put it on both since it doesn't hurt anything. When you remove the neighbor commands, I would restart the ospf process. I suspect that it's a gns issue in all honesty. If after clearing the ospf process on both of these routers and your still get an adjacency, let me know and I'd be glad to lab this up. Another way to test it is to save your configs and restart gns to see if you can still get an adjacency.

HTH,

John

HTH, John *** Please rate all useful posts ***
929
Views
0
Helpful
1
Replies
CreatePlease login to create content