Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame-relay network with floating route

ccnp.jpeg.jpeg

hi,

i have this frame relay network running rip protocol and aslo have a static route directly connect to R3 from R1, now the problem is when i close serial interface connected to frame-relay switchi lose connectivity from 192.168.1.0 network.

Here is my output files

R1#sh running-config

Building configuration...

Current configuration : 1844 bytes

!

upgrade fpd auto

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

!

!

!        

no ip domain lookup

no ipv6 cef

!        

multilink bundle-name authenticated

!                

archive  

log config

  hidekeys

!        

ip tcp synwait-time 5

!    

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!        

interface FastEthernet0/0

no ip address

shutdown

duplex half

!        

interface Serial1/0

ip address 192.168.1.1 255.255.255.0

encapsulation frame-relay

shutdown

serial restart-delay 0

frame-relay map ip 192.168.1.3 103 broadcast

frame-relay map ip 192.168.1.2 102 broadcast

!        

interface Serial1/1

ip address 210.1.1.1 255.255.255.0

serial restart-delay 0

!        

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!        

router rip

version 2

network 172.12.0.0

network 192.168.1.0

network 210.1.1.0

no auto-summary

!        

ip forward-protocol nd

ip route 2.2.2.2 255.255.255.255 192.168.1.2

ip route 3.3.3.3 255.255.255.255 192.168.1.3

no ip http server

end

R2#sh running-config

Building configuration...

Current configuration : 1819 bytes

!

upgrade fpd auto

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

       

no ip domain lookup

no ipv6 cef

!        

multilink bundle-name authenticated

!        

     

  archive  

log config

  hidekeys

!        

!        

      

ip tcp synwait-time 5

!        

!        

!        

!        

interface Loopback1

ip address 2.2.2.2 255.255.255.255

!        

interface FastEthernet0/0

ip address 172.12.23.1 255.255.255.224

duplex half

!        

interface Serial1/0

ip address 192.168.1.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 192.168.1.3 201 broadcast

frame-relay map ip 192.168.1.1 201 broadcast

!        

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!        

router rip

version 2

network 172.12.0.0

network 192.168.1.0

no auto-summary

!        

ip forward-protocol nd

ip route 1.1.1.1 255.255.255.255 192.168.1.1

ip route 3.3.3.3 255.255.255.255 192.168.1.1

no ip http server

no ip http secure-server

R3#sh running-conf

Building configuration...

Current configuration : 1849 bytes

!

upgrade fpd auto

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

    

no ip domain lookup

no ipv6 cef

!        

multilink bundle-name authenticated

!        

 

archive  

log config

  hidekeys

!        

 

ip tcp synwait-time 5

!        

     

interface Loopback1

ip address 3.3.3.3 255.255.255.255

!        

interface FastEthernet0/0

ip address 172.12.23.2 255.255.255.224

duplex half

!        

interface Serial1/0

ip address 192.168.1.3 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 192.168.1.2 301 broadcast

frame-relay map ip 192.168.1.1 301 broadcast

!        

interface Serial1/1

ip address 210.1.1.2 255.255.255.0

serial restart-delay 0

!        

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!        

router rip

version 2

network 172.12.0.0

network 192.168.1.0

network 210.1.1.0

no auto-summary

!        

ip forward-protocol nd

ip route 1.1.1.1 255.255.255.255 192.168.1.1

ip route 2.2.2.2 255.255.255.255 192.168.1.1

no ip http server

no ip http secure-server

------------------------------------------------------------------------------------------------------------------------------------------------

R1#sh ip route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback1

     2.0.0.0/32 is subnetted, 1 subnets

S       2.2.2.2 [1/0] via 192.168.1.2

     3.0.0.0/32 is subnetted, 1 subnets

S       3.3.3.3 [1/0] via 192.168.1.3

     172.12.0.0/27 is subnetted, 1 subnets

R       172.12.23.0 [120/1] via 210.1.1.2, 00:00:15, Serial1/1

R    192.168.1.0/24 [120/1] via 210.1.1.2, 00:00:15, Serial1/1

C    210.1.1.0/24 is directly connected, Serial1/1


R2#sh ip route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

S       1.1.1.1 [1/0] via 192.168.1.1

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback1

     3.0.0.0/32 is subnetted, 1 subnets

S       3.3.3.3 [1/0] via 192.168.1.1

     172.12.0.0/27 is subnetted, 1 subnets

C       172.12.23.0 is directly connected, FastEthernet0/0

C    192.168.1.0/24 is directly connected, Serial1/0

R    210.1.1.0/24 [120/1] via 172.12.23.2, 00:00:19, FastEthernet0/0

R3#sh ip route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

S       1.1.1.1 [1/0] via 192.168.1.1

     2.0.0.0/32 is subnetted, 1 subnets

S       2.2.2.2 [1/0] via 192.168.1.1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback1

     172.12.0.0/27 is subnetted, 1 subnets

C       172.12.23.0 is directly connected, FastEthernet0/0

C    192.168.1.0/24 is directly connected, Serial1/0

C    210.1.1.0/24 is directly connected, Serial1/1

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Frame-relay network with floating route

Hello

"Router 1 has learned rip routes via R3 and R2 so router R1 know how to reach 192.168.1.2 and 172.12.23.2 destinations. R1 send rip updates via serial interface 1/1 (210.1.1.1)"

- Wrong
R1 has a valid next hop to reach R3 loopback because of the rip routes it learned from r3 via ser1/1 which included 192.168.1.0/24 and the subnet between r2&r3

However r2 k r3 still thinks to get to r1 loopback they need to go via ser0/1 and because these two rtrs are not aware 192.168 1.0/24 is not available due to their ser0/1 interfaces still being up this subnet is still being advertised are directly connected by both of them

This is not the case for r1 as its ser0/1 interface is down so the 192.168.10/24 isnt advertised in it rib table as directly connected and is now learned via rip over ser1/1

Res
Paul


Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
9 REPLIES
Purple

Frame-relay network with floating route

Hi,

I don't see any floating route here as all your static routes have an AD of 1 which is the default, furthermure if you want to do failover then your static routes must be using the HDLC link between R1 and R3 and be for the same prefix advertised by your routing protocol.

What are you trying to achieve ? ping the loopback on R1 from R2 or R3 not using the frame-relay cloud when the frame-relay interface of R1 comes down ? if this is what you want then I'll post the configs to achieve this.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Frame-relay network with floating route

well forget about the floating route, why i can't ping from network 210.1.1.1 to 192.168.1.2 or 1.3. but all loopback ping each other.

Purple

Frame-relay network with floating route

Hi,

So you're pinging R2 and R3 frame-relay IP sourcing from the hdlc link on R1 and it is failing but pinging the loopbacks on R2 and R3 from the same source is succeeding ?

Regards

Alain

Don't forget to rate helpful posts.
New Member

Frame-relay network with floating route

Sorry by mistake my prevoius post wrongly said tht all loopback pinging each other, now router 1 has ping connectivity to 3.3.3.3 and 210.1.1.2 and 172.12.23.2 and router 2 has ping connectivity to 172.12.23.2 and 210.1.1.1. and router 3 has only ping connectivity to 210.1.1.1

R1#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

..

Success rate is 0 percent (0/2)

R1#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

...

Success rate is 0 percent (0/3)

R1#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/56 ms

R3#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R3#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

..

Success rate is 0 percent (0/2)

R3#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

..

Success rate is 0 percent (0/2)

R3#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R3#ping 210.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 210.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/33/68 ms

R2#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#ping 192.168.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#ping 210.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 210.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/40/68 ms

Frame-relay network with floating route

Hello

The reason has been stated by Cadet Allan - the static's are still pointing to a unreachable next hop and have preference.

1) You can Advertise the loopbacks in rip  and apply ip sla tracking to the static routes

2) Have no  static and either LB between the interfaces or offset the rip routes for a desired path.

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Frame-relay network with floating route

okay, how am pinging from r1 ro r3 loop interface but r3 not pinging to r1 loop interface ?

Re: Frame-relay network with floating route

Hello

Possibly spilt sh horizon is prohibiting R1 from  re-advertsing 192.168.1.0/24 back out of the same interface it  leraned that route from ( in this case ser1/1)

R3 is seeing 192.168.1.0/24 direcdtly connected via ser0/1 which is down, if you add another static on R3  pointing to ser1/1 next hop R3 would able to ping 1.1.1.1. or advertise the loopbacks via rip

R1

  3.0.0.0/32 is subnetted, 1 subnets

S       3.3.3.3 [1/0] via 192.168.1.3

     172.12.0.0/27 is subnetted, 1 subnets

R    192.168.1.0/24 [120/1] via 210.1.1.2, 00:00:15, Serial1/1

R3

     1.0.0.0/32is subnetted, 1 subnets

S       1.1.1.1 [1/0] via 192.168.1.1

  

C    192.168.1.0/24 is directly connected, Serial1/0


res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Frame-relay network with floating route

sorry i didn't understand correctly, how you saying that split horizon is prohibiting ?? R1 has two interface one was shutdown manually which is directly connected to frame relay switch another directly connected to R3 via serial interface.

Router 1 has learned rip routes via R3 and R2 so router R1 know how to reach 192.168.1.2 and 172.12.23.2 destinations. R1 send rip updates via serial interface 1/1 (210.1.1.1)

R1#sh ip route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback1

     2.0.0.0/32 is subnetted, 1 subnets

S       2.2.2.2 [1/0] via 192.168.1.2

     3.0.0.0/32 is subnetted, 1 subnets

S       3.3.3.3 [1/0] via 192.168.1.3

     172.12.0.0/27 is subnetted, 1 subnets

R       172.12.23.0 [120/1] via 210.1.1.2, 00:00:15, Serial1/1

R    192.168.1.0/24 [120/1] via 210.1.1.2, 00:00:15, Serial1/1

C    210.1.1.0/24 is directly connected, Serial1/1

Re: Frame-relay network with floating route

Hello

"Router 1 has learned rip routes via R3 and R2 so router R1 know how to reach 192.168.1.2 and 172.12.23.2 destinations. R1 send rip updates via serial interface 1/1 (210.1.1.1)"

- Wrong
R1 has a valid next hop to reach R3 loopback because of the rip routes it learned from r3 via ser1/1 which included 192.168.1.0/24 and the subnet between r2&r3

However r2 k r3 still thinks to get to r1 loopback they need to go via ser0/1 and because these two rtrs are not aware 192.168 1.0/24 is not available due to their ser0/1 interfaces still being up this subnet is still being advertised are directly connected by both of them

This is not the case for r1 as its ser0/1 interface is down so the 192.168.10/24 isnt advertised in it rib table as directly connected and is now learned via rip over ser1/1

Res
Paul


Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
222
Views
0
Helpful
9
Replies