Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame-relay network with RIP route

Hi,

here i have frame-relay network running RIP protocol, currently too many weird things happening in thise scneario.let see one by one,

First i make a frame-relay network all three router has end to end ip connectivity, after that i start rip protocol on all three routers but didn't see any router sending update by viewing debug ip rip cmd.i did google search some of them saying run rip on interface level and some other saying use neigbour cmd on hub router then running rip by interface level router1 (hub) start sending updates i did the same thing on r2 and r3  now both spoke router can able to ping hub router loop interface, but router1 not ping to spoke doesn't has any rip route .please help me to understand this problem.

R1# sh runn

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!        

interface FastEthernet0/0

no ip address

shutdown

duplex half

!        

interface Serial1/0

ip address 192.168.1.1 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 192.168.1.3 103 broadcast

frame-relay map ip 192.168.1.2 102 broadcast

no frame-relay inverse-arp

!        

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!

router rip

version 2

network 1.0.0.0

network 192.168.1.0

no auto-summary

R2# sh runn

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Serial1/0

ip address 192.168.1.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 192.168.1.3 201

frame-relay map ip 192.168.1.1 201

no frame-relay inverse-arp

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!

router rip

version 2

network 2.0.0.0

network 192.168.1.0

no auto-summary

!

ip forward-protocol nd

no ip http server

R3#sh runn

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Serial1/0

ip address 192.168.1.3 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 192.168.1.2 301

frame-relay map ip 192.168.1.1 301

no frame-relay inverse-arp

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/4

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/5

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/6

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/7

no ip address

shutdown

serial restart-delay 0

!

router rip

version 2

network 3.0.0.0

network 192.168.1.0

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

R1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

C    192.168.1.0/24 is directly connected, Serial1/0

R2#sh ip rou

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

R       1.1.1.1 [120/1] via 192.168.1.1, 00:00:01, Serial1/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

C    192.168.1.0/24 is directly connected, Serial1

R3#sh ip rou

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

R       1.1.1.1 [120/1] via 192.168.1.1, 00:00:22, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

C    192.168.1.0/24 is directly connected, Serial1/0


1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Frame-relay network with RIP route

Hi,

split=horizon is disabled on a multipoint frame-relay physical interface and enabled on a multipoint frame-relay subinterface by default,it has no sense on a point-to-point subinterface. What split-horizon does is not sending updates out thesame interface they were received on.

So by default if you are using multipoint subinterfaces on the hub,the updates from one spoke won't get to the other spoke as split-horizon is enabled by default and you'll have to disable it with the no ip split-horizon command on the hub for each spoke to see the other spokes routes advertised by RIP.

The best design is to use point-to-point subinterfaces on all routers and you won't have to worry about static frame maps,split-horizon.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
6 REPLIES

Frame-relay network with RIP route

Try adding "no ip split-horizon" on the interface that connects to the frame on R1 and see if you get your routes...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Frame-relay network with RIP route

yes now it's working, can you please tell me any other way to do this without disableing split-horizon.

Purple

Frame-relay network with RIP route

Hi John,

Isn' split-horizon disabled by default on a physical Frame-relay interface ? In the config posted by OP the broadcast keyword is missing on the static mappings of the spokes.

Regards

Alain

Don't forget to rate helpful posts.
New Member

Frame-relay network with RIP route

Hi cadet alain,

i give broadcast command on all three routers after that rip start send updates also i enable rip on serial interface which directly connect to frame-realy switch.but now i understand how its work any why we need to disble split horizon on hub router

am very big confused what is the use of point to point and multipoint link i read one article they didn't disble split-horizon on point to point link and hub send updates to spoke to spoke.

It would be very helpful if you explain the use of point to point and multipoint links.

Purple

Frame-relay network with RIP route

Hi,

split=horizon is disabled on a multipoint frame-relay physical interface and enabled on a multipoint frame-relay subinterface by default,it has no sense on a point-to-point subinterface. What split-horizon does is not sending updates out thesame interface they were received on.

So by default if you are using multipoint subinterfaces on the hub,the updates from one spoke won't get to the other spoke as split-horizon is enabled by default and you'll have to disable it with the no ip split-horizon command on the hub for each spoke to see the other spokes routes advertised by RIP.

The best design is to use point-to-point subinterfaces on all routers and you won't have to worry about static frame maps,split-horizon.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Frame-relay network with RIP route

thanks, if i use point to point sub interface have to use seperate subnet for each spoke. anyway i understand well am going to try point to point sub interface if i got any problem or doubt with this scenario i ll post in my next reply aslo i ll rate this post if it success . Thanks for your useful reply cadet.

745
Views
0
Helpful
6
Replies
CreatePlease login to create content