Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi all,

Router 1 is connected back to back serial WIC 1T  to Router 2.

Router 1 is config with frame relay switching command and is acting as DCE.

OSPF is running between them

Router A config

sh run int se1/0

Building configuration...

Current configuration : 175 bytes

!

interface Serial1/0

ip address 192.168.2.1 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay interface-dlci 103

frame-relay intf-type dce

end

Serial int

sh int se1/0

Serial1/0 is up, line protocol is up

  Hardware is DSCC4 with integrated T1 CSU/DSU

  Internet address is 192.168.2.1/24

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation FRAME-RELAY, loopback not set

  Keepalive set (10 sec)

  Restart-Delay is 0 secs

  LMI enq sent  0, LMI stat recvd 0, LMI upd recvd 0

  LMI enq recvd 4146, LMI stat sent  4146, LMI upd sent  0, DCE LMI up

  LMI DLCI 1023  LMI type is CISCO  frame relay DCE

  FR SVC disabled, LAPF state down

  Broadcast queue 0/64, broadcasts sent/dropped 30/0, interface broadcasts 0

  Last input 00:00:01, output 00:00:04, output hang never

  Last clearing of "show interface" counters 11:48:32

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     7711 packets input, 348717 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     290 input errors, 272 CRC, 18 frame, 0 overrun, 0 ignored, 0 abort**********************************************************Input and CRC  errors

     6275 packets output, 240861 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Logs

Jan  3 05:59:00.324 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

Jan  3 05:59:00.324 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached

Jan  3 05:59:20.358 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

Jan  3 06:02:20.669 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from LOADING to FULL, Loading Done

Jan  3 06:23:00.943 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

Jan  3 06:23:00.943 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached

Jan  3 06:23:20.976 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

Jan  3 06:26:31.305 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from LOADING to FULL, Loading Done

Jan  3 08:44:51.632 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

Jan  3 08:44:51.632 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached

Jan  3 08:45:11.669 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

Jan  3 08:48:32.010 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from LOADING to FULL, Loading Done

Jan  3 09:44:15.312 MST: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection

Jan  3 09:53:41.457 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

Jan  3 09:53:41.457 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached

Jan  3 09:54:01.678 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

Jan  3 09:57:06.962 MST: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.8.3 on Serial1/0 from LOADING to FULL, Loading Done

*********************************************************************************************************************************************************

Router 2 config

     sh run int se0/1

Building configuration...

Current configuration : 184 bytes

!

interface Serial0/1

ip address 192.168.2.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

frame-relay interface-dlci 103

end

Serial interface

sh int se0/1

Serial0/1 is up, line protocol is up

  Hardware is PQUICC with Fractional T1 CSU/DSU

  Internet address is 192.168.2.2/24

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation FRAME-RELAY, loopback not set

  Keepalive set (10 sec)

  Restart-Delay is 0 secs

  LMI enq sent  4220, LMI stat recvd 4115, LMI upd recvd 0, DTE LMI up

  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0

  LMI DLCI 1023  LMI type is CISCO  frame relay DTE

  FR SVC disabled, LAPF state down

  Broadcast queue 0/64, broadcasts sent/dropped 34/0, interface broadcasts 0

  Last input 00:00:08, output 00:00:08, output hang never

  Last clearing of "show interface" counters 11:43:20

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     6217 packets input, 237778 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     7618 packets output, 343965 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Logs of Router 2

Jan  3 06:00:31.167 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from FULL to DOWN, Neighbor Down: Too many retransmissions

.Jan  3 06:01:31.072 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from DOWN to DOWN, Neighbor Down: Ignore timer expired

.Jan  3 06:01:31.508 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from LOADING to FULL, Loading Done

.Jan  3 06:24:27.381 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from FULL to DOWN, Neighbor Down: Too many retransmissions

.Jan  3 06:25:27.286 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from DOWN to DOWN, Neighbor Down: Ignore timer expired

.Jan  3 06:25:39.227 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from LOADING to FULL, Loading Done

.Jan  3 08:46:05.466 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from FULL to DOWN, Neighbor Down: Too many retransmissions

.Jan  3 08:47:05.372 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from DOWN to DOWN, Neighbor Down: Ignore timer expired

.Jan  3 08:47:25.828 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from LOADING to FULL, Loading Done

.Jan  3 09:54:27.711 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from FULL to DOWN, Neighbor Down: Too many retransmissions

.Jan  3 09:55:27.617 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from DOWN to DOWN, Neighbor Down: Ignore timer expired

.Jan  3 09:55:29.529 MST: %OSPF-4-NONEIGHBOR: Received database description from unknown neighbor 4.4.4.4

.Jan  3 09:55:34.545 MST: %OSPF-4-NONEIGHBOR: Received database description from unknown neighbor 4.4.4.4

.Jan  3 09:55:39.537 MST: %OSPF-4-NONEIGHBOR: Received database description from unknown neighbor 4.4.4.4

.Jan  3 09:55:44.529 MST: %OSPF-4-NONEIGHBOR: Received database description from unknown neighbor 4.4.4.4

.Jan  3 09:55:54.505 MST: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/1 from LOADING to FULL, Loading Done

OSPF nei

sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

4.4.4.4           1   FULL/BDR        00:01:41    192.168.2.1     Serial0/1

My question is why OSPF nei is getting down so frequently and CRC, Input errors are on Router 1?

Thanks

MAhesh

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Frame Relay OSPF nei down Too many retransmissions

13 REPLIES

Re: Frame Relay OSPF nei down Too many retransmissions

Set the clock rate on the dce end and post the output of sh frame map and sh frame PVC And post your OSPF config of both devices

Sent from Cisco Technical Support iPad App

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew

Here is required info

Router 1

2691Router#sh frame-relay map

Serial0/0 (up): ip 192.168.1.2 dlci 102(0x66,0x1860), static,

              broadcast,

              CISCO

Serial1/0 (up): ip 192.168.2.2 dlci 103(0x67,0x1870), dynamic,

              broadcast,, status defined, active

2691Router#sh frame-relay pvc 103

PVC Statistics for interface Serial1/0 (Frame Relay DCE)

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 6171          output pkts 4987         in bytes 516641

  out bytes 436517         dropped pkts 0           in pkts dropped 0

  out pkts dropped 0                out bytes dropped 0

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0

  out BECN pkts 0          in DE pkts 0             out DE pkts 0

  out bcast pkts 83        out bcast bytes 2822

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  pvc create time 3d13h, last time pvc status changed 06:45:30

router ospf 1

router-id 4.4.4.4

log-adjacency-changes

redistribute static metric 50 metric-type 1

network 192.168.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0****************************************

network 192.168.5.0 0.0.0.255 area 0

network 192.168.6.0 0.0.0.255 area 0

neighbor 192.168.2.2********************************************************************

neighbor 192.168.1.2

default-information originate

Router 2

router ospf 1

log-adjacency-changes

area 4 stub

network 192.168.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0   ********************************

network 192.168.8.0 0.0.0.255 area 4

650Router#sh frame-relay map

Serial0/0 (up): ip 192.168.1.1 dlci 102(0x66,0x1860), static,

              broadcast,

              CISCO

Serial0/1 (up): ip 192.168.2.1 dlci 103(0x67,0x1870), dynamic,

              broadcast,, status defined, active

Serial0/1 (up): ip 192.168.2.2 dlci 103(0x67,0x1870), static,

              CISCO, status defined, active

2650Router#sh frame pvc 103

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1

  input pkts 5060          output pkts 6142         in bytes 437927

  out bytes 529083         dropped pkts 0           in pkts dropped 0

  out pkts dropped 0                out bytes dropped 0

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0

  out BECN pkts 0          in DE pkts 0             out DE pkts 0

  out bcast pkts 89        out bcast bytes 3026

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  pvc create time 1d21h, last time pvc status changed 06:48:42

Thanks

MAhesh

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew and darren

I am unable to set the clock rate on DCE  router it gives error

2691Router(config-if)#clock ?

  rate  Configure serial interface clock speed

2691Router(config-if)#clock rate 64000

This command applies only to DCE interfaces

Thanks

mahesh

Re: Frame Relay OSPF nei down Too many retransmissions

First thing remove "frame-relay intf-type dce" from routerA - then set the clock rate.

Then add static frame-relay maps to both routers defining the DLCI and IP address

i.e

Router1

int sx/x

frame-relay map ip 192.168.1.2 102 broadcast

Router2

int sx/x

frame-relay map ip 192.168.1.1 102 broadcast

Confirm ICMP pings from both sides - then change the OSPF interface type on both routers

int sx/x

ip ospf network point-to-point

Also remove keepalives from the frame serial interfaces "no keepalive"

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew,

Thanks for the reply.

I did exactly as you said on R1 router

2691Router(config-if)#ip ospf network point-to-point

2691Router(config-if)#end

2691Router#sh run int se1/0

Building configuration...

Current configuration : 226 bytes

!

interface Serial1/0

ip address 192.168.2.1 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

serial restart-delay 0

frame-relay map ip 192.168.2.2 103 broadcast

frame-relay interface-dlci 103

end

2691Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

2691Router(config)#int se1/0

2691Router(config-if)#clock rate 64000

This command applies only to DCE interfaces*****************************************

2691Router(config-if)#

Still unable to add clock rate?

MAhesh

Frame Relay OSPF nei down Too many retransmissions

I am afriad you did not - paste the below into 2691Router

interface s1/0

no frame-relay intf-type dce

clock rate 64000

no keepalive

no frame-relay interfface-dlci 103

frame-relay map ip 192.168.2.2 103 broadcast

ip ospf network point-to-point

and on the other router paste

interface s1/0

no keepalive

no frame-relay interfface-dlci 103

frame-relay map ip 192.168.2.1 103 broadcast

ip ospf network point-to-point

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew,

Thanks for reply

Still unable to add clock rate to R1

R1 

2691Router(config-if)#clock rate 64000

This command applies only to DCE interfaces

2691Router(config-if)#end

2691Router#sh run int se1/0

Building configuration...

Current configuration : 208 bytes

!

interface Serial1/0

ip address 192.168.2.1 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

no keepalive

serial restart-delay 0

frame-relay map ip 192.168.2.2 103 broadcast

end

R2

2650Router#sh run int se0/1

Building configuration...

Current configuration : 244 bytes

!

interface Serial0/1

ip address 192.168.2.2 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

no keepalive

serial restart-delay 0

frame-relay map ip 192.168.2.1 103 broadcast

But now both interfaces are up up and ospf nei is full .

Only thing changed is Network type from Non Broadcast to Point to point.

2691Router#sh ip ospf int se1/0

Serial1/0 is up, line protocol is up

  Internet Address 192.168.2.1/24, Area 0

  Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 65*****************

  Transmit Delay is 1 sec, State POINT_TO_POINT

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:07

  Supports Link-local Signaling (LLS)

  Index 4/4, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 6, maximum is 7

  Last flood scan time is 0 msec, maximum is 4 msec

  Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 192.168.8.3

  Suppress hello for 0 neighbor(s)

So Andrew in this case now it is point to point and there is no DR and BDR .

So we can consider this as Hub or spoke connection or just point to point?

So far no errors.

Thanks

mahesh

Frame Relay OSPF nei down Too many retransmissions

That is correct there are no elections on a pt-pt link.  It is just a pt-pt connection.

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew,

CRC errors occur again

R1

2691Router#sh int se1/0

Serial1/0 is up, line protocol is up

  Hardware is DSCC4 with integrated T1 CSU/DSU

  Internet address is 192.168.2.1/24

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation FRAME-RELAY, loopback not set

  Keepalive not set

  Restart-Delay is 0 secs

  FR SVC disabled, LAPF state down

  Broadcast queue 0/64, broadcasts sent/dropped 60/0, interface broadcasts 60

  Last input 00:00:02, output 00:00:06, output hang never

  Last clearing of "show interface" counters 00:10:06

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     55 packets input, 4620 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     6 input errors, 6 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     60 packets output, 5040 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2 is clean so far

2650Router#sh int se0/1

Serial0/1 is up, line protocol is up

  Hardware is PQUICC with Fractional T1 CSU/DSU

  Internet address is 192.168.2.2/24

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation FRAME-RELAY, loopback not set

  Keepalive not set

  Restart-Delay is 0 secs

  LMI DLCI 1023  LMI type is CISCO  frame relay DTE

  FR SVC disabled, LAPF state down

  Broadcast queue 0/64, broadcasts sent/dropped 70/0, interface broadcasts 70

  Last input 00:00:04, output 00:00:00, output hang never

  Last clearing of "show interface" counters 00:11:32

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     69 packets input, 5796 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     155 packets output, 11555 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Silver

Frame Relay OSPF nei down Too many retransmissions

mahesh18 wrote:

Hi all,

Router 1 is connected back to back serial WIC 1T  to Router 2.

Router 1 is config with frame relay switching command and is acting as DCE.

OSPF is running between them

Router A config

[...]

     290 input errors, 272 CRC, 18 frame, 0 overrun, 0 ignored, 0 abort**********************************************************Input and CRC  errors

     6275 packets output, 240861 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Mahesh.

You need to set a clock rate on the interface on router A (the DCE) and also check your cabling - you're getting CRC and frame errors which could indicate some dodgy cables somewhere. I suspect the OSPF is changing state so constantly because your link is flapping, caused by either the lack of clocking or the framing errors.

Cheers.

Re: Frame Relay OSPF nei down Too many retransmissions

Community Member

Frame Relay OSPF nei down Too many retransmissions

Hi Andrew,

Many thanks for your time to point me in right direction.

Now there are no CRC errors.

Thanks

Mahesh

Frame Relay OSPF nei down Too many retransmissions

No problem, glad to help.

984
Views
10
Helpful
13
Replies
CreatePlease to create content