Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame relay problem

Hi there

i am trying to set up a frame relay hub and spoke enviroment in my home lab.I have three 2600 routers and one frame switch(2520).R1 is the hub

I have the s0/0 of R1 connected to s1 of FR switch.R2 has s0/0 coneected t0 S2 of FRS and R3 has s0/0 to S3 of FRS.

The conf on FRS is

!

frame-relay switching

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

no ip address

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

clockrate 56000

no frame-relay inverse-arp

frame-relay lmi-type cisco

frame-relay intf-type dce

frame-relay route 122 interface Serial2 221

frame-relay route 123 interface Serial3 321

!

interface Serial2

no ip address

encapsulation frame-relay

clockrate 56000

no frame-relay inverse-arp

frame-relay lmi-type cisco

frame-relay intf-type dce

frame-relay route 221 interface Serial1 122

!

interface Serial3

no ip address

encapsulation frame-relay

clockrate 56000

no frame-relay inverse-arp

frame-relay lmi-type cisco

frame-relay intf-type dce

frame-relay route 321 interface Serial1 123

< THE CONFIG on R1 HUB is >

interface Serial0/0

ip address 172.12.123.1 255.255.255.0

encapsulation frame-relay

frame-relay map ip 172.12.123.2 122 broadcast

frame-relay map ip 172.12.123.3 123 broadcast

no frame-relay inverse-arp

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

ip classless

<THE CONFIG ON SPOKE R2 is >

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 172.23.23.2 255.255.255.224

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/0.123 multipoint

ip address 172.12.123.2 255.255.255.0

frame-relay map ip 172.12.123.1 221 broadcast

frame-relay map ip 172.12.123.3 221

THE CONFIG ON SPOKE R3 IS

nterface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 172.23.23.3 255.255.255.224

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/0.31 point-to-point

ip address 172.12.123.3 255.255.255.0

frame-relay interface-dlci 321

!

interface Serial0/1

no ip address

shutdown

WHEN GO FRS AND RUN

SHOW FRAME ROUTE it gives output

2520-1#sh frame route

Input Intf Input Dlci Output Intf Output Dlci Status

Serial1 122 Serial2 221 inactive

Serial1 123 Serial3 321 inactive

Serial2 221 Serial1 122 inactive

Serial3 321 Serial1 123 inactive

When i Run SHOW FRAME MAP on R1 It gives output

R1#sh frame map

Serial0/0 (down): ip 172.12.123.2 dlci 122(0x7A,0x1CA0), static,

broadcast,

CISCO, status deleted

Serial0/0 (down): ip 172.12.123.3 dlci 123(0x7B,0x1CB0), static,

broadcast,

CISCO, status deleted

THE OUTPUT OF SH FRAME MAP ON R2 IS

R2#sh frame map

Serial0/0.123 (down): ip 172.12.123.1 dlci 221(0xDD,0x34D0), static,

broadcast,

CISCO, status defined, inactive

Serial0/0.123 (down): ip 172.12.123.3 dlci 221(0xDD,0x34D0), static,

CISCO, status defined, inactive

How can i bring this pvc to be active

please help

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Frame relay problem

Hi There

Another person using the Bryant Advantage study material. I recognise the configuration :)

Can I ask if you have run the command "no shutdown" on the Frame interfaces on R1, R2 & R3 as well as on the Frame Switches interfaces?

The "show frame map" command on R1 shows "status deleted" this signifies a problem at the local end, and is usually either a problem with the frame mappings or the interface administratively down. Your frame mappings look correct.

The "show frame map" statements on R2 & R2 show "status defined inactive". This signifies a problem on the far end. You would expect to see this if the far end router was not yet configured for Frame Relay.

So my advice at this stage is check that all interfaces are open, on the Frame switch as well as the hub and spokes. After that I would make sure that you have the DCE ends of you serial back to back cables connected to the Frame Switches interfaces and the DTE ends going to to the hub and spoke routers.

Other than that I am not sure as I have compared your configuration with both my own home lab and the Bryant Advantage study material and it looks ok.

HTH

Best Regards,

Michael

2 REPLIES
Silver

Re: Frame relay problem

Hi There

Another person using the Bryant Advantage study material. I recognise the configuration :)

Can I ask if you have run the command "no shutdown" on the Frame interfaces on R1, R2 & R3 as well as on the Frame Switches interfaces?

The "show frame map" command on R1 shows "status deleted" this signifies a problem at the local end, and is usually either a problem with the frame mappings or the interface administratively down. Your frame mappings look correct.

The "show frame map" statements on R2 & R2 show "status defined inactive". This signifies a problem on the far end. You would expect to see this if the far end router was not yet configured for Frame Relay.

So my advice at this stage is check that all interfaces are open, on the Frame switch as well as the hub and spokes. After that I would make sure that you have the DCE ends of you serial back to back cables connected to the Frame Switches interfaces and the DTE ends going to to the hub and spoke routers.

Other than that I am not sure as I have compared your configuration with both my own home lab and the Bryant Advantage study material and it looks ok.

HTH

Best Regards,

Michael

New Member

Re: Frame relay problem

hi

thank so much michael

I just got to much bad luck whenever i sit down and work on the routers occasionally

My cables ditch me all the time and this is the third time it happenned to me.

it was a faulty cable wasting all my time

Whew!

112
Views
0
Helpful
2
Replies