Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame Relay QOS - PVC vs Main Interface

All,

  I'm working on a 7204 router with multiple FR DLCIs, one for internal WAN and the other for Internet access (using VFR for routing table separation, T3 physical/18Mbps CIR).  We have priority queing enabled via map-class on the subinterfaces and we aren't seeing drops on the subinterface queues.  We are still seeing drops on the serial interface, though, and some voice quality complaints.  My question is, should we lower the CIRs manually to match, attempt to add the service policy to the main interface (dumping FRTS), or do something else?  Since I don't have visibility to what's being dropped (can't show policy-map int) I'm not sure if the drop behavior is what I'm expecting.  Any help is appreciated.

Serial1/0 is up, line protocol is up
  Hardware is M1T-T3+ pa
  Description: 4032434
  MTU 4470 bytes, BW 18432 Kbit, DLY 200 usec,
     reliability 255/255, txload 16/255, rxload 42/255
  Encapsulation FRAME-RELAY IETF, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
    Broadcast queue 0/256, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 6d20h
  Input queue: 0/75/0/22578 (size/max/drops/flushes); Total output drops: 12474
  Queueing strategy: dual fifo
  Output queue: high size/max/dropped 0/256/0
  Output queue: 0/128 (size/max)
  5 minute input rate 3091000 bits/sec, 501 packets/sec
  5 minute output rate 1209000 bits/sec, 539 packets/sec
     130058690 packets input, 1958602193 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
              0 parity
     0 input errors, 0 CRC, 0 frame, 0 overrun, 401 ignored, 0 abort
     169482430 packets output, 1317261149 bytes, 0 underruns
     0 output errors, 0 applique, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions
   rxLOS inactive, rxLOF inactive, rxAIS inactive
   txAIS inactive, rxRAI inactive, txRAI inactive

config snippets

map-class frame-relay VOICE-MAP
frame-relay cir 18432000
frame-relay mincir 18432000
frame-relay fragment 1000
service-policy output VOICE-POLICY

class-map match-all VOICE-CLASS
match  dscp ef
class-map match-any VOICE-CONTROL
match  dscp cs3
match  dscp af31
class-map match-all voice
match  dscp ef
match fr-dlci 31
!
!
policy-map VOICE-POLICY
  class VOICE-CLASS
  priority 5000
  class VOICE-CONTROL
  bandwidth 2000
  class class-default
  fair-queue

interface Serial1/0
description 4032434
no ip address
encapsulation frame-relay IETF
ip route-cache flow
dsu bandwidth 18432
framing c-bit
cablelength 10
serial restart-delay 0
frame-relay traffic-shaping
frame-relay lmi-type ansi
max-reserved-bandwidth 96
!
interface Serial1/0.30 point-to-point
description DIA-VC-30
ip address 67.155.1.193 255.255.255.252
ip access-group block-private-networks in
ip access-group match-local out
no cdp enable
frame-relay class VOICE-MAP
frame-relay interface-dlci 30 IETF
!
interface Serial1/0.31 point-to-point
description Mesh-VPN-VC-31
ip vrf forwarding VPN
ip address 10.1.1.1 255.255.255.252
ip nbar protocol-discovery
no cdp enable
frame-relay class VOICE-MAP
frame-relay interface-dlci 31 IETF

Everyone's tags (3)
1 REPLY
Hall of Fame Super Bronze

Re: Frame Relay QOS - PVC vs Main Interface

You won't see output drops under logical interfaces, you will only see it under physical interfaces.

S1/0 represents both logical interfaces and there is congestion on egress.

You mentioned having 18Mbps from the provider - that's your CIR for all logical interfaces under S1/0

You've configured a map-class that instruct the router that each logical interface can use 18Mbps.

If both logical interfaces, per your example, are sending 18Mbps at the same time, you will have oversubscription on the serial interface.

You need to create a map-class that will provide a total of 18Mbps for both classes, not each having 18Mbps.

You must also make use of the mincir effectively along with a frame-relay adaptive shaping mechanism.

My recommendation for your map-class would be:

map-class frame-relay VOICE-MAP
frame-relay cir 18432000
frame-relay mincir 9216000

frame-relay adaptive-shaping interface-congestion
frame-relay fragment 1000

1533
Views
0
Helpful
1
Replies
CreatePlease to create content