Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Frame relay question

All,

I have a test lab configured in gns3 for frame-relay, and I had the following question.

I configured frame relay on both router's physical interfaces, but I couldn't ping either one. I then changed the physical interface to only encapsulate frame-relay and then I created subinterfaces for point-to-point connections. I could then ping each router.

My question is, when is it appropriate to use the "frame-relay map ip" command? I tried this command on the physical interface before creating my subinterfaces and it didn't work.

Thanks,

John

HTH, John *** Please rate all useful posts ***
23 REPLIES
Hall of Fame Super Silver

Re: Frame relay question

Hello John,

frame-relay map ip is useful for point-to-multipoint subinterfaces and physical interfaces in the following scenarios:

(one of more of the following can apply)

a) you don't want to rely on inverse-ARP

b) you need to run routing protocols that use multicast discovery so you use

frame-rel map ip remote-ip local-dlci-to-remote-ip broadcast

broadcast keyword

c) you haven't a full mesh but an hub and spoke and you need to add an additional

frame-relay map ip other-spoke-ipaddr dlci_to_hub

in order to ping from spoke to spoke on wan interfaces

It should have worked also with physical interfaces: notice that if you have emulated a back to back connection the dlci cannot change at the two ends

Hope to help

Giuseppe

Re: Frame relay question

Giuseppe,

What do you mean by this:

"notice that if you have emulated a back to back connection the dlci cannot change at the two ends"?

What I had configured is "something" like this:

RTRA:

int s0/0

ip address 192.168.1.1 255.255.255.0

encaps frame-relay

frame-relay interface-dlci 100

frame-relay map ip 192.168.1.2 101 broadcast

(I also tried frame-relay local-dlci 100)

RTRB:

int s0/0

ip address 192.168.1.2 255.255.255.0

encaps frame-relay

frame-relay interface-dlci 101

frame-relay map ip 192.168.1.1 100 broadcast

I was unable to ping from either router. I took the same config and placed it under a subinterface as p2p, and it worked fine. This was all virtual though (using gns3), so I'm not sure how accurate it is. I also tried to put on one router "frame-relay intf-type dce" to emulate the dce side of the connection, but that didn't work either =)

Thanks!

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Blue

Re: Frame relay question

John

GNS3 is accurate, it's just a GUI front-end for dynamips.

What Giuseppe was referring to was the difference between 2 routers

1) connected directly together via a serial link

2) each router connected to a frame-relay switch, which is an option in dynamips.

You could always post the GNS3 .net file and i could load it up and have a look.

Jon

Hall of Fame Super Silver

Re: Frame relay question

Hello John,

unless you have configured a router to act as a FR switch the DLCI is the same.

if you have a FR switch the situation can be:

RA -- DLCI 101 -- FR switch --- DLCI 100

there is no concept of local DLCI : DLCI is always local on each interface to FR switch link.

so for the scenario above

RA

int ser0/0

frame-rel map ip 192.168.1.2 100 broadcast

RB

int ser0/0

frame-rel map ip 192.168.1.1 101 broadcast

this is all you need.

frame-relay interface-dlci is usually used with point-to-point subinterfaces.

Hope to help

Giuseppe

Re: Frame relay question

John,

Rememeber you have to link the layer 2 (Frame Relay) to the layer 3 (IP)

Without "frame-relay map ip" how will the device to know what layer 2 needs to bew binded to what layer 3?

It would be appropriate to use it on point-multipoint, or when you have not configured a specific interface for a specific DLCI, alsi if you do not have address space available for the WAN to be a whole /24

HTH>

Hall of Fame Super Bronze

Re: Frame relay question

Hi John,

Frame-Relay networks are non-broadcast in nature and they need Layer2 to Layer3 mapping for IP connectivity.

When you use the frame-relay map ip you are performing a static mapping but if you want long enough while the interface are up/up, you will also get dynamic mappings from the Frame-Relay switch. Frame-Relay relies on inverse-arp (enabled by default) for dynamic mappings but this process can be delayed so the fastest way to get connectivity is to use static mappings.

You mentioned the static mappings didn't work, care to post the sample config along with the show frame pvc output?

HTH,

__

Edison.

Re: Frame relay question

Edison,

This was all virtual in gns3. I'll get the output tonight when I'm playing with it again, and I'll post the output tomorrow.

Thanks!

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Bronze

Re: Frame relay question

John,

Yes, you said GNS3 at the beginning and that's why I said if you wait long enough.

Now, I created a little lab on GNS3 with a FRSW (provided by GNS3) along with 2 3600 routers.

On the FRSW, I create the following mapping:

Port 1

DLCI 101

Port 2

DLCI 201

Port 2 is connected to R1

Port 1 is connected to R0

Looking at R1 show frame pvc output is showing DLCI 201:

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 0 0 0 0

Switched 0 0 0 0

Unused 0 1 0 0

DLCI = 201, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial0/0

This information is being sent from the FRSW.

On R0, I see DLCI 101

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 0 0 0 0

Switched 0 0 0 0

Unused 0 1 0 0

DLCI = 101, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial0/0

If I wait long enough, both PVCs will be ACTIVE and I will have mappings thus the ability to ping will be there.

R0 is now ACTIVE:

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 1 0 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

R1 is also ACTIVE:

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 1 0 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

And you can see the mapping:

R0#sh frame map

Serial0/0 (up): ip 192.168.12.2 dlci 201(0xC9,0x3090), dynamic,

broadcast,, status defined, active

R1#sh frame map

Serial0/0 (up): ip 192.168.12.1 dlci 101(0x65,0x1850), dynamic,

broadcast,, status defined, active

And ping across:

R1#ping 192.168.12.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:

!!!!!

R0#ping 192.168.12.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:

!!!!!

Now, if you are referring to the fact that you can't ping the interface itself, well - that's a different story and you have to create a static mapping pointing to a remote DLCI for this to work.

BTW, here is the portion of the config:

R1#sh run int s0/0

Building configuration...

Current configuration : 117 bytes

!

interface Serial0/0

ip address 192.168.12.2 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

end

R0#sh run int s0/0

Building configuration...

Current configuration : 117 bytes

!

interface Serial0/0

ip address 192.168.12.1 255.255.255.0

encapsulation frame-relay

serial restart-delay 0

Re: Frame relay question

That's awesome Edison! I could get the routers to see each other creating the dlci through the frame switch that gns provides. I wanted to see the "frame-relay map" in action, and that's what I couldn't get to work.

Thanks!

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Bronze

Re: Frame relay question

John,

Well, tonight - be sure to post the show frame pvc and identify what each side is seeing.

Dynamic mapping can be painful a times and a reboot may be required. Static mappings works right away and from my example, R1 static mapping would be like:

frame map ip 192.168.12.1 dlci 101

and R0

frame map ip 192.168.12.2 dlci 201

Re: Frame relay question

Okay,

My pvcs came up, and I see what you mean about how it will learn the mapping from the switch. I couldn't get R1 to see R2 because it wasn't in the mapping (sh frame-relay map), so I tried to manually map it and it still didn't work.

Here's the topology (gns3 file), and the configs that I created.

R0 can see R1 and R2

R2 can see R0 but not R1

R1 can see R0 but not R2

I couldn't map more dlcis in the switch because they said they were already mapped. The dlci config on the FRSw looks like:

1:101 2:201

1:102 3:202

(or something like that). I could map 2:201 -> 3:202 or vice-versa.

Also, I can't get ospf to run between R1 and R0, but R0 and R2 work fine.

Thanks!

John

HTH, John *** Please rate all useful posts ***

Re: Frame relay question

And here's the last one.

Thanks!

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Bronze

Re: Frame relay question

John,

Your FRSW portion isn't complete. You need 2 PVCs for each spoke.

Here is my FRSW portion:

[[FRSW FR1]]

1:102 = 2:201

1:103 = 3:301

2:201 = 1:102

2:203 = 3:302

3:301 = 1:103

3:302 = 2:203

And I'm getting mappings:

R0#sh frame map

Serial0/0 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,

broadcast,, status defined, active

Serial0/0 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,

broadcast,, status defined, active

R1#sh frame map

Serial0/0 (up): ip 192.168.123.1 dlci 201(0xC9,0x3090), dynamic,

broadcast,, status defined, active

Serial0/0 (up): ip 192.168.123.3 dlci 203(0xCB,0x30B0), dynamic,

broadcast,, status defined, active

R2#sh frame map

Serial0/0 (up): ip 192.168.123.1 dlci 301(0x12D,0x48D0), dynamic,

broadcast,, status defined, active

Serial0/0 (up): ip 192.168.123.2 dlci 302(0x12E,0x48E0), dynamic,

broadcast,, status defined, active

BTW, don't use frame-relay interface-dlci under the main interface. This command is intended for DLCI allocation in subinterfaces.

http://www.cisco.com/en/US/docs/ios/wan/command/reference/wan_f1.html#wp1015008

HTH,

__

Edison.

Re: Frame relay question

Thanks Edison! I'll try your suggestions tonight. I created the mappings in gns3, and for some reason it kept telling me that the addresses were already mapped, which they weren't. I'll manually edit the file and see what happens.

Is there a way to keep FR routers from learning the mapping from the switch? I'd like to see how the frame-relay map ip statement works. Thank you for the link too. :)

Thanks!

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Bronze

Re: Frame relay question

Re: Frame relay question

Thanks! I'll let you know more tomorrow how things went :)

HTH, John *** Please rate all useful posts ***

Re: Frame relay question

disable "frame-relay inverse-arp"

Blue

Re: Frame relay question

Hi:

"Frame-Relay relies on inverse-arp (enabled by default) for dynamic mappings but this process can be delayed so the fastest way to get connectivity is to use static mappings."

Edison, I dont know how the virtual router system works because I never used it. But in the real world, on an actual device, isn't frame relay inverse arp automatically disabled when you configure a static mapping under an interface?

Thanks

Victor

Hall of Fame Super Bronze

Re: Frame relay question

Victor,

No, you have to manually disable it.

__

Edison.

Re: Frame relay question

Hi guys,

I am running/testing dynamic Frame-Relay mapping on GNS, too. I used a Cisco router as FR-switch; at first I tried with frame-relay route command on each interface, but after waiting more than 10 minutes for the wonder to happen I also tried with connect command.

None of these two works, as I got PVC up and the right DLCI but no mapping is developing after, and DLCI stays UNUSED.

Here is the FR-Switch configuration:

interface Serial0/0

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay intf-type dce

end

interface Serial0/1

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay intf-type dce

end

connect R2R5 Serial0/0 201 Serial0/1 102

show connection all   

ID   Name               Segment 1            Segment 2           State      

========================================================================

2    R2R5              Se0/0 201            Se0/1 102            UP         

And here is the R2 and R5 configuration:

R5#show frame-relay pvc

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

              Active     Inactive      Deleted       Static

  Local          0            0            0            0

  Switched       0            0            0            0

  Unused         1            0            0            0

DLCI = 102, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1

  input pkts 0             output pkts 0            in bytes 0        

  out bytes 0              dropped pkts 0           in pkts dropped 0        

  out pkts dropped 0                out bytes dropped 0        

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        

  out BECN pkts 0          in DE pkts 0             out DE pkts 0        

  out bcast pkts 0         out bcast bytes 0        

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  pvc create time 00:22:45, last time pvc status changed 00:22:35

R2#show frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static

  Local          0            0            0            0

  Switched       0            0            0            0

  Unused         1            0            0            0

DLCI = 201, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 0             output pkts 0            in bytes 0        

  out bytes 0              dropped pkts 0           in pkts dropped 0        

  out pkts dropped 0                out bytes dropped 0        

  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        

  out BECN pkts 0          in DE pkts 0             out DE pkts 0        

  out bcast pkts 0         out bcast bytes 0        

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  pvc create time 00:22:59, last time pvc status changed 00:22:49

The FR on R2 and R5 is configured on subinterfaces:

R2#sri se0/0 

!

interface Serial0/0

no ip address

encapsulation frame-relay

serial restart-delay 0

end

interface Serial0/0.1 multipoint

ip address 172.10.7.1 255.255.255.240

ip ospf 100 area 0

end

R5#sri se0/1

!

interface Serial0/1

no ip address

encapsulation frame-relay

serial restart-delay 0

end

interface Serial0/1.1 multipoint

ip address 172.10.7.5 255.255.255.240

ip ospf 100 area 0

end

Any idea would be highly appreciated !

Re: Frame relay question

Meanwhile I started another Frame Relay - GNS 3 scenario:

R3 is configured as FR-Switch

R1 and R2 are connected to R3 using FR encapsulation. I configured 2 IP addresses on Serial interfaces.

R4 and R5 are also connected to R3. R4 is configured on a subinterface point-to-point, while R5 is configured on a subinterface multipoint.

Here are some results:

R1 - R2 communication started to work IMMEDIATELY (of course using inverse-arp)

On the FR switch I configured:

connect R2R4 Serial0/0 204 Serial0/2 402

connect R1R5 Serial0/1 105 Serial0/3 501

None of these two pairs, works. After debug frame-relay packet issued on both R4 and R5 it's clear that inverse-arp is not working on either of these two. Nevertheless both R1 and R2 send INARP packets:

R4: Serial0/2: frame relay INARP received

R5: Serial0/3: frame relay INARP received

My conclusion is that at least on 3640 model I use, INARP does NOT work on SUBINTERFACES.

Feel free to share your experience about this.

L.E. I run another couple of tests:

1. I stopped both "trouble routers" R4 and R5.

2. I started R4 because I read somewhere that INARP works after a router reload. The results was the same: PVC gets ACTIVE but UNUSED. R2 receives no INARP from R4, it just send INARP for PVC 204. Because of this if I try to ping 10.0.0.4 I receive the classic error:

Serial0/0:Encaps failed--no map entry link 7(IP).

3. I changed the configuration on the FR-Switch and replaced:

no connect R1R5 Serial0/1 105 Serial0/3 501 with

frame-relay route 501 interface se0/1 105 on Se0/3

frame-relay route 105 interface se0/3 501 on Se0/0

4. I started R5 but I received the same results as stated at point 2.

5. I waited 10 minutes before "ending tests" in case FR "converges" slowly than expected.

6. I added static mapping between R1 and R5 and worked at once!

7. I added PVC between R4 and R5 and again INARP doesn't work.

With these tests I believed I exhausted most of the possibilities.

Purple

Frame relay question

Hi,

in your first example you had forgot to assign the DLCI to the subinterface( by default it is on the physical interface) with

the frame-relay interface-dlci command under each subinterface.

I suspect you have the same problem in your second test.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Re: Frame relay question

Ok, so you are saying that without frame-relay interface-dlci command INARP will not work on FrameRelay subinterfaces?

Here is what I read while you were posting:

When a multipoint subinterface is created under a physical interface, it is necessary to specifically assign DLCIs to the multipoint subinterface.

By default, the Cisco IOS software allocates all unassigned DLCIs advertised by the Frame Relay switch to the physical interface on the router.

On a multipoint subinterface, the frame-relay interface-dlci dlci command or the frame-relay map protocol protocol-address dlci [broadcast] command in the subinterface configuration mode can be used to associate the multipoint subinterface with specific DLCIs.

The frame-relay interface-dlci dlci command performs dynamic address mapping using Inverse ARP to map the next-hop protocol address to the local DLCI on the router.

Seems I learned this the hard way!

Thank you for clearing this up!

503
Views
39
Helpful
23
Replies
CreatePlease to create content