Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Frame Relay + Ripv2 Issue

Hello all,

I am having an issue with frame relay and rip. For some reason I cannot send pings to R3 over frame relay. Here are my configs

Here are the configs for R1

router rip

version 2

redistribute connected

passive-interface FastEthernet0/1

network 10.0.0.0

network 172.16.0.0

default-information originate

no auto-summary

interface Serial0/0/1

ip address 172.16.0.9 255.255.255.252

encapsulation frame-relay

frame-relay map ip 172.16.0.10 103 broadcast

frame-relay interface-dlci 103

frame-relay lmi-type ansi

no keepalive

Configs for R3

interface Serial0/0/0

ip address 172.16.0.10 255.255.255.252

encapsulation frame-relay

frame-relay map ip 172.16.0.9 301 broadcast

frame-relay interface-dlci 301

frame-relay lmi-type ansi

no keepalive

clock rate 4000000

router rip

version 2

redistribute connected

passive-interface FastEthernet0/1

network 10.0.0.0

network 172.16.0.0

default-information originate

no auto-summary

I was told that there was supposed to be 7 entries for RIP, but I am not sure what I am missing. Can any of you point me in the right direction please?

  • WAN Routing and Switching
14 REPLIES
Hall of Fame Super Silver

Re: Frame Relay + Ripv2 Issue

Hello Joshua,

I would remove frame-relay interface-dlci XX commands they are good for point-to-point subinterfaces and you are using the main interfaces.

Notice that if the two are directy connected to each other (I see you have the clock on one side) the DLCI cannot change and one of the two should use

frame-relay intf-type dce

Hope to help

Giuseppe

New Member

Re: Frame Relay + Ripv2 Issue

so your saying my frame relay dcli 103 and 301 commands should not be in there?

Does it matter which two use

frame-relay intf-type dce ?

also what does that command do?

New Member

Re: Frame Relay + Ripv2 Issue

I tried entering that command and in the packet tracer file it says the command is unreconized

New Member

Re: Frame Relay + Ripv2 Issue

I can upload the packet tracer file that I been practicing on

Re: Frame Relay + Ripv2 Issue

Packet Tracer does not handle alot of Frame relay commands. You can use the 'cloud', but as for commands like frame-reley switching and other commands, it wont work for that.

New Member

Re: Frame Relay + Ripv2 Issue

ic ic.

Right now there is not frame relay switching going on. Its just two serial links (its part of a lab I am testing out).

Re: Frame Relay + Ripv2 Issue

I plugged in your config and troubleshot it for about an hour, no good....the output below shows it 'should' work...but sometimes with PacketTracer you have to be careful, you could be doing everything right, but PT will say your wrong...I will plug the configs into a lab enviroment Monday or Tuesday and let you know how it goes then.

R1#sh frame-relay map

Serial1/0 (up): ip 172.16.0.10 dlci 103, static, broadcast, CISCO, status defined, active

Serial1/0 (up): ip 172.16.0.9 dlci 103, static, CISCO, status defined, active

R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial1/0

input pkts 14055 output pkts 32795 in bytes 1096228

out bytes 6216155 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 32795 out bcast bytes 6216155

R1#ping 172.16.0.9

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.0.9, timeout is 2 seconds:

.....

New Member

Re: Frame Relay + Ripv2 Issue

thank you jim, I appreciate you helping me out>

Re: Frame Relay + Ripv2 Issue

I started a new thread:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&topicID=.ee71a06&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cd2fe59

I never could get it working (on real routers), so I am only left to believe it cant. Did you lab say it should work? Was it a cisco netacad lab?

296
Views
12
Helpful
14
Replies
This widget could not be displayed.