Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame Relay shaping, PVC, QoS and GRE Tunnel

Hi

I'm trying to configure QoS (CBWFQ) on a 2620XM router that run its GRE Tunnel interface through a FR PVC that has FR traffic shaping (TS)configured on the PVC as per below:

!

class-map match-all FTP-Traffic

match protocol ftp

class-map match-any Interactive

match protocol citrix

match protocol telnet

class-map match-any Transactional

match protocol sqlnet

match protocol sqlserver

class-map match-all Batch

match protocol exchange

!

!

policy-map QoS

class Interactive

set precedence 3

priority percent 30

class Transactional

bandwidth percent 20

class FTP-Traffic

bandwidth percent 10

class Batch

bandwidth percent 10

class class-default

fair-queue

!

interface Tunnel0

ip route-cache flow

qos pre-classify

tunnel source 192.168.155.xx

tunnel destination 192.168.155.yy

!

interface Serial0/0

encapsulation frame-relay IETF

frame-relay traffic-shaping

frame-relay lmi-type ansi

hold-queue 1500 out

!

interface Serial0/0.16 point-to-point

frame-relay class Shaping-QOS

frame-relay interface-dlci 16

!

!

map-class frame-relay Shaping-QOS

frame-relay traffic-rate 1024000 1920000

frame-relay adaptive-shaping becn

service-policy output QoS

My problem is I don't think that the config is working since it does not show any match packets as shown:

c2620XM#sho policy-map int t0

c2620XM#sho policy-map int s0/0

c2620XM#sho policy-map int s0/0.16

Serial0/0.16: DLCI 16 -

Service-policy output: QoS

Class-map: Interactive (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol citrix

0 packets, 0 bytes

30 second rate 0 bps

Match: protocol telnet

0 packets, 0 bytes

30 second rate 0 bps

QoS Set

precedence 3

Packets marked 0

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 30 (%)

Bandwidth 153 (kbps) Burst 3825 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: Transactional (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol sqlnet

0 packets, 0 bytes

30 second rate 0 bps

Match: protocol sqlserver

0 packets, 0 bytes

30 second rate 0 bps

Queueing

Output Queue: Conversation 41

Bandwidth 20 (%)

Bandwidth 102 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: FTP-Traffic (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol ftp

Queueing

Output Queue: Conversation 42

Bandwidth 10 (%)

Bandwidth 51 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: Batch (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol exchange

Queueing

Output Queue: Conversation 43

Bandwidth 10 (%)

Bandwidth 51 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

7427853 packets, 1871077126 bytes

30 second offered rate 147000 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 32

(total queued/total drops/no-buffer drops) 0/426/0

c2620XM#

Can someone point out to me where my problem is. Thanks.

8 REPLIES

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Hi vincent. Can you so a "show frame-relay pvc 16". The service policy is applied to a frame-relay PVC so I think this should show the required output.

New Member

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Thanks Mark for your reply. Since the output exceeded the # characters limit, can you please look into the attached text file and let me know what you think. Thanks.

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Hi,

did you overload the PVC with traffic? If not, the counters will not encrease. The reason is, that the counters will not "see" packets CEF or fast switched. Only those packets queued will be seen, as only those will have to be treated by the CPU of the router.

You are doing CBWFQ and this is only invoked, when there is an overload situation. So use a traffic generator and make sure you get some drops as a sure indication of overloading the interface. If the counters still are not increasing, then the policy does not work and further investigations are needed.

Regards, Martin

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

hi, I see everything is going into the default queue. Just to make sure that traffic is coming in as expected can you enable "ip nbar protocol-discovery" on the inbound interface then do "show ip nbar protocol-discovery" to check that traffic is entering the router as you expect. If this is the case then I wonder if "qos pre-classify" is working correctly in your scenario. I've never used this feature before but as far as I can see you have configured it correctly. Can you respond with the previous nbar commands?

New Member

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Gents.

Thanks again for your posts. My answers to the two previous posts are as followed:

1. "Overloading the PVC" - I think that I'm definitely overloading the PVC. I have similar configuration at a different site and it's working fine. The only difference is the other site do not run via the GRE Tunnel interface but instead the FR PVC.

2. I've configured "ip nbat protocol-discovery" as requested. Attached is the output of the requested show command. Also, I've made sure that the destination (10.95.3.0/24) is via the Tunnel0 interface from this router.

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Hi Vincent. I setup your script in a lab and had the same issue. I believe the problem is because you are trying to classify and queue on the outbound interface. You need to split this up over different interfaces. Classify and mark traffic on your ingress interface. Then take action (queue) on the egress interface. I have configured this and it worked fine!

New Member

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

Thanks Mark for the reply. Is there any chance that you can show me the config that you setup in the lab that works?

Re: Frame Relay shaping, PVC, QoS and GRE Tunnel

sure (see below). I've not completed the queuing for all classes but I'm sure you get the idea.

class-map match-all Batch

match protocol exchange

class-map match-all ICMP

match protocol icmp

class-map match-all FTP-Traffic

match protocol ftp

class-map match-any Interactive

match protocol citrix

match protocol telnet

class-map match-any Transactional

match protocol sqlnet

match protocol sqlserver

class-map match-all Batch-out

match ip precedence 1

class-map match-all ICMP-out

match ip precedence 0

class-map match-all FTP-out

match ip precedence 2

class-map match-all interactive-out

match ip precedence 4

class-map match-any Transactional

match ip precedence 5

policy-map QOS-OUT

class FTP-out

bandwidth percent 10

class ICMP-out

bandwidth percent 5

class interactive-out

priority percent 30

class class-default

fair-queue

policy-map QoS

class Interactive

set precedence 4

class Transactional

set precedence 5

class FTP-Traffic

set precedence 2

class Batch

set precedence 1

class ICMP

interface Tunnel0

ip address 31.31.31.3 255.255.255.0

qos pre-classify

tunnel source 1.1.1.3

tunnel destination 1.1.1.1

!

interface FastEthernet0/0

ip address 20.20.20.3 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

service-policy input QoS

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

frame-relay traffic-shaping

hold-queue 1500 out

!

interface Serial0/0.31 point-to-point

ip address 1.1.1.3 255.255.255.0

frame-relay interface-dlci 301

class Shaping-QOS

ip route 0.0.0.0 0.0.0.0 Tunnel0

!

map-class frame-relay Shaping-QOS

frame-relay traffic-rate 1024000 1920000

frame-relay adaptive-shaping becn

service-policy output QOS-OUT

258
Views
5
Helpful
8
Replies
CreatePlease to create content