Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame Relay Switch

I have a cisco 2610 router (IOS 12.3(15)) that I am trying to configure as a frame relay switch. It has 2 T1 DSU/CSU cards. I am experiencing some difficulty in activating the 2 serial interfaces. I have attached the show run and show frame route outputs. Any help in getting the configuration correct would be greatly appreciated.

Thanks

I have corrected the configuration and my frame relay switch is up and running. The following is the configuration for the frame relay switch.

FRS#sh run
Building configuration...

Current configuration : 1113 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
frame-relay switching
!
!
!
interface Ethernet0/0
ip address 192.168.1.10 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
fair-queue
service-module t1 clock source internal
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 122 interface Serial0/1 221
!
interface Serial0/1
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
fair-queue
service-module t1 clock source internal
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 221 interface Serial0/0 122
!
ip http server
ip classless
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!
!
end

FRS#

The following is the configuration for one of my frame relay spoke routers.

Vista#sh run
Building configuration...

Current configuration : 702 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Vista
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
no ip address
!
interface Serial0/1
ip address 192.168.1.4 255.255.255.0
encapsulation frame-relay
fair-queue
frame-relay interface-dlci 221
!
        
ip http server
ip classless
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!
!
end

Vista#

Message was edited by: barhamgary

Everyone's tags (2)
2 REPLIES
Hall of Fame Super Gold

Re: Frame Relay Switch

Also include "show version", you need enterprise IOS for FR switching.

Do not use attachments unless necessary.

Re: Frame Relay Switch

Your configuration looks fine, so I don't think this is an IOS related issue (Commands won't be accepted for unsupported features)

The CE on se0/0 should have dlci 122 and the one on se 0/1 should have dlci 221. If it doesn't work, check if Layer 1 is up on both ends, then try "debug frame lmi" on the CE and the switch.

857
Views
0
Helpful
2
Replies