Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Frame Relay traffic shaping

Good day

I'm trying to traffic shape a circuit I have currently it is set up to take the full T1 1536K what I wanted to do is shape that to only take 1M how or can someone point me to a doc that tells me how to do this? Thank you in advance!!!

12 REPLIES
Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

You can do Frame-Relay Traffic Shaping (FRTS) or Generic Traffic Shaping (GTS) with Modular QoS CLI (MQC).

With FRTS, you have the ability to shape per PVC while with GTS, it treats the interface as a single interface. In other words, you can designated traffic to DLCI 101 without affecting DLCI 102.

Due to this limitation, it's often recommended to shape using FRTS vs GTS.

Can you provide your config and network topology ?

__

Edison.

Community Member

Re: Frame Relay traffic shaping

Sure basically I have a point to point connection. Here is the config on both ends:

Far end:

interface Serial0/0/0

bandwidth 1536

ip address 172.19.90.126 255.255.255.252

encapsulation frame-relay

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

frame-relay traffic-shaping

frame-relay map ip 172.19.90.125 121 broadcast

frame-relay lmi-type cisco

end

Near end(my end)

interface Serial0/0/0.138 point-to-point

description PVC to sfscitrt2

bandwidth 256000

ip address 172.19.90.125 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay class cit-fr-cmap

frame-relay interface-dlci 138

end

map-class frame-relay cit-fr-cmap

frame-relay cir 256000

frame-relay bc 32000

frame-relay be 160000

frame-relay mincir 128000

frame-relay adaptive-shaping becn

service-policy output cit-pmap-egress

I didn't see a map class on the far end

My goal is to stop this connection from taking

over the whole Frame T1. Whenever this connection burst up to the Full T1 I lose connectivity to 2 sites

Also to add I have a Frame T1 with 10 other connections on it not sure why we have a connection on a Frame T1 that can burst up to T1 speed but we do everthing else is 128k the second biggest connection is 512k

Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

On this router, you implemented FRTS - which is great !

It's configured for 256kbps and mincir 128kbps, can we see the config from the router you want to change ?

Please, also indicate how much traffic you want allocated per DLCI.

Community Member

Re: Frame Relay traffic shaping

On a public forum I'm not allowed to do so but

if you have a email address I can send it to you. I noticed that FRTS is only configured on my router(near end) but the remote end

I don't see anything configured.

Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

Just mask the ip addresses and DLCI information. I just want to have a general idea of how the config looks like.

You need to configure FRTS on the hub and spokes. You've only posted the config from one of the spokes.

Community Member

Re: Frame Relay traffic shaping

Here it is....

Current configuration : 12669 bytes

!

! Last configuration change at 14:13:24 UTC Thu Jan 17 2008 by wgranada

! NVRAM config last updated at 20:31:35 UTC Fri Dec 7 2007 by wgranada

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec show-timezone

service timestamps log datetime msec show-timezone

service password-encryption

no service dhcp

!

hostname sfscitrt2

!

boot-start-marker

boot system flash flash:c2800nm-advipservicesk9-mz.124-3d.bin

boot-end-marker

!

security authentication failure rate 10 log

logging buffered 16000 informational

no logging console

!

aaa new-model

!

!

!

aaa session-id common

!

resource policy

!

ip subnet-zero

no ip source-route

ip gratuitous-arps

ip tcp selective-ack

ip tcp path-mtu-discovery

!

!

ip cef

!

!

!

track 10 rtr 1 reachability

!

track 20 rtr 2 reachability

!

class-map match-all cit-pref-cmap-egress

match access-group 182

!

!

policy-map vti-pmap

class class-default

shape average 512000

policy-map cit-pmap-egress

class cit-pref-cmap-egress

bandwidth percent 85

class class-default

fair-queue

!

!

crypto logging session

!

crypto isakmp policy 1

encr aes 256

authentication pre-share

group 5

crypto isakmp key

crypto isakmp keepalive 10

!

!

crypto ipsec transform-set

!

crypto ipsec profile vti

set transform-set sfscitrt2-tset

!

!

!

!

interface Tunnel101

bandwidth 512000

ip address XXXXX

ip nat inside

ip virtual-reassembly

ip ospf network point-to-point

tunnel source this router

tunnel destination distant end ip

service-policy output vti-pmap

!

interface Null0

no ip unreachables

!

interface Loopback0

ip address XXXX

ntp disable

!

interface FastEthernet0/0

ip address XXXX

ip access-group SFSHOSTS in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip rip send version 2

ip rip receive version 2

ip virtual-reassembly

no ip mroute-cache

duplex full

speed 100

ntp disable

no cdp enable

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 1536

ip address XXXXX

encapsulation frame-relay

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

frame-relay traffic-shaping

frame-relay map ip distant end IP 121 broadcast

frame-relay lmi-type cisco

!

interface BRI0/1/0

no ip address

shutdown

!

router ospf 1

router-id XXXX

log-adjacency-changes

summary-address

summary-address

summary-address

summary-address

redistribute connected subnets route-map redis-connected

redistribute static metric 5 subnets route-map redis-static

redistribute rip metric 5 subnets route-map redist-from-citi

passive-interface default

no passive-interface Tunnel101

network XXXX area 2

!

router rip

version 2

redistribute static metric 5 route-map announce-to-citi-rmap

passive-interface default

no passive-interface FastEthernet0/0

network XXXX

distribute-list announce-to-citi-list out

distribute-list citi-cep-routes in

distance 75

no auto-summary

!

ip classless

!

!

!

map-class frame-relay 256/128

frame-relay cir 256000

frame-relay bc 32000

frame-relay mincir 128000

frame-relay adaptive-shaping becn

!

map-class frame-relay cit-fr-cmap

frame-relay cir 1536000

frame-relay bc 192000

frame-relay mincir 768000

frame-relay adaptive-shaping becn

no cdp run

!

route-map redist-from-citi permit 10

match ip address citi-cep-routes

!

route-map redis-connected permit 10

match ip address 31

!

route-map announce-to-citi-rmap permit 10

match ip address announce-to-citi-list

!

route-map redis-static permit 10

match ip address 32

!

!

!

!

control-plane

!

!

!

!

!

!

end

Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

I don't see any subinterfaces and I don't see what circuit you want to allocate the bandwidth.

What I need for you is a breakdown on how you want to divide the T1 per DLCI.

Community Member

Re: Frame Relay traffic shaping

Sorry this is the distant end all the subinterfaces are at my end(NEAR End)

The config is a lot longer so it will take a few

Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

You have shaping enabled on this router but you have not applied any policy to it. Was that your intention ?

__

Edison.

Community Member

Re: Frame Relay traffic shaping

Not sure as I didn't configure this router but I think if I enable shaping on both ends and install the correct policy then I think I would be limit this PVC to 1 meg. All I really did was take the existing policy and chaged 1536000 to 1000000:

map-class frame-relay cit-fr-cmap

frame-relay cir 1000000

frame-relay bc 192000

frame-relay mincir 768000

frame-relay adaptive-shaping becn

Hall of Fame Super Bronze

Re: Frame Relay traffic shaping

Right, currently the router is shaping to 56kbps.

You can verify with the command show frame pvc [dlci]

Community Member

Re: Frame Relay traffic shaping

Ok I know what I need to do now thanks for knocking off the cob webs I will give it a shot this weekend and we will see what happens. thank you for your help!!!!!

189
Views
5
Helpful
12
Replies
CreatePlease to create content