Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame Relay with Hub and Spoke

Hi there,

I have the attached design.

I want to configure the Frame Relay Hub and Spoke.

Do you have any advice on configuration??

Multipoint, Point-to-point, subinterfaces...!!!

kindly advice

regards

fady

8 REPLIES

Re: Frame Relay with Hub and Spoke

you have not given number of DLCI information...and i think you want to go for MULIPOINT ...as you have all your spokes in same subnet...so tell me how many DLCI do you have...

regards

Devang

Hall of Fame Super Silver

Re: Frame Relay with Hub and Spoke

If all the spokes are in the same subnet then it certainly points at a multipoint implementation. For hub and spoke Frame Relay the use of point to point subinterfaces is usually the preferred practice. Unless there is some particular reason to implement multipoint I would suggest that point to point is the better way to go.

HTH

Rick

Re: Frame Relay with Hub and Spoke

hi rick,,,

if we want to go for the point to point then we need to put all spoke in different subnet... right...but as per the diagram all spokes are in the same subnet then we are having point to multipoint configuration right and here he had not given the dlci...i think here we need to have the 12 DLCI as there are 6 spoke and one hub for partial mesh...right...

waiting for reply

regards

Devang

Hall of Fame Super Silver

Re: Frame Relay with Hub and Spoke

Devang

Fady posted the drawing and asked if we had advice. My advice is that if he is committed to having all spokes in the same subnet that this implies that it must be a point to multipoint implementations. But that if he was looking for a best practices suggestion that the best practice for Frame Relay Hub and Spoke is to configure point to point subinterfaces (with each spoke in a different subnet).

That is my advice.

HTH

Rick

Re: Frame Relay with Hub and Spoke

thank you rick for your reply...

now one more thing will you explain me why point to point is more preferable over the multipoint?

regards

Devang

Gold

Re: Frame Relay with Hub and Spoke

Devang

The short answer is that multipoint has a lot of hidden things that will bite you. Point-point subinterfaces are just simpler in the long run to configure.

I started to place a longer explination here but it got too long so I will point out the 2 major issues and you can try it in a lab environment.

1. On each spoke you must manually map the other spokes ip to the dlci since frame inarp only will give you the hub

2. Split horizon on the hub will prevent broadcast from being sent out the same interface it was received. Routing protocols and multicast have issues

New Member

Re: Frame Relay with Hub and Spoke

Hi Guys,

Actually i've put the Spokes in the same subnet sinc e i was reading a lot of deigns and recommendation and i'm a bit confused.

Actually i can get as many DLCIs as i want, it's flexible.

I want to implement the best practice, if it's point-to-point and i need to have each spoke/Sub-interface in a different subnet i'll do it, but is there any reason for that????

If i want to use subinterface that means i'll have:

Router3825(config)# interface s0/0

Router3825(config-if)# encapsulation frame-relay

Router3825(config-if)# frame-relay lmi-type auto

Router3825(config-if)#no shut

Router3825(config)#interface s0/0.140 point-to-point

Router3825(config-if)#ip address 10.170.4.254 255.255.255.252

Router3825(config-if)#frame-relay interface-dlci 140

Router3825(config)#interface s0/0.150 point-to-point

Router3825(config-if)# ip address 10.170.4.254 255.255.255.252

Router3825(config-if)#frame-relay interface-dlci 150

Router1751Accra(config)# Interface s0/0

Router1751Accra(config)# encapsulation frame-relay

Router1751Accra(config)# frame-relay lmi-type auto

Router1751Accra(config)# interface s0/0.40 point-to-point

Router1751Accra(config-if)# ip address 10.170.4.253 255.255.255.252

Router1751Accra(config-if)#frame-relay interface-dlci 40

Router1751Okai(config)#interface s0/0

Router1751Okai(config)#encap. frma-relay

Router1751Okai(config)#frame-relay lmi-type auto

Router1751Okai(config)# interface s0/0.50 point-to-point

Router1751Okai(config-if)# ip address 10.170.5.253 255.255.255.252

Router1751Okai(config-if)#frame-relay interface-dlci 50

This is from the Frame Relay prespective.

I was also confused about the Routing Protocol, since i have a PIX Firewall, should i use OSPF or i should stick into Static routes, or maybe EIGRP and then redistribute the routes into PIX....etc???

also i need an advice.

Thank you for your cooperation

Fady

Re: Frame Relay with Hub and Spoke

Router3825(config)#interface s0/0.140 point-to-point

Router3825(config-if)#ip address 10.170.4.254 255.255.255.252

Router3825(config-if)#frame-relay interface-dlci 140

Router3825(config)#interface s0/0.150 point-to-point

Router3825(config-if)# ip address 10.170.4.254 255.255.255.252

Router3825(config-if)#frame-relay interface-dlci 150

in above configuration you have configure 10.170.4.254 ip addresses on both the sub interface so there should be change make it correct...and now you are using the FR point to point configuration...and as per your visio diagram you are having stub type of environment on spoke router so i will suggess you to use the EIGRP with stub at spoke router but still wait for the other reply...

hope this will helps you

rate this post if it helps

regards

Devang

284
Views
0
Helpful
8
Replies
CreatePlease login to create content