Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame Relay

Dear All,

I have configured a cisco router to work as a Frame Relay switch. I have two serial ports connected to 2 routers.

I find these serial interface on my routers going up and down. Below are my config

FR

================

!

interface Serial0/0

no ip address

encapsulation frame-relay

clock rate 64000

frame-relay intf-type dce

frame-relay route 102 interface Serial0/1 201

!        

interface Serial0/1

no ip address

encapsulation frame-relay

clock rate 64000

frame-relay intf-type dce

frame-relay route 201 interface Serial0/0 102

=======================

R1

=========================

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.1 multipoint

ip address 192.168.1.1 255.255.255.0

frame-relay map ip 192.168.1.2 102 broadcast

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

network 172.16.16.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

neighbor 192.168.1.2

!

======================================

R2

=====================

!

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.2 multipoint

ip address 192.168.1.2 255.255.255.0

frame-relay map ip 192.168.1.1 201 broadcast

!

router ospf 10

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 2

  network 192.168.1.0 0.0.0.255 area 0

neighbor 192.168.1.1

on FR

=============

Router#

*Mar  1 00:37:55.155: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down

*Mar  1 00:38:55.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar  1 00:41:17.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

*Mar  1 00:41:35.275: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down

Any reason why it is doing so? Am I missing any config?

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Frame Relay

by default inverse ARP enabled on the interface and all dlcis linked to physical interface.

you didn't disable inverse arp on physical interfaces then did frame map statements on your multipoint subinterfaces so you linked the dlcis to the subinterfaces and did a static mapping altogether but you surely had a dynamic mapping for the physical interface already in place which was messing things up.

If you give the output of the show frame map, show frame pvc before you disable inv arp and after I think we should see the difference and tell exactly what happened

Don't forget to rate helpful posts.
11 REPLIES
Purple

Re: Frame Relay

on Frame-relay switch you forgot gobal config command: frame-relay switching.

Don't forget to rate helpful posts.
New Member

Re: Frame Relay

hi cadetalain,

I already have it in my config.

Still does not work. Please let me know if you need any further information.

Thanks in advance

Ravi

Purple

Re: Frame Relay

do a show controllers  for each interface on FR and routers to be sure the clocking is on the DCE side.

Don't forget to rate helpful posts.

Re: Frame Relay

Ravindra,

Try adding "frame-relay lmi-type ansi" under the serial interfaces of your FR switch.

HTH

New Member

Re: Frame Relay

Hi cadetalain/HTH,

Sh controllers s0/0 on FR and R1 made sure that the clock rate is working on fr switch only.

Tried LMI type ANSI....still same result  :-(

Solution is tightly required and appreciated.

Thanks

Ravi

Cisco Employee

Re: Frame Relay

Try to add frame-relay interface dlci 201/102 in both of the routers (you might check sh frame-relay pvc to see which dlci is showing up). If you have only one pvc, you do not need subinterfaces I guess, but that wouldn't cause a problem.

The thing is as far as you use subinterfaces, you have to tell the router which sub if is using which PVC.

Otherwise, try running debug frame pvc/lmi.

New Member

Re: Frame Relay

Hi,

no frame-relay inverse-arp  helped me in resolving the issue. 

I have no dynamic dlci. can anybody explain me why it resolved the issue.

I appreciate you time.

Thanks
Ravi

Purple

Re: Frame Relay

ok so do a no frame-relay lmi ansi and let cisco lmi autosense work.

Can you post the output of the following show commands:

on your switch: sh frame route and show int serial

on your routers: sh ip int br ,sh int serial , sh frame lmi, sh frame map and sh frame pvc.

Don't forget to rate helpful posts.
New Member

Re: Frame Relay

Hi,

no frame-relay inverse-arp  helped me in resolving the issue. 

I have no dynamic dlci. can anybody explain me why it resolved the issue.

I appreciate you time.

Thanks
Ravi

Purple

Re: Frame Relay

by default inverse ARP enabled on the interface and all dlcis linked to physical interface.

you didn't disable inverse arp on physical interfaces then did frame map statements on your multipoint subinterfaces so you linked the dlcis to the subinterfaces and did a static mapping altogether but you surely had a dynamic mapping for the physical interface already in place which was messing things up.

If you give the output of the show frame map, show frame pvc before you disable inv arp and after I think we should see the difference and tell exactly what happened

Don't forget to rate helpful posts.
New Member

Re: Frame Relay

that makes sense !

let me take this further.

Thank

Ravi

325
Views
0
Helpful
11
Replies
CreatePlease login to create content