Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FTP Upload Problem with 837 Router

Hi I have a 837 ADSL Router and site to site VPN is configured with VPN Concentrator, also we are using inter net from the same line, the problem is i have ftp clinet which upload data in to my head office over VPN, when i transfer small size of data it works like 10 KB ... but when i transfer morethan 100 KB it disconnect after a while.

3 REPLIES

Re: FTP Upload Problem with 837 Router

Your config looks quite allright although I'm always a bit reluctant in using very long ACL's, which you have done here.

I have two tips to aid in troubleshooting:

1: run a debug dialer and make an ftp transfer that causes the line to disconnect. You might get a disconnect cause or some other vital clues

2: try what happens when you deactivate the access-list. there is little risk in running without security for a short while.

Regards,

Leo

VIP Purple

Re: FTP Upload Problem with 837 Router

Hello,

in addition to what Leo says, you might want to try and configure some sort of traffic prioritizing for your FTP traffic. It might just be that large files starve your bandwidth, and you get disconnected because of other traffic.

Try and configure the following on your router:

ip cef

!

class-map match-all FTP

match protocol ftp

!

policy-map FTP_PRIORITY

class FTP

bandwidth percent 50

!

interface Ethernet0

service-policy output FTP_PRIORITY

If your router does not support the 'match protocol ftp' command, use the following config:

class-map match-all FTP

match access-group 112

!

policy-map FTP_PRIORITY

class FTP

bandwidth percent 50

!

interface Ethernet0

service-policy output FTP_PRIORITY

!

access-list 101 permit tcp any any eq 21

Just a thought, but might be worth trying...

Regards,

GP

New Member

Re: FTP Upload Problem with 837 Router

We have only one user browsing internet, i don't think to prioritise traffic....

thanks

119
Views
0
Helpful
3
Replies