Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Getting routes into bgp

Hi all

Just a quick one,  with bgp you can advertise routes using the static command or the network command. If I have say a router with a static route on it and use the redistribute static command, will this work? I tried it today and it didn't work, it only started working when I put the network command in for the network of the fast Ethernet interface that it sits on.

So would I need both ?

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Getting routes into bgp

You can simply point the static route to null0 interface and than redistribute static to BGP

example:

router bgp 1234

no synchronization

bgp log-neighbor-changes

redistribute static

neighbor 172.16.1.1 remote-as 123

no auto-summary

ip route 172.220.0.0 255.255.0.0 null 0

This will redistribute 172.220.0.0 255.255.0.0 to BGP

HTH

1 REPLY
VIP Super Bronze

Getting routes into bgp

You can simply point the static route to null0 interface and than redistribute static to BGP

example:

router bgp 1234

no synchronization

bgp log-neighbor-changes

redistribute static

neighbor 172.16.1.1 remote-as 123

no auto-summary

ip route 172.220.0.0 255.255.0.0 null 0

This will redistribute 172.220.0.0 255.255.0.0 to BGP

HTH

216
Views
0
Helpful
1
Replies
CreatePlease to create content