Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

getting routes into eigrp for my 2 internet routers running bgp

hi all

I have 2 different internet routers on my site going to 2 different providers, we run the full bgp table on the internet routers. whats the best way of getting the routes into my enterprise network eigrp for the internet, i obviously dont want the full table into eigrp, so what is normally done ?

cheers

1 ACCEPTED SOLUTION

Accepted Solutions

getting routes into eigrp for my 2 internet routers running bgp

Carl,

If your edge routers are receiving Default route (along with the complete internet routing table) from each ISP, then you don't need to have a static default route redistribute, instead you can redistribute BGP into EIGRP using a route-map only allowing 0.0.0.0/0 into EIGRP.

** config example to advertise default route using EIGRP:

access-list 50 permit 0.0.0.0 0.0.0.0

access-list 50 deny any (this line is already implicit)

route-map REDISTRIBUTE_BGP permit 10

match ip address 50

router eigrp 100

redistribute bgp 65000 route-map REDISTRIBUTE_BGP metric 1500 1 255 1 1500

where:

1500 - Bandwidth in Kbits per second

1 - Delay metric, in 10 microsecond units

255 - Reliability metric where 255 is 100% reliable

1 - Effective bandwidth metric (Loading) where 255 is 100% loaded

1500 - Maximum Transmission Unit metric of the path

Rest for preferring one ISP over other in EIGRP, you've already got the answer in this thread:

https://supportforums.cisco.com/message/3602676#3602676

If the ISP's are not sending you default route, then you'd have to first configure a static default route in each router and then redistribute it in EIGRP

Hope it clarifies the doubt

Neeraj

5 REPLIES

Re: getting routes into eigrp for my 2 internet routers running

Hi Carl,

Are you using both link simultaneously or primary-backup scenario.

If you are using it in primary-backup scenario, the best way is to advertise the default route toward your LAN network from your internett routers.

If you are using both link simultaneously, then i will advised to terminate both WAN links on single router.

(EDITTED): and then advertise default route towards your LAN.

Regards,

Smitesh

Community Member

Re: getting routes into eigrp for my 2 internet routers running

They are in a in a primary backup scenario, would I just redistribute a static into EIGRP, and change the metric value on the backup conection to higher delay ?

what would I do if I had 2 sites with different providers, would I do the same ?

getting routes into eigrp for my 2 internet routers running bgp

Carl,

If your edge routers are receiving Default route (along with the complete internet routing table) from each ISP, then you don't need to have a static default route redistribute, instead you can redistribute BGP into EIGRP using a route-map only allowing 0.0.0.0/0 into EIGRP.

** config example to advertise default route using EIGRP:

access-list 50 permit 0.0.0.0 0.0.0.0

access-list 50 deny any (this line is already implicit)

route-map REDISTRIBUTE_BGP permit 10

match ip address 50

router eigrp 100

redistribute bgp 65000 route-map REDISTRIBUTE_BGP metric 1500 1 255 1 1500

where:

1500 - Bandwidth in Kbits per second

1 - Delay metric, in 10 microsecond units

255 - Reliability metric where 255 is 100% reliable

1 - Effective bandwidth metric (Loading) where 255 is 100% loaded

1500 - Maximum Transmission Unit metric of the path

Rest for preferring one ISP over other in EIGRP, you've already got the answer in this thread:

https://supportforums.cisco.com/message/3602676#3602676

If the ISP's are not sending you default route, then you'd have to first configure a static default route in each router and then redistribute it in EIGRP

Hope it clarifies the doubt

Neeraj

Community Member

getting routes into eigrp for my 2 internet routers running bgp

connect both the internet routers lan interface into a single router.

configure a static default route to ISP1 with SLA, let the SLA checkconnecticity to internet by ping some address on internet

configure another static route with higher administrative distance and next hop will be ISP2.

ISP1 will be primary, if the SLA fails it will withdraw the route dynamically and vice verse.

when the primary route fail the other will automatically kick in and when the SLA of route 1 is OK it will automatically be installed agian in the routing table as best and the ISP2 route will be removed.

let me know if you have confusions.

Community Member

getting routes into eigrp for my 2 internet routers running bgp

can you please give me an example of the ip sla config?

cheers

415
Views
0
Helpful
5
Replies
CreatePlease to create content