Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

GLBP weighted load-balance

Dear all,

I am trying GLBP for the first time. The customer has 2 gateway routers, and i want to utilize both to load share of corporate traffic. i am trying to use weighted glbp by using a reachability track to a public ip address 8.8.8.8. I have kept the weight same on both routers i.e. 110. The thing is that only router 2 is taking all traffic load and router 1 is sitting idle, but it only takes up load when the other router goes down. This is just like HSRP behaviour, but what i was trying to accomplish, is that along with this the traffic should get distributed as soon as the track goes down on router 2 more towards router 1 and vice versa. Track 5 is same on both routers, I hope this is possible. Could someone kindly help?


Router 1

===================================================
!
interface GigabitEthernet0/1.300
encapsulation dot1Q 300
ip address 10.10.4.3 255.255.255.0
ip nat outside
glbp 5 ip 10.10.4.2
glbp 5 timers 5 18
glbp 5 timers redirect 1800 28800
glbp 5 priority 90
glbp 5 preempt
glbp 5 weighting 110 lower 95 upper 105
glbp 5 load-balancing weighted
glbp 5 weighting track 5 decrement 5
!
interface GigabitEthernet0/2
ip address 192.168.66.16 255.255.255.0
ip nat inside
glbp 10 ip 192.168.66.15
glbp 10 timers 5 18
glbp 10 timers redirect 1800 28800
glbp 10 priority 90
glbp 10 preempt
glbp 10 weighting 110 lower 95 upper 105
glbp 10 load-balancing weighted
glbp 10 weighting track 5 decrement 5
!

ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/1.300
frequency 15
ip sla schedule 1 life forever start-time now

track 5 ip sla 1 reachability
delay down 10 up 20

*************************************************************************

show glbp output

GigabitEthernet0/1.300 - Group 5

  State is Standby

    1 state change, last state change 00:48:32

  Virtual IP address is 10.10.4.2

  Hello time 5 sec, hold time 18 sec

    Next hello sent in 4.672 secs

  Redirect time 1800 sec, forwarder timeout 28800 sec

  Preemption enabled, min delay 0 sec

  Active is 10.10.4.5, priority 120 (expires in 17.312 sec)

  Standby is local

  Priority 90 (configured)

  Weighting 110 (configured 110), thresholds: lower 95, upper 105

    Track object 5 state Up decrement 5

  Load balancing: weighted

  Group members:

    24b6.5753.8551 (10.10.4.3) local

    649e.f32b.86f1 (10.10.4.5)

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Listen

    MAC address is 0007.b400.0501 (learnt)

    Owner ID is 649e.f32b.86f1

    Time to live: 28796.000 sec (maximum 28800 sec)

    Preemption enabled, min delay 30 sec

    Active is 10.10.4.5 (primary), weighting 110 (expires in 14.240 sec)

  Forwarder 2

    State is Active

      1 state change, last state change 00:48:21

    MAC address is 0007.b400.0502 (default)

    Owner ID is 24b6.5753.8551

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

GigabitEthernet0/2 - Group 10

  State is Standby

    1 state change, last state change 00:48:32

  Virtual IP address is 192.168.66.15

  Hello time 5 sec, hold time 18 sec

    Next hello sent in 1.856 secs

  Redirect time 1800 sec, forwarder timeout 28800 sec

  Preemption enabled, min delay 0 sec

  Active is 192.168.66.17, priority 120 (expires in 15.968 sec)

  Standby is local

  Priority 90 (configured)

  Weighting 110 (configured 110), thresholds: lower 95, upper 105

    Track object 5 state Up decrement 5

  Load balancing: weighted

  Group members:

    24b6.5753.8552 (192.168.66.16) local

    649e.f32b.86f2 (192.168.66.17)

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Listen

    MAC address is 0007.b400.0a01 (learnt)

    Owner ID is 649e.f32b.86f2

    Time to live: 28796.736 sec (maximum 28800 sec)

    Preemption enabled, min delay 30 sec

    Active is 192.168.66.17 (primary), weighting 110 (expires in 16.576 sec)

  Forwarder 2

    State is Active

      1 state change, last state change 00:48:20

    MAC address is 0007.b400.0a02 (default)

    Owner ID is 24b6.5753.8552

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

GigabitEthernet0/1.300 - Group 5

  State is Active

    3 state changes, last state change 01:57:01

  Virtual IP address is 10.10.4.2

  Hello time 5 sec, hold time 18 sec

    Next hello sent in 3.616 secs

  Redirect time 1800 sec, forwarder timeout 28800 sec

  Preemption enabled, min delay 0 sec

  Active is local

  Standby is 10.10.4.3, priority 90 (expires in 15.712 sec)

  Priority 120 (configured)

  Weighting 110 (configured 110), thresholds: lower 95, upper 105

    Track object 5 state Up decrement 5

  Load balancing: weighted

  Group members:

    24b6.5753.8551 (10.10.4.3)

    649e.f32b.86f1 (10.10.4.5) local

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Active

      3 state changes, last state change 01:57:02

    MAC address is 0007.b400.0501 (default)

    Owner ID is 649e.f32b.86f1

    Redirection enabled

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

    Client selection count: 77

  Forwarder 2

    State is Listen

      4 state changes, last state change 00:49:59

    MAC address is 0007.b400.0502 (learnt)

    Owner ID is 24b6.5753.8551

    Redirection enabled, 1797.728 sec remaining (maximum 1800 sec)

    Time to live: 28797.728 sec (maximum 28800 sec)

    Preemption enabled, min delay 30 sec

    Active is 10.10.4.3 (primary), weighting 110 (expires in 17.472 sec)

    Client selection count: 57

GigabitEthernet0/2 - Group 10

  State is Active

    5 state changes, last state change 01:57:05

  Virtual IP address is 192.168.66.15

  Hello time 5 sec, hold time 18 sec

    Next hello sent in 3.840 secs

  Redirect time 1800 sec, forwarder timeout 28800 sec

  Preemption enabled, min delay 0 sec

  Active is local

  Standby is 192.168.66.16, priority 90 (expires in 15.488 sec)

  Priority 120 (configured)

  Weighting 110 (configured 110), thresholds: lower 95, upper 105

    Track object 5 state Up decrement 5

  Load balancing: weighted

  Group members:

    24b6.5753.8552 (192.168.66.16)

    649e.f32b.86f2 (192.168.66.17) local

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Active

      5 state changes, last state change 01:57:04

    MAC address is 0007.b400.0a01 (default)

    Owner ID is 649e.f32b.86f2

    Redirection enabled

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

    Client selection count: 2

  Forwarder 2

    State is Listen

      4 state changes, last state change 00:49:58

    MAC address is 0007.b400.0a02 (learnt)

    Owner ID is 24b6.5753.8552

    Redirection enabled, 1797.504 sec remaining (maximum 1800 sec)

    Time to live: 28797.504 sec (maximum 28800 sec)

    Preemption enabled, min delay 30 sec

    Active is 192.168.66.16 (primary), weighting 110 (expires in 15.584 sec)

    Client selection count: 2

GigabitEthernet0/1.300 - Group 5
  State is Standby
    1 state change, last state change 00:48:32
  Virtual IP address is 10.10.4.2
  Hello time 5 sec, hold time 18 sec
    Next hello sent in 4.672 secs
  Redirect time 1800 sec, forwarder timeout 28800 sec
  Preemption enabled, min delay 0 sec
  Active is 10.10.4.5, priority 120 (expires in 17.312 sec)
  Standby is local
  Priority 90 (configured)
  Weighting 110 (configured 110), thresholds: lower 95, upper 105
    Track object 5 state Up decrement 5
  Load balancing: weighted
  Group members:
    24b6.5753.8551 (10.10.4.3) local
    649e.f32b.86f1 (10.10.4.5)
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
    MAC address is 0007.b400.0501 (learnt)
    Owner ID is 649e.f32b.86f1
    Time to live: 28796.000 sec (maximum 28800 sec)
    Preemption enabled, min delay 30 sec
    Active is 10.10.4.5 (primary), weighting 110 (expires in 14.240 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 00:48:21
    MAC address is 0007.b400.0502 (default)
    Owner ID is 24b6.5753.8551
    Preemption enabled, min delay 30 sec
    Active is local, weighting 110
GigabitEthernet0/2 - Group 10
  State is Standby
    1 state change, last state change 00:48:32
  Virtual IP address is 192.168.66.15
  Hello time 5 sec, hold time 18 sec
    Next hello sent in 1.856 secs
  Redirect time 1800 sec, forwarder timeout 28800 sec
  Preemption enabled, min delay 0 sec
  Active is 192.168.66.17, priority 120 (expires in 15.968 sec)
  Standby is local
  Priority 90 (configured)
  Weighting 110 (configured 110), thresholds: lower 95, upper 105
    Track object 5 state Up decrement 5
  Load balancing: weighted
  Group members:
    24b6.5753.8552 (192.168.66.16) local
    649e.f32b.86f2 (192.168.66.17)
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
    MAC address is 0007.b400.0a01 (learnt)
    Owner ID is 649e.f32b.86f2
    Time to live: 28796.736 sec (maximum 28800 sec)
    Preemption enabled, min delay 30 sec
    Active is 192.168.66.17 (primary), weighting 110 (expires in 16.576 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 00:48:20
    MAC address is 0007.b400.0a02 (default)
    Owner ID is 24b6.5753.8552
    Preemption enabled, min delay 30 sec
    Active is local, weighting 110


======================================================================

Router 2
======================================================================

!
interface GigabitEthernet0/1.300
encapsulation dot1Q 300
ip address 10.10.4.5 255.255.255.0
ip nat outside
glbp 5 ip 10.10.4.2
glbp 5 timers 5 18
glbp 5 timers redirect 1800 28800
glbp 5 priority 120
glbp 5 preempt
glbp 5 weighting 110 lower 95 upper 105
glbp 5 load-balancing weighted
glbp 5 weighting track 5 decrement 5
!
interface GigabitEthernet0/2
ip address 192.168.66.17 255.255.255.0
ip nat inside
glbp 10 ip 192.168.66.15
glbp 10 timers 5 18
glbp 10 timers redirect 1800 28800
glbp 10 priority 120
glbp 10 preempt
glbp 10 weighting 110 lower 95 upper 105
glbp 10 load-balancing weighted
glbp 10 weighting track 5 decrement 5
!

ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/1.300
frequency 15
ip sla schedule 1 life forever start-time now

track 5 ip sla 1 reachability
delay down 10 up 20

*************************************************************************

show glbp output

GigabitEthernet0/1.300 - Group 5
  State is Active
    3 state changes, last state change 01:57:01
  Virtual IP address is 10.10.4.2
  Hello time 5 sec, hold time 18 sec
    Next hello sent in 3.616 secs
  Redirect time 1800 sec, forwarder timeout 28800 sec
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 10.10.4.3, priority 90 (expires in 15.712 sec)
  Priority 120 (configured)
  Weighting 110 (configured 110), thresholds: lower 95, upper 105
    Track object 5 state Up decrement 5
  Load balancing: weighted
  Group members:
    24b6.5753.8551 (10.10.4.3)
    649e.f32b.86f1 (10.10.4.5) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      3 state changes, last state change 01:57:02
    MAC address is 0007.b400.0501 (default)
    Owner ID is 649e.f32b.86f1
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 110
    Client selection count: 77
  Forwarder 2
    State is Listen
      4 state changes, last state change 00:49:59
    MAC address is 0007.b400.0502 (learnt)
    Owner ID is 24b6.5753.8551
    Redirection enabled, 1797.728 sec remaining (maximum 1800 sec)
    Time to live: 28797.728 sec (maximum 28800 sec)
    Preemption enabled, min delay 30 sec
    Active is 10.10.4.3 (primary), weighting 110 (expires in 17.472 sec)
    Client selection count: 57
GigabitEthernet0/2 - Group 10
  State is Active
    5 state changes, last state change 01:57:05
  Virtual IP address is 192.168.66.15
  Hello time 5 sec, hold time 18 sec
    Next hello sent in 3.840 secs
  Redirect time 1800 sec, forwarder timeout 28800 sec
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 192.168.66.16, priority 90 (expires in 15.488 sec)
  Priority 120 (configured)
  Weighting 110 (configured 110), thresholds: lower 95, upper 105
    Track object 5 state Up decrement 5
  Load balancing: weighted
  Group members:
    24b6.5753.8552 (192.168.66.16)
    649e.f32b.86f2 (192.168.66.17) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      5 state changes, last state change 01:57:04
    MAC address is 0007.b400.0a01 (default)
    Owner ID is 649e.f32b.86f2
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 110
    Client selection count: 2
  Forwarder 2
    State is Listen
      4 state changes, last state change 00:49:58
    MAC address is 0007.b400.0a02 (learnt)
    Owner ID is 24b6.5753.8552
    Redirection enabled, 1797.504 sec remaining (maximum 1800 sec)
    Time to live: 28797.504 sec (maximum 28800 sec)
    Preemption enabled, min delay 30 sec
    Active is 192.168.66.16 (primary), weighting 110 (expires in 15.584 sec)
    Client selection count: 2

393
Views
0
Helpful
0
Replies
CreatePlease to create content