Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

GPRS Problem with Cisco3640

We are facing a problem while connecting Siemens MC35 GPRS modem to Cisco3640 router through Serial A/S interface the problem is that the chat-script can not start with the modem

Here is the output error followed by the configurations:

‘NOTE The same configurations & the same router working with another modem’

Dial on demand events debugging is on

Router#

Router#

Router#ping 100.100.100.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.100.100.10, timeout is 2 seconds:

*Mar 1 00:58:52.083: Se2/0 DDR: rotor dialout [best] least recent failure is also most recent failure

*Mar 1 00:58:52.083: Se2/0 DDR: rotor dialout [best] also has most recent failure

*Mar 1 00:58:52.083: Se2/0 DDR: rotor dialout [best]

*Mar 1 00:58:52.083: Se2/0 DDR: Dialing cause ip (s=10.7.15.129, d=10.7.15.210)

*Mar 1 00:58:52.083: Se2/0 DDR: Attempting to dial *99***1#

*Mar 1 00:58:52.083: CHAT65: Attempting async line dialer script

*Mar 1 00:58:52.083: CHAT65: Dialing using Modem script: tmobile & System script: none

*Mar 1 00:58:52.083: CHAT65: process started

*Mar 1 00:58:52.139: CHAT65: Asserting DTR

*Mar 1 00:58:52.139: CHAT65: Chat script tmobile started...

*Mar 1 00:58:57.187: CHAT65: Chat script tmobile finished, status = Connection timed out; remote host not responding

*Mar 1 00:58:57.187: Se2/0 DDR: disconnecting call

*Mar 1 00:58:58.083: Di1: No free dialer - starting fast idle timer.

*Mar 1 00:59:00.083: Di1: No free dialer - starting fast idle timer.

Success rate is 0 percent (0/5)

chat-script tmobile "" "AT" TIMEOUT 5 OK "AT+CBST=12,0,1" TIMEOUT 5 OK AT+CGDCONT=,,"mobinilbank005" TIMEOUT 5 OK "ATD*99***1#" TIMEOUT 20 CONNECT

interface Tunnel13

ip address 172.16.104.2 255.255.255.252

tunnel source 10.7.15.129

tunnel destination 10.7.15.210

interface Serial2/0

physical-layer async

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

async mode dedicated

no peer default ip address

no fair-queue

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string "*99***1#"

dialer-group 1

no cdp enable

no ppp lcp fast-start

line 65

exec-timeout 0 0

no flush-at-activation

script dialer tmobile

modem InOut

modem autoconfigure type default

no exec

transport input all

stopbits 1

3 REPLIES
VIP Purple

Re: GPRS Problem with Cisco3640

Hello,

it looks like your router is not communicating with the modem. Do you have any LED activity at all on the modem ? I think GPRS modems are not able to detect dial tones, so the AT+iXRC=0 string might need to be added. You also might want to try and reset the modem (to factory defaults, if possible, with the AT&F command)...

Regards,

GP

Re: GPRS Problem with Cisco3640

After using AT+iXRC=0 in the modem i got the output error.

AT+iXRC=0

ERROR

please advice.

Best Regards,

Mounir Mohamed

VIP Purple

Re: GPRS Problem with Cisco3640

Hello Mounir,

where did you get the chat-script from ?

Do you have physical connectivity between your router and your GRPS modem ?

Regards,

GP

92
Views
0
Helpful
3
Replies