Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

GRE issue ; Tunnel up/down on one side and up/up on the other side

Hello Gents,

We have an issue with a very basic GRE configuration ; GRE Tunnel is up/up on one side but up/down on the other side.

It's possible to ping tunnel destination from each side, but the tunnel doesn't come up.

Here are router configs :

R1 (Cisco 3945E Version 15.2(4)M4)

interface Loopback3

ip address 10.10.112.97 255.255.255.252

!

interface Tunnel50

ip address 192.168.255.234 255.255.255.252

tunnel source Loopback3

tunnel destination 10.10.108.57

R1#ping 10.10.108.57 source loopback 3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.108.57, timeout is 2 seconds:

Packet sent with a source address of 10.10.112.97

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 96/110/168 ms

R1#sh int tunnel 50

Tunnel50 is up, line protocol is down

  Hardware is Tunnel

  Internet address is 192.168.255.234/30

  MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation TUNNEL, loopback not set

  Keepalive not set

  Tunnel source 10.10.112.97 (Loopback3), destination 10.10.108.57

   Tunnel Subblocks:

      src-track:

         Tunnel50 source tracking subblock associated with Loopback3

          Set of tunnels with source Loopback3, 3 members (includes iterators), on interface <OK>

  Tunnel protocol/transport GRE/IP

    Key disabled, sequencing disabled

    Checksumming of packets disabled

  Tunnel TTL 255, Fast tunneling enabled

  Path MTU Discovery, ager 10 mins, min MTU 92

  Tunnel transport MTU 1476 bytes

  Tunnel transmit bandwidth 8000 (kbps)

  Tunnel receive bandwidth 8000 (kbps)

  Last input 00:01:23, output 00:01:37, output hang never

  Last clearing of "show interface" counters 02:00:10

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     360 packets input, 21764 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     298 packets output, 14304 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

R2 (Cisco 3745 Version 12.4(7))

interface Loopback1

ip address 10.10.108.57 255.255.255.255

end

!

interface Tunnel50

ip address 192.168.255.233 255.255.255.252

tunnel source Loopback1

tunnel destination 10.10.112.97

!

R2#ping 10.10.112.97 source loopback 1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.112.97, timeout is 2 seconds:

Packet sent with a source address of 10.10.108.57

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 92/96/104 ms

R2#sh int tunnel 50

Tunnel50 is up, line protocol is up

  Hardware is Tunnel

  Internet address is 192.168.255.233/30

  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation TUNNEL, loopback not set

  Keepalive not set

  Tunnel source 10.10.108.57 (Loopback1), destination 10.10.112.97

  Tunnel protocol/transport GRE/IP

    Key disabled, sequencing disabled

    Checksumming of packets disabled

  Tunnel TTL 255

  Fast tunneling enabled

  Tunnel transmit bandwidth 8000 (kbps)

  Tunnel receive bandwidth 8000 (kbps)

  Last input 00:16:02, output 00:04:58, output hang never

  Last clearing of "show interface" counters 00:32:16

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     298 packets input, 14304 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     301 packets output, 14448 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

------------------------------------------------------------------------------

For information, routing is all static.

I tried to activate keepalive and i can see that they are correctly received on each side but tunnel on R1 was still line protocol down; so i removed it.

Jan 15 17:32:28: Tunnel50: sending keepalive, 10.10.112.97->10.10.108.57 (len=24 ttl=255), counter=1
Jan 15 17:32:28: Tunnel50: keepalive received, 10.10.112.97->10.10.108.57 (len=24 ttl=244), resetting counter

I have also checked on bug tool search but i couldn't find any bug related to our issue.

If you add any advice, it will be very appreciated ; ) !

Best Regards,

Adrien

Everyone's tags (1)
1 REPLY

Re: GRE issue ; Tunnel up/down on one side and up/up on the othe

Hello

Tunnel MTU values are different, On Each tunnel

Int tun xxx
ip tcp-adjust mss 1476


Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
3173
Views
0
Helpful
1
Replies
CreatePlease to create content